summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-04-19 15:23:10 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-04-25 15:13:50 +0100
commit781ac476e24cf4f613da41e2013444fb23442fb8 (patch)
tree92d176db4a8353daadec5235d41daced49c5e546 /net-p2p
parentnet-p2p/c-lightning: version bump (diff)
downloadportage-781ac476e24cf4f613da41e2013444fb23442fb8.tar.xz
net-p2p/kovri: version bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch99
-rw-r--r--net-p2p/kovri/kovri-0.2.0_rc1.ebuild (renamed from net-p2p/kovri/kovri-0.1.0_alpha.ebuild)10
2 files changed, 106 insertions, 3 deletions
diff --git a/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch b/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..118f5987
--- /dev/null
+++ b/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,99 @@
+From daf5e950a459194104ca01ee4dd63bbe81ef26b5 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Wed, 26 Sep 2018 00:46:42 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+---
+ deps/CMakeLists.txt | 62 +------------------------------
+ src/core/router/transports/upnp.h | 8 ++--
+ 2 files changed, 6 insertions(+), 64 deletions(-)
+
+diff --git a/deps/CMakeLists.txt b/deps/CMakeLists.txt
+index 835cafc7763a..fab217288b27 100644
+--- a/deps/CMakeLists.txt
++++ b/deps/CMakeLists.txt
+@@ -31,63 +31,5 @@
+ find_package(Miniupnpc REQUIRED)
+ add_library(libminiupnpc INTERFACE)
+
+-# In addition to allowing optional local building of miniupnpc, the following will require that
+-# the build is built locally if a system package only provides a shared library (like on Arch)
+-# even though we have chosen to build statically. NOTE: do *not* distribute a local dynamic-build
+-# when building in-tree dynamic (must build statically).
+-if (NOT MINIUPNP_INCLUDE_DIR OR NOT MINIUPNP_LIBRARY)
+- set(BUILD_MINIUPNPC ON)
+-endif()
+-
+-if (BUILD_MINIUPNPC)
+- if (NOT WITH_STATIC)
+- set(UPNPC_BUILD_STATIC OFF CACHE BOOL "Disable static lib target" FORCE)
+- set(UPNPC_BUILD_SHARED ON CACHE BOOL "Enable shared lib target" FORCE)
+- endif()
+-
+- if (MINIUPNP_FOUND)
+- message(WARNING "Ignoring system miniupnpc, forcing a local build")
+- endif()
+-
+- message(STATUS "Using " ${CMAKE_CURRENT_SOURCE_DIR}/miniupnp/miniupnpc)
+- add_subdirectory(miniupnp/miniupnpc)
+-
+- if (NOT WITH_STATIC)
+- set(MINIUPNPC_TARGET libminiupnpc-shared)
+- else()
+- set(MINIUPNPC_TARGET libminiupnpc-static)
+- endif()
+-
+- set(MINIUPNPC_FLAGS "")
+- if(MSVC)
+- list(APPEND MINIUPNPC_FLAGS "-wd4244 -wd4267")
+- elseif(NOT MSVC)
+- list(APPEND MINIUPNPC_FLAGS "-Wno-undef -Wno-unused-result -Wno-unused-value")
+- endif()
+- if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+- list(APPEND MINIUPNPC_FLAGS "-D_NETBSD_SOURCE")
+- endif()
+-
+- string(REPLACE ";" " " MINIUPNPC_FLAGS "${MINIUPNPC_FLAGS}" )
+- set_property(TARGET ${MINIUPNPC_TARGET} APPEND_STRING PROPERTY COMPILE_FLAGS "${MINIUPNPC_FLAGS}")
+- set_property(TARGET ${MINIUPNPC_TARGET} PROPERTY FOLDER "deps")
+-
+- if (WITH_STATIC)
+- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
+- INTERFACE_COMPILE_DEFINITIONS MINIUPNP_STATICLIB)
+- endif()
+-
+- # Use #include <miniupnp/miniupnpc/miniupnpc.h>
+- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
+- INTERFACE_INCLUDE_DIRECTORIES $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>)
+-
+- # Suppress warnings from miniupnpc headers
+- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
+- INTERFACE_SYSTEM_INCLUDE_DIRECTORIES $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>)
+-
+- target_link_libraries(libminiupnpc INTERFACE ${MINIUPNPC_TARGET})
+- set(MINIUPNPC_BUILT ON PARENT_SCOPE) # TODO(unassigned): HACK for install
+-else()
+- target_include_directories(libminiupnpc INTERFACE ${MINIUPNP_INCLUDE_DIR})
+- target_link_libraries(libminiupnpc INTERFACE ${MINIUPNP_LIBRARY})
+-endif()
++target_include_directories(libminiupnpc INTERFACE ${MINIUPNP_INCLUDE_DIR})
++target_link_libraries(libminiupnpc INTERFACE ${MINIUPNP_LIBRARY})
+diff --git a/src/core/router/transports/upnp.h b/src/core/router/transports/upnp.h
+index 0390dca93f23..a2430ca3e67b 100644
+--- a/src/core/router/transports/upnp.h
++++ b/src/core/router/transports/upnp.h
+@@ -35,10 +35,10 @@
+
+ #include <boost/asio.hpp>
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/miniwget.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/miniwget.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #include <memory>
+ #include <string>
diff --git a/net-p2p/kovri/kovri-0.1.0_alpha.ebuild b/net-p2p/kovri/kovri-0.2.0_rc1.ebuild
index 7a7f9556..de4e77c5 100644
--- a/net-p2p/kovri/kovri-0.1.0_alpha.ebuild
+++ b/net-p2p/kovri/kovri-0.2.0_rc1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit git-r3 toolchain-funcs python-r1 bash-completion-r1
DESCRIPTION="Free, decentralized, anonymity technology based on I2P's open specifications"
@@ -12,7 +12,7 @@ EGIT_COMMIT="v${PV/_/-}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE="doc python"
RDEPEND="dev-libs/openssl:0
@@ -28,6 +28,10 @@ DEPEND=">=sys-devel/clang-3.5
)
${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch"
+)
+
src_prepare () {
export AR=$(tc-getAR)
export RANLIB=$(tc-getRANLIB)