summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-06-15 03:27:37 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-06-15 21:15:48 +0100
commit1a019990de01f21fc2d51692155ed72728ddf0e3 (patch)
tree0f81cbc4966b563478df45f6749cc22dc6d63ace /net-p2p/monero/files
parentprofiles/raspberry-pi: add keyword for app-misc/jq (diff)
downloadportage-1a019990de01f21fc2d51692155ed72728ddf0e3.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'net-p2p/monero/files')
-rw-r--r--net-p2p/monero/files/0.14.1.0-Do-not-install-trezor-dep-libs.patch25
-rw-r--r--net-p2p/monero/files/0.14.1.0-Drop-in-tree-miniupnpc.patch57
-rw-r--r--net-p2p/monero/files/0.14.1.0-Use-gentoo-versioning.patch38
3 files changed, 120 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.14.1.0-Do-not-install-trezor-dep-libs.patch b/net-p2p/monero/files/0.14.1.0-Do-not-install-trezor-dep-libs.patch
new file mode 100644
index 00000000..9525a2f6
--- /dev/null
+++ b/net-p2p/monero/files/0.14.1.0-Do-not-install-trezor-dep-libs.patch
@@ -0,0 +1,25 @@
+From 29277ef1a899be4f71d97d3df0909b561299edb7 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 15 Jun 2019 00:57:09 +0100
+Subject: [PATCH] Do not install trezor dep libs
+
+---
+ src/wallet/CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
+index d0fc21f51175..6d8f5e4cb3a7 100644
+--- a/src/wallet/CMakeLists.txt
++++ b/src/wallet/CMakeLists.txt
+@@ -142,11 +142,7 @@ if (BUILD_GUI_DEPS)
+ install(TARGETS wallet_merged
+ ARCHIVE DESTINATION ${lib_folder})
+
+- install(FILES ${TREZOR_DEP_LIBS}
+- DESTINATION ${lib_folder})
+ file(WRITE "trezor_link_flags.txt" ${TREZOR_DEP_LINKER})
+- install(FILES "trezor_link_flags.txt"
+- DESTINATION ${lib_folder})
+ endif()
+
+ add_subdirectory(api)
diff --git a/net-p2p/monero/files/0.14.1.0-Drop-in-tree-miniupnpc.patch b/net-p2p/monero/files/0.14.1.0-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..23fafa98
--- /dev/null
+++ b/net-p2p/monero/files/0.14.1.0-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,57 @@
+From defc40037d89c32c9763e660af1b5a9260f43867 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 17 Jun 2018 22:34:11 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+Since 6b8539803184 ("Build: update CMake and p2p for in-tree
+miniupnp"), a hard dependency is made on miniupnpc which is a git
+submodule not part of the archive available upstream.
+---
+ external/CMakeLists.txt | 16 +++-------------
+ src/p2p/net_node.inl | 6 +++---
+ 2 files changed, 6 insertions(+), 16 deletions(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index bc4344b34833..10189ce3a2fb 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -37,19 +37,9 @@
+
+ find_package(Miniupnpc REQUIRED)
+
+-message(STATUS "Using in-tree miniupnpc")
+-add_subdirectory(miniupnp/miniupnpc)
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
+-if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
+-endif()
+-
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++set(UPNP_STATIC false PARENT_SCOPE)
++set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index ba29d92c9144..e9f62ad1717b 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -60,9 +60,9 @@
+ #include "cryptonote_core/cryptonote_core.h"
+ #include "net/parse.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
diff --git a/net-p2p/monero/files/0.14.1.0-Use-gentoo-versioning.patch b/net-p2p/monero/files/0.14.1.0-Use-gentoo-versioning.patch
new file mode 100644
index 00000000..b1f11ec7
--- /dev/null
+++ b/net-p2p/monero/files/0.14.1.0-Use-gentoo-versioning.patch
@@ -0,0 +1,38 @@
+From 777b5fb5c1128b54a008b47bd637cb93fe1253b4 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 15 Jun 2019 00:15:54 +0100
+Subject: [PATCH] Use gentoo versioning
+
+---
+ cmake/Version.cmake | 19 ++-----------------
+ 1 file changed, 2 insertions(+), 17 deletions(-)
+
+diff --git a/cmake/Version.cmake b/cmake/Version.cmake
+index 632c1431c953..5aaa404b9f6f 100644
+--- a/cmake/Version.cmake
++++ b/cmake/Version.cmake
+@@ -31,22 +31,7 @@ function (write_static_version_header hash)
+ configure_file("${CMAKE_SOURCE_DIR}/src/version.cpp.in" "${CMAKE_BINARY_DIR}/version.cpp")
+ endfunction ()
+
+-find_package(Git QUIET)
+-if ("$Format:$" STREQUAL "")
+- # We're in a tarball; use hard-coded variables.
+- write_static_version_header("release")
+-elseif (GIT_FOUND OR Git_FOUND)
+- message(STATUS "Found Git: ${GIT_EXECUTABLE}")
+- add_custom_command(
+- OUTPUT "${CMAKE_BINARY_DIR}/version.cpp"
+- COMMAND "${CMAKE_COMMAND}"
+- "-D" "GIT=${GIT_EXECUTABLE}"
+- "-D" "TO=${CMAKE_BINARY_DIR}/version.cpp"
+- "-P" "cmake/GenVersion.cmake"
+- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}")
+-else()
+- message(STATUS "WARNING: Git was not found!")
+- write_static_version_header("unknown")
+-endif ()
++write_static_version_header("release")
++
+ add_custom_target(genversion ALL
+ DEPENDS "${CMAKE_BINARY_DIR}/version.cpp")