summaryrefslogtreecommitdiff
path: root/net-p2p/c-lightning
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-10-29 23:21:36 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-10-29 23:21:36 +0000
commitf675c89fc1e8c181acd7ad04155476f22a20d35c (patch)
treee6ff8289d829d81befdaa18caad167f2d60d2378 /net-p2p/c-lightning
parentfactory-default: add app-admin/syslog-ng-3.23.1 (diff)
downloadportage-f675c89fc1e8c181acd7ad04155476f22a20d35c.tar.xz
net-p2p/c-lightning: Version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Diffstat (limited to 'net-p2p/c-lightning')
-rw-r--r--net-p2p/c-lightning/c-lightning-0.7.0.ebuild72
-rw-r--r--net-p2p/c-lightning/c-lightning-0.7.3.ebuild (renamed from net-p2p/c-lightning/c-lightning-0.7.1.ebuild)14
-rw-r--r--net-p2p/c-lightning/files/0.7.0-build-do-not-Werror.patch36
-rw-r--r--net-p2p/c-lightning/files/0.7.0-build-do-not-refresh-external-modules.patch22
-rw-r--r--net-p2p/c-lightning/files/0.7.0-build-use-FHS-docdir.patch22
-rw-r--r--net-p2p/c-lightning/files/0.7.1-build-remove-deprecated-AM_ENABLE_MULTILIB.patch25
-rw-r--r--net-p2p/c-lightning/files/0.7.3-build-do-not-Werror.patch (renamed from net-p2p/c-lightning/files/0.7.1-build-do-not-Werror.patch)4
-rw-r--r--net-p2p/c-lightning/files/0.7.3-build-do-not-refresh-external-modules.patch (renamed from net-p2p/c-lightning/files/0.7.1-build-do-not-refresh-external-modules.patch)4
-rw-r--r--net-p2p/c-lightning/files/0.7.3-build-remove-deprecated-AM_ENABLE_MULTILIB.patch (renamed from net-p2p/c-lightning/files/0.7.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch)0
-rw-r--r--net-p2p/c-lightning/files/0.7.3-build-use-FHS-docdir.patch (renamed from net-p2p/c-lightning/files/0.7.1-build-use-FHS-docdir.patch)6
10 files changed, 16 insertions, 189 deletions
diff --git a/net-p2p/c-lightning/c-lightning-0.7.0.ebuild b/net-p2p/c-lightning/c-lightning-0.7.0.ebuild
deleted file mode 100644
index 5078abf2..00000000
--- a/net-p2p/c-lightning/c-lightning-0.7.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit git-r3 autotools libtool toolchain-funcs systemd
-
-DESCRIPTION="A specification compliant Lightning Network implementation in C"
-HOMEPAGE="https://github.com/ElementsProject/lightning"
-EGIT_REPO_URI="https://github.com/ElementsProject/lightning.git"
-EGIT_COMMIT="v${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-
-DEPEND="dev-libs/libsodium:=
- dev-libs/gmp:0
- dev-db/sqlite:3
- sys-libs/zlib:=
- app-text/asciidoc"
-RDEPEND="${DEPEND}
- net-p2p/bitcoin-cli"
-
-PATCHES=(
- "${FILESDIR}/${PV}-build-do-not-Werror.patch"
- "${FILESDIR}/${PV}-build-do-not-refresh-external-modules.patch"
- "${FILESDIR}/${PV}-build-remove-deprecated-AM_ENABLE_MULTILIB.patch"
- "${FILESDIR}/${PV}-build-use-FHS-docdir.patch"
-)
-
-src_prepare() {
- default
-
- export PYTEST=:
- export CC="$(tc-getCC)" CONFIGURATOR_CC="${CBUILD}-gcc"
- export CDEBUGFLAGS="-std=gnu11 -fstack-protector ${CFLAGS}"
-
- sed -i \
- -e "s:^VERSION=.*:VERSION=${PVR}:" \
- Makefile \
- || die
-
- local externals=( libbacktrace libbase58 libsodium libwally-core )
-
- for x in ${externals[@]} ; do
- pushd "external/${x}" > /dev/null || die
- eautoreconf
- popd > /dev/null || die
- done
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --enable-compat \
- --disable-static \
- --disable-developer \
- --disable-experimental-features \
- --disable-valgrind \
- --disable-address-sanitizer
-}
-
-src_compile() {
- emake CDEBUGFLAGS="${CDEBUGFLAGS}"
-}
-
-src_install() {
- default
-
- systemd_dounit contrib/init/lightningd.service
-}
diff --git a/net-p2p/c-lightning/c-lightning-0.7.1.ebuild b/net-p2p/c-lightning/c-lightning-0.7.3.ebuild
index 37f6aa07..0d71562f 100644
--- a/net-p2p/c-lightning/c-lightning-0.7.1.ebuild
+++ b/net-p2p/c-lightning/c-lightning-0.7.3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 autotools libtool toolchain-funcs systemd
+PYTHON_COMPAT=( python{3_6,3_7} )
+inherit git-r3 autotools libtool toolchain-funcs systemd python-r1
DESCRIPTION="A specification compliant Lightning Network implementation in C"
HOMEPAGE="https://github.com/ElementsProject/lightning"
@@ -12,13 +13,16 @@ EGIT_COMMIT="v${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
-IUSE=""
+IUSE="+sqlite"
+BDEPEND="${PYTHON_DEPS}
+ dev-python/mako:=[${PYTHON_USEDEP}]
+ app-text/asciidoc
+ sys-devel/gettext"
DEPEND="dev-libs/libsodium:=
dev-libs/gmp:0
- dev-db/sqlite:3
- sys-libs/zlib:=
- app-text/asciidoc"
+ sqlite? ( dev-db/sqlite:3 )
+ sys-libs/zlib:="
RDEPEND="${DEPEND}
net-p2p/bitcoin-cli"
diff --git a/net-p2p/c-lightning/files/0.7.0-build-do-not-Werror.patch b/net-p2p/c-lightning/files/0.7.0-build-do-not-Werror.patch
deleted file mode 100644
index 873f6fb1..00000000
--- a/net-p2p/c-lightning/files/0.7.0-build-do-not-Werror.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From b9430ac0bf6455893a654f2a7c17936ebedaa90b Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Mon, 13 May 2019 23:59:33 +0000
-Subject: [PATCH] build: do not -Werror
-
----
- Makefile | 2 +-
- configure | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 7e23e8a2a827..1e2cfc60cef7 100644
---- a/Makefile
-+++ b/Makefile
-@@ -185,7 +185,7 @@ WIRE_GEN := tools/generate-wire.py
- ALL_PROGRAMS =
-
- CPPFLAGS = -DBINTOPKGLIBEXECDIR='"'$(shell sh tools/rel.sh $(bindir) $(pkglibexecdir))'"'
--CWARNFLAGS := -Werror -Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition
-+CWARNFLAGS := -W -Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition
- CDEBUGFLAGS := -std=gnu11 -g -fstack-protector $(SANITIZER_FLAGS)
- CFLAGS = $(CPPFLAGS) $(CWARNFLAGS) $(CDEBUGFLAGS) -I $(CCANDIR) $(EXTERNAL_INCLUDE_FLAGS) -I . -I/usr/local/include $(FEATURES) $(COVFLAGS) $(DEV_CFLAGS) -DSHACHAIN_BITS=48 -DJSMN_PARENT_LINKS $(PIE_CFLAGS) $(COMPAT_CFLAGS)
-
-diff --git a/configure b/configure
-index b220cde05ed7..6549d0b67856 100755
---- a/configure
-+++ b/configure
-@@ -6,7 +6,7 @@ set -e
- # Default values, loaded from environment or canned.
- PREFIX=${PREFIX:-/usr/local}
- CC=${CC:-cc}
--CWARNFLAGS=${CWARNFLAGS:--Werror -Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition}
-+CWARNFLAGS=${CWARNFLAGS:--W -Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition}
- CDEBUGFLAGS=${CDEBUGFLAGS:--std=gnu11 -g -fstack-protector}
- DEVELOPER=${DEVELOPER:-0}
- EXPERIMENTAL_FEATURES=${EXPERIMENTAL_FEATURES:-0}
diff --git a/net-p2p/c-lightning/files/0.7.0-build-do-not-refresh-external-modules.patch b/net-p2p/c-lightning/files/0.7.0-build-do-not-refresh-external-modules.patch
deleted file mode 100644
index 77b307ce..00000000
--- a/net-p2p/c-lightning/files/0.7.0-build-do-not-refresh-external-modules.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 936ada65ede521c46cf34b7a9e2ff7cb7799431f Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Mon, 13 May 2019 23:50:38 +0000
-Subject: [PATCH] build: do not refresh external modules
-
----
- external/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/external/Makefile b/external/Makefile
-index fc0088ba7f93..94e88e3c7e03 100644
---- a/external/Makefile
-+++ b/external/Makefile
-@@ -32,7 +32,7 @@ endif
- EXTERNAL_LDLIBS := -Lexternal $(patsubst lib%.a,-l%,$(notdir $(EXTERNAL_LIBS)))
-
- submodcheck: FORCE
-- @tools/refresh-submodules.sh $(SUBMODULES)
-+ : @tools/refresh-submodules.sh $(SUBMODULES)
-
- # We build libsodium, since Ubuntu xenial has one too old.
- external/libsodium.a: external/libsodium/src/libsodium/libsodium.la
diff --git a/net-p2p/c-lightning/files/0.7.0-build-use-FHS-docdir.patch b/net-p2p/c-lightning/files/0.7.0-build-use-FHS-docdir.patch
deleted file mode 100644
index 30548328..00000000
--- a/net-p2p/c-lightning/files/0.7.0-build-use-FHS-docdir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From b1483d2208b7a50e2f8f7744e8eccad18748e6a2 Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Tue, 14 May 2019 01:33:02 +0000
-Subject: [PATCH] build: use FHS docdir
-
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 1e2cfc60cef7..7387a6ca7db6 100644
---- a/Makefile
-+++ b/Makefile
-@@ -442,7 +442,7 @@ libexecdir = $(exec_prefix)/libexec
- pkglibexecdir = $(libexecdir)/$(PKGNAME)
- plugindir = $(pkglibexecdir)/plugins
- datadir = $(PREFIX)/share
--docdir = $(datadir)/doc/$(PKGNAME)
-+docdir = $(datadir)/doc/$(PKGNAME)-$(VERSION)
- mandir = $(datadir)/man
- man1dir = $(mandir)/man1
- man5dir = $(mandir)/man5
diff --git a/net-p2p/c-lightning/files/0.7.1-build-remove-deprecated-AM_ENABLE_MULTILIB.patch b/net-p2p/c-lightning/files/0.7.1-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
deleted file mode 100644
index 415a71cf..00000000
--- a/net-p2p/c-lightning/files/0.7.1-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 8271ca3e71e258c99675c0f873724d07a8c22440 Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Mon, 13 May 2019 23:47:42 +0000
-Subject: [PATCH] build: remove deprecated AM_ENABLE_MULTILIB
-
----
- external/libbacktrace/configure.ac | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/external/libbacktrace/configure.ac b/external/libbacktrace/configure.ac
-index 2aad65ad9c7f..0cebaab8fc9a 100644
---- a/external/libbacktrace/configure.ac
-+++ b/external/libbacktrace/configure.ac
-@@ -35,11 +35,6 @@ AC_CONFIG_SRCDIR(backtrace.h)
- AC_CONFIG_HEADER(config.h)
- AC_CONFIG_MACRO_DIR(config)
-
--# with_target_subdir is used when configured as part of a GCC tree.
--if test -n "${with_target_subdir}"; then
-- AM_ENABLE_MULTILIB(, ..)
--fi
--
- AC_CANONICAL_SYSTEM
- target_alias=${target_alias-$host_alias}
-
diff --git a/net-p2p/c-lightning/files/0.7.1-build-do-not-Werror.patch b/net-p2p/c-lightning/files/0.7.3-build-do-not-Werror.patch
index aa00bd05..836ff05c 100644
--- a/net-p2p/c-lightning/files/0.7.1-build-do-not-Werror.patch
+++ b/net-p2p/c-lightning/files/0.7.3-build-do-not-Werror.patch
@@ -1,4 +1,4 @@
-From 2654dde156c1c3d7ee28874c4d4d7312087a4faf Mon Sep 17 00:00:00 2001
+From b0c5647f184522ac11f817b8be542e6277a9efe3 Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Mon, 13 May 2019 23:59:33 +0000
Subject: [PATCH] build: do not -Werror
@@ -8,7 +8,7 @@ Subject: [PATCH] build: do not -Werror
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
-index 3ebebb2c8dc9..4f24590909ba 100755
+index 0d28929502a8..9aec451beb2f 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@ set -e
diff --git a/net-p2p/c-lightning/files/0.7.1-build-do-not-refresh-external-modules.patch b/net-p2p/c-lightning/files/0.7.3-build-do-not-refresh-external-modules.patch
index 4ba95879..f6118a6c 100644
--- a/net-p2p/c-lightning/files/0.7.1-build-do-not-refresh-external-modules.patch
+++ b/net-p2p/c-lightning/files/0.7.3-build-do-not-refresh-external-modules.patch
@@ -1,4 +1,4 @@
-From 658a20dbab9aab683ba65d126d9fbc0ca1b4eb77 Mon Sep 17 00:00:00 2001
+From 6ab2b283141a381c16ed207a543b5366e93d7fe2 Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Mon, 13 May 2019 23:50:38 +0000
Subject: [PATCH] build: do not refresh external modules
@@ -8,7 +8,7 @@ Subject: [PATCH] build: do not refresh external modules
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/external/Makefile b/external/Makefile
-index fc0088ba7f93..94e88e3c7e03 100644
+index 697258120f1d..e365563b10e5 100644
--- a/external/Makefile
+++ b/external/Makefile
@@ -32,7 +32,7 @@ endif
diff --git a/net-p2p/c-lightning/files/0.7.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch b/net-p2p/c-lightning/files/0.7.3-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
index 415a71cf..415a71cf 100644
--- a/net-p2p/c-lightning/files/0.7.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
+++ b/net-p2p/c-lightning/files/0.7.3-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
diff --git a/net-p2p/c-lightning/files/0.7.1-build-use-FHS-docdir.patch b/net-p2p/c-lightning/files/0.7.3-build-use-FHS-docdir.patch
index 567b8768..70f2ae34 100644
--- a/net-p2p/c-lightning/files/0.7.1-build-use-FHS-docdir.patch
+++ b/net-p2p/c-lightning/files/0.7.3-build-use-FHS-docdir.patch
@@ -1,4 +1,4 @@
-From 9c7cd1b9f964534af85c9dbafd4fe539e8df10d8 Mon Sep 17 00:00:00 2001
+From 5ac9f6749086d573bcc43a04e7ae958ce9bdf431 Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Tue, 14 May 2019 01:33:02 +0000
Subject: [PATCH] build: use FHS docdir
@@ -8,10 +8,10 @@ Subject: [PATCH] build: use FHS docdir
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 22152da886db..146d440dc756 100644
+index 7c19a5d6d5f3..c1ebb281690c 100644
--- a/Makefile
+++ b/Makefile
-@@ -444,7 +444,7 @@ libexecdir = $(exec_prefix)/libexec
+@@ -452,7 +452,7 @@ libexecdir = $(exec_prefix)/libexec
pkglibexecdir = $(libexecdir)/$(PKGNAME)
plugindir = $(pkglibexecdir)/plugins
datadir = $(PREFIX)/share