summaryrefslogtreecommitdiff
path: root/net-p2p/c-lightning
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-05-24 03:51:09 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-06-02 23:06:10 +0100
commit176f3c60a13bd67c9f36cff552ff7a8fbfa7a5c1 (patch)
tree372febfaa5f11fcb61d3d41d02696a12edfd3c35 /net-p2p/c-lightning
parentdev-libs/randomx: version bump (diff)
downloadportage-176f3c60a13bd67c9f36cff552ff7a8fbfa7a5c1.tar.xz
net-p2p/c-lightning: version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Diffstat (limited to 'net-p2p/c-lightning')
-rw-r--r--net-p2p/c-lightning/c-lightning-0.10.0.ebuild81
-rw-r--r--net-p2p/c-lightning/files/0.10.0-build-do-not-Werror.patch22
-rw-r--r--net-p2p/c-lightning/files/0.10.0-build-do-not-refresh-external-modules.patch22
-rw-r--r--net-p2p/c-lightning/files/0.10.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch25
-rw-r--r--net-p2p/c-lightning/files/0.10.0-build-use-FHS-docdir.patch22
-rw-r--r--net-p2p/c-lightning/files/0.8.1-build-do-not-Werror.patch8
6 files changed, 176 insertions, 4 deletions
diff --git a/net-p2p/c-lightning/c-lightning-0.10.0.ebuild b/net-p2p/c-lightning/c-lightning-0.10.0.ebuild
new file mode 100644
index 00000000..5194ac0b
--- /dev/null
+++ b/net-p2p/c-lightning/c-lightning-0.10.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+inherit git-r3 autotools libtool toolchain-funcs systemd python-r1
+
+DESCRIPTION="A specification compliant Lightning Network implementation in C"
+HOMEPAGE="https://github.com/ElementsProject/lightning"
+EGIT_REPO_URI="https://github.com/ElementsProject/lightning.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+sqlite"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-python/mako:=[${PYTHON_USEDEP}]
+ app-text/asciidoc
+ sys-apps/coreutils
+ sys-devel/gettext"
+DEPEND="dev-libs/libsodium:=
+ dev-libs/gmp:0
+ sqlite? ( dev-db/sqlite:3 )
+ sys-libs/zlib:="
+RDEPEND="${DEPEND}
+ net-p2p/bitcoin-cli
+ acct-user/bitcoin"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-build-do-not-Werror.patch"
+ "${FILESDIR}/${PV}-build-do-not-refresh-external-modules.patch"
+ "${FILESDIR}/${PV}-build-remove-deprecated-AM_ENABLE_MULTILIB.patch"
+ "${FILESDIR}/${PV}-build-use-FHS-docdir.patch"
+)
+
+src_prepare() {
+ default
+
+ export PYTEST=:
+ export CC="$(tc-getCC)" CONFIGURATOR_CC="${CBUILD}-gcc"
+ export PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ export CDEBUGFLAGS="-std=gnu11 -fstack-protector ${CFLAGS}"
+
+ sed -i \
+ -e "s:^VERSION=.*:VERSION=${PVR}:" \
+ Makefile \
+ || die
+
+ local externals=( libbacktrace libsodium libwally-core )
+
+ for x in ${externals[@]} ; do
+ pushd "external/${x}" > /dev/null || die
+ eautoreconf
+ popd > /dev/null || die
+ done
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --enable-compat \
+ --disable-static \
+ --disable-developer \
+ --disable-experimental-features \
+ --disable-valgrind \
+ --disable-address-sanitizer \
+ --disable-ub-sanitize \
+ --disable-fuzzing
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CDEBUGFLAGS}" V=1
+}
+
+src_install() {
+ default
+
+ systemd_dounit contrib/init/lightningd.service
+}
diff --git a/net-p2p/c-lightning/files/0.10.0-build-do-not-Werror.patch b/net-p2p/c-lightning/files/0.10.0-build-do-not-Werror.patch
new file mode 100644
index 00000000..fcde42c8
--- /dev/null
+++ b/net-p2p/c-lightning/files/0.10.0-build-do-not-Werror.patch
@@ -0,0 +1,22 @@
+From d26898b055c18b884f93a7a56959fdb7ab193195 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Mon, 13 May 2019 23:59:33 +0000
+Subject: [PATCH] build: do not -Werror
+
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 6282eca29651..4754f8967890 100755
+--- a/configure
++++ b/configure
+@@ -6,7 +6,7 @@ set -e
+ CONFIGURATOR=ccan/tools/configurator/configurator
+ CONFIG_VAR_FILE=config.vars
+ CONFIG_HEADER=ccan/config.h
+-BASE_WARNFLAGS="-Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition -Werror"
++BASE_WARNFLAGS="-Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition"
+
+ : ${PKG_CONFIG=pkg-config}
+
diff --git a/net-p2p/c-lightning/files/0.10.0-build-do-not-refresh-external-modules.patch b/net-p2p/c-lightning/files/0.10.0-build-do-not-refresh-external-modules.patch
new file mode 100644
index 00000000..50290a4d
--- /dev/null
+++ b/net-p2p/c-lightning/files/0.10.0-build-do-not-refresh-external-modules.patch
@@ -0,0 +1,22 @@
+From b31c16645db26a663d7abf6a607453965b07841f Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Mon, 13 May 2019 23:50:38 +0000
+Subject: [PATCH] build: do not refresh external modules
+
+---
+ external/Makefile | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/external/Makefile b/external/Makefile
+index bb5d748f4904..703a269952a7 100644
+--- a/external/Makefile
++++ b/external/Makefile
+@@ -48,8 +48,6 @@ endif
+ EXTERNAL_LDLIBS := -L${TARGET_DIR} $(patsubst lib%.a,-l%,$(notdir $(EXTERNAL_LIBS)))
+
+ submodcheck: FORCE
+- @tools/refresh-submodules.sh $(SUBMODULES)
+- @cd external/libwally-core && ../../tools/refresh-submodules.sh src/secp256k1
+
+ $(EXTERNAL_HEADERS): submodcheck
+
diff --git a/net-p2p/c-lightning/files/0.10.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch b/net-p2p/c-lightning/files/0.10.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
new file mode 100644
index 00000000..415a71cf
--- /dev/null
+++ b/net-p2p/c-lightning/files/0.10.0-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
@@ -0,0 +1,25 @@
+From 8271ca3e71e258c99675c0f873724d07a8c22440 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Mon, 13 May 2019 23:47:42 +0000
+Subject: [PATCH] build: remove deprecated AM_ENABLE_MULTILIB
+
+---
+ external/libbacktrace/configure.ac | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/external/libbacktrace/configure.ac b/external/libbacktrace/configure.ac
+index 2aad65ad9c7f..0cebaab8fc9a 100644
+--- a/external/libbacktrace/configure.ac
++++ b/external/libbacktrace/configure.ac
+@@ -35,11 +35,6 @@ AC_CONFIG_SRCDIR(backtrace.h)
+ AC_CONFIG_HEADER(config.h)
+ AC_CONFIG_MACRO_DIR(config)
+
+-# with_target_subdir is used when configured as part of a GCC tree.
+-if test -n "${with_target_subdir}"; then
+- AM_ENABLE_MULTILIB(, ..)
+-fi
+-
+ AC_CANONICAL_SYSTEM
+ target_alias=${target_alias-$host_alias}
+
diff --git a/net-p2p/c-lightning/files/0.10.0-build-use-FHS-docdir.patch b/net-p2p/c-lightning/files/0.10.0-build-use-FHS-docdir.patch
new file mode 100644
index 00000000..82d1411d
--- /dev/null
+++ b/net-p2p/c-lightning/files/0.10.0-build-use-FHS-docdir.patch
@@ -0,0 +1,22 @@
+From e461e3fb37ee1ccad5d4e03a07716b4dfeb73d82 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Tue, 14 May 2019 01:33:02 +0000
+Subject: [PATCH] build: use FHS docdir
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 192d4ec1e63a..84c58d5de74c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -602,7 +602,7 @@ libexecdir = $(exec_prefix)/libexec
+ pkglibexecdir = $(libexecdir)/$(PKGNAME)
+ plugindir = $(pkglibexecdir)/plugins
+ datadir = $(PREFIX)/share
+-docdir = $(datadir)/doc/$(PKGNAME)
++docdir = $(datadir)/doc/$(PKGNAME)-$(VERSION)
+ mandir = $(datadir)/man
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
diff --git a/net-p2p/c-lightning/files/0.8.1-build-do-not-Werror.patch b/net-p2p/c-lightning/files/0.8.1-build-do-not-Werror.patch
index e26f05a3..9e3f35f5 100644
--- a/net-p2p/c-lightning/files/0.8.1-build-do-not-Werror.patch
+++ b/net-p2p/c-lightning/files/0.8.1-build-do-not-Werror.patch
@@ -1,4 +1,4 @@
-From a9d1f53a9a7f4b6e2cd31fbd4845607ae89d2607 Mon Sep 17 00:00:00 2001
+From f0c79eb6408e4a062701145b48b235123e10da59 Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Mon, 13 May 2019 23:59:33 +0000
Subject: [PATCH] build: do not -Werror
@@ -8,7 +8,7 @@ Subject: [PATCH] build: do not -Werror
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
-index 91dce80e70c1..7ac31556d566 100755
+index 6282eca29651..4754f8967890 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@ set -e
@@ -18,5 +18,5 @@ index 91dce80e70c1..7ac31556d566 100755
-BASE_WARNFLAGS="-Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition -Werror"
+BASE_WARNFLAGS="-Wall -Wundef -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wold-style-definition"
- usage_with_default()
- {
+ : ${PKG_CONFIG=pkg-config}
+