summaryrefslogtreecommitdiff
path: root/net-p2p/bisq
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-06-01 02:48:49 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-06-02 23:06:11 +0100
commit7b6b1bece0bd31628846092a8a324c42f8e56807 (patch)
treee7c472c3be6b0bc8b452779b9d440bca0887024f /net-p2p/bisq
parentsys-kernel/stable-sources: versionn bump (diff)
downloadportage-7b6b1bece0bd31628846092a8a324c42f8e56807.tar.xz
net-p2p/bisq: version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Diffstat (limited to 'net-p2p/bisq')
-rw-r--r--net-p2p/bisq/Manifest1
-rw-r--r--net-p2p/bisq/bisq-1.6.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-p2p/bisq/Manifest b/net-p2p/bisq/Manifest
index 68f89387..772ae823 100644
--- a/net-p2p/bisq/Manifest
+++ b/net-p2p/bisq/Manifest
@@ -1,2 +1,3 @@
DIST bisq-1.6.4.tar.gz 61111627 BLAKE2B a342686db255d06f00baa64966087be319303f2d80af8629c8e129a6e24ec847801d759d7bdcd6615301ef0390558d1ff5c043c60f129c2ad34985a0705519cb SHA512 379f68662f713b6f515d72866ce2f795a76ea2101e62f091438cfe0f2fdd4712c70ef71b8a8dc68957fea418450575ebeb78174e54dbb2e3bb79ab3ef1a11bb7
+DIST bisq-1.6.5.tar.gz 64603095 BLAKE2B d971cf2f905424d4721010cdc0a17714fca886aaf8f0ddde7cda04dffe35d5ec5307d10eec9b3c816c201d08d16f39cc87eda53ab13962d312ff09a45d5363e3 SHA512 918a97ca969f3b74fd0a92ef1b8029281d58605112b7a4feeb3fbd3fbea3bdf3c134d4e2ebdb18b587d55102e672e67c0d0c108457168fab8b8c8819829dbcc9
DIST gradle-5.6.4-all.zip 139794962 BLAKE2B 1ed22491abf92188c6a233c7ec1b4635bc167c386777639dbc9f61dae89f8d7382185b937de54df97d4dbdfcfa82fba19c8e79faecd0d6a336bfd18264e8cfad SHA512 b2914e7497dc1eb2c68557466a2268b3f78371e00fdf9aa793ae6f614836ccb18ac9c9fb6d3b342c9ef152bdc474ae889a788f4b78b54fb83c1509781f2ee192
diff --git a/net-p2p/bisq/bisq-1.6.5.ebuild b/net-p2p/bisq/bisq-1.6.5.ebuild
new file mode 100644
index 00000000..2babcae7
--- /dev/null
+++ b/net-p2p/bisq/bisq-1.6.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGRADLE_VER="5.6.4"
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Decentralized governance for a decentralized exchange"
+HOMEPAGE="https://bisq.network"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="|| (
+ dev-java/openjdk:11
+ dev-java/openjdk-bin:11
+ )
+ "
+RDEPEND="|| (
+ dev-java/openjdk:11[javafx]
+ (
+ dev-java/openjdk-bin:11
+ dev-java/openjfx:11
+ )
+ )
+"
+
+SRC_URI="https://bisq.network/downloads/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://services.gradle.org/distributions/gradle-${EGRADLE_VER}-all.zip"
+
+# FIXME identify all download made by gradle
+# See https://stackoverflow.com/questions/37697622/gradle-get-url-of-dependency-artifact
+RESTRICT="network-sandbox"
+
+src_prepare () {
+ default
+
+ if has_version "dev-java/openjdk:11" ; then
+ JAVA_HOME="${EPREFIX}/usr/$(get_libdir)/openjdk-11"
+ elif has_version "dev-java/openjdk-bin:11" ; then
+ JAVA_HOME="${EPREFIX}/opt/openjdk-bin-11"
+ else
+ die "Unable to find java"
+ fi
+
+ export JAVA_HOME
+ export GRADLE_HOME="${WORKDIR}/gradle-${EGRADLE_VER}"
+}
+
+src_compile () {
+ # FIXME add --offline
+ "${GRADLE_HOME}/bin/gradle" \
+ -Djava.io.tmpdir="${T}" \
+ --info \
+ --console=verbose \
+ --no-daemon \
+ --no-build-cache \
+ --project-cache-dir="${T}/gradle-project" \
+ --gradle-user-home="${T}/gradle-homedir" \
+ --stacktrace \
+ --exclude-task test \
+ :desktop:build \
+ || die "gradle failed"
+
+ # Force JAVA_HOME until dev-java/openjdk:11 supports USE=gentoo-vm
+ sed -i \
+ -e "/^DEFAULT_JVM_OPTS=/i export JAVA_HOME='${JAVA_HOME}'" \
+ desktop/build/app/bin/bisq-desktop \
+ || die "failed to alter desktop/build/app/bin/bisq-desktop"
+}
+
+src_install () {
+ # Binary
+ into /opt/bisq
+ dobin desktop/build/app/bin/bisq-desktop
+ dosym ../../opt/bisq/bin/bisq-desktop /usr/bin/bisq
+
+ # Libraries
+ insinto /opt/bisq
+ doins -r desktop/build/app/lib
+
+ # Documentation
+ dodoc README.md CONTRIBUTING.md
+ dodoc -r docs/.
+}