summaryrefslogtreecommitdiff
path: root/net-analyzer/ethstatus
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2010-07-06 00:33:06 +0200
committerBertrand Jacquin <beber@meleeweb.net>2010-07-06 00:33:06 +0200
commit4ef2f4ebfc8b05aab8055ddcf8f7e7231474c585 (patch)
treed3f030b60f3c6705adecd1c153adb4f4c6daf8da /net-analyzer/ethstatus
parenthot-babe portage sync (diff)
downloadportage-4ef2f4ebfc8b05aab8055ddcf8f7e7231474c585.tar.xz
ethstatus for cross compile
Diffstat (limited to 'net-analyzer/ethstatus')
-rw-r--r--net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild44
-rw-r--r--net-analyzer/ethstatus/files/ethstatus-BJA-0.4.2-gcc-overridable.diff19
2 files changed, 63 insertions, 0 deletions
diff --git a/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild b/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild
new file mode 100644
index 00000000..8a2bbd20
--- /dev/null
+++ b/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild,v 1.7 2008/11/24 15:57:54 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="ncurses based utility to display real time statistics about network traffic."
+HOMEPAGE="http://ethstatus.calle69.net/"
+SRC_URI="mirror://debian/pool/main/e/ethstatus/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.4-r1"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.1.4-r1"
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/ethstatus-BJA-0.4.2-gcc-overridable.diff
+
+ #Fix LDFLAGS ordering, see bug #247926
+ sed -i 's/$(LDFLAGS) -o ${BIN} ${SRC}/-o ${BIN} ${SRC} $(LDFLAGS)/' "${S}/Makefile"
+}
+
+src_compile()
+{
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" || die "Compilation failed"
+}
+
+src_install()
+{
+ dobin ethstatus
+ doman ethstatus.1
+ dodoc CHANGELOG README
+}
diff --git a/net-analyzer/ethstatus/files/ethstatus-BJA-0.4.2-gcc-overridable.diff b/net-analyzer/ethstatus/files/ethstatus-BJA-0.4.2-gcc-overridable.diff
new file mode 100644
index 00000000..6f9873f5
--- /dev/null
+++ b/net-analyzer/ethstatus/files/ethstatus-BJA-0.4.2-gcc-overridable.diff
@@ -0,0 +1,19 @@
+--- Makefile.ori 2009-08-17 11:01:43.000000000 +0200
++++ Makefile 2009-08-17 11:02:12.000000000 +0200
+@@ -3,6 +3,7 @@
+ # Edited for Debian GNU/Linux.
+ DESTDIR =
+
++CC = gcc
+ LDFLAGS = -lncurses
+ CFLAGS = -O2 -Wall
+ #CFLAGS = -Wall -g
+@@ -19,7 +20,7 @@
+ all : ethstatus
+
+ ethstatus : ethstatus.c ethstatus.h
+- gcc $(CFLAGS) $(LDFLAGS) -o ${BIN} ${SRC}
++ $(CC) $(CFLAGS) $(LDFLAGS) -o ${BIN} ${SRC}
+
+ clean:
+ rm -f ${BIN} *.o core *~