summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-06-08 17:51:46 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-06-08 17:51:46 +0200
commit8063cee52a783b4d0642b50d7ed1ee057ce65ca2 (patch)
tree699aa1534eb056d437a1bf38aff294db459fb5cb /media-tv
parentAdd missing directory metadata/md5-cache (diff)
downloadportage-8063cee52a783b4d0642b50d7ed1ee057ce65ca2.tar.xz
media-tv/congruity: Add some parse and debug patches as per discussion with Scott Talbert
Package-Manager: portage-2.1.12.3
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/congruity/ChangeLog6
-rw-r--r--media-tv/congruity/Manifest6
-rw-r--r--media-tv/congruity/congruity-16.ebuild7
-rw-r--r--media-tv/congruity/files/congruity-16-mhgui-debug.patch21
-rw-r--r--media-tv/congruity/files/congruity-16-mhgui-parse.patch43
5 files changed, 80 insertions, 3 deletions
diff --git a/media-tv/congruity/ChangeLog b/media-tv/congruity/ChangeLog
index 9a994220..9922785b 100644
--- a/media-tv/congruity/ChangeLog
+++ b/media-tv/congruity/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Jun 2013; Bertrand Jacquin <beber@meleeweb.net>
+ +files/congruity-16-mhgui-debug.patch, +files/congruity-16-mhgui-parse.patch,
+ congruity-16.ebuild:
+ media-tv/congruity: Add some parse and debug patches as per discussion with
+ Scott Talbert
+
05 Jun 2013; Bertrand Jacquin <beber@meleeweb.net> congruity-16.ebuild:
media-tv/congruity: Use python-r1 eclass
diff --git a/media-tv/congruity/Manifest b/media-tv/congruity/Manifest
index e1ce016b..12b927d7 100644
--- a/media-tv/congruity/Manifest
+++ b/media-tv/congruity/Manifest
@@ -1,4 +1,6 @@
+AUX congruity-16-mhgui-debug.patch 773 SHA256 c07354d691227c96446f4772d5d7120f30fe5f953ae99b59b487a9c0d6c946b0 WHIRLPOOL 10487597143d179132c37467ae10daf8f03de3b7619d1adc8c8745cc3f1ffcc077f4e6e538b5bddb4438b7e876665e424a82318e7e00a781a14ffadf1030a6fd
+AUX congruity-16-mhgui-parse.patch 1424 SHA256 1de685d99cdcf0e93d2f568b2670cedb251fa6b087f2c6e637a0b6032f10016a WHIRLPOOL 0e62e056a544ea7c5d82a59764e578cbea80ee2c3e2b288653f6d58427dee9e650458fce55035569fc1674a6c53e14fcd957a98a72050f9be27ad4ebf8103a92
DIST congruity-16.tar.bz2 174981 SHA256 46915b23b13f3a2aaa3f5c766a639859fb7c42f99e44904b8cb88c263d193032 WHIRLPOOL 5d686570f81081176af26b5ebded513cd4c55caf875e462d42652b848298a18c8b609ee9bd98148f8a44853a42de5bef765b10cf03a4b788950ca4d78417d4b2
-EBUILD congruity-16.ebuild 783 SHA256 d014f4aa8fd4dd0f4c2a5a7210bf818d59617cad30755ac10936389b4c4f5606 WHIRLPOOL f7d28a7bad7ea3f8c99a85ebf9c97b7b284e42ee08291d2be8be7ea2cc6f5eadd8603da21081752dac43795a23ed210a0a45656ed415d4fc9ac8ca30e9f154ea
-MISC ChangeLog 770 SHA256 b8900ee7183e6ab4a50fa33420e26826aff9d366be1ee578c88cdc943efed382 WHIRLPOOL aba40926d0d64f18d8bbea206f3c85436a2ef4bbf984d13752b5cd6d81c4c7659afd37bc8e6c336d54d1917aa88c3766eec7abece621583071b9a39af50efdd1
+EBUILD congruity-16.ebuild 899 SHA256 cb6591fcd0e4b2f956facf4bb2d268c2a6a74236542759ea90289aac43418e66 WHIRLPOOL 55a4c20dfd48f7e531385f06322de204a6b78539f7b0c243d0079447e0a59ca1697509f2a4993f727e7ef1c7527a6049906b9bfe887ca6bd2cd3dbf48fbb4b1c
+MISC ChangeLog 1021 SHA256 9b2b90d50a8719e685e95c6cf2e686a00ca4df35668f93af06fa1cf8d7863788 WHIRLPOOL 90420648c5df56e069164131beb1311134fdb990f1060009cfe91cb2b9c2b05877d5ba2c3e11f57efbe564320966eb468da7ea4119e30d79d1437339b4d4788a
MISC metadata.xml 139 SHA256 5cdc1888ebc8807b9a37b1d33429c61cabe7415a4f240e21a4c2ff8eca7a34ed WHIRLPOOL 620431014dd4fb752c3d46d11904ecb2c6d4525f5b4e30f4f778a3b74d3f7187ae4ccd856ebd7eabb48ce261b21849c732928fe647edce024a3fdc082d8f8630
diff --git a/media-tv/congruity/congruity-16.ebuild b/media-tv/congruity/congruity-16.ebuild
index 2e050618..33e958cc 100644
--- a/media-tv/congruity/congruity-16.ebuild
+++ b/media-tv/congruity/congruity-16.ebuild
@@ -4,7 +4,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1 fdo-mime
+inherit python-single-r1 fdo-mime eutils
DESCRIPTION="GUI application for programming Logitech Harmony"
HOMEPAGE="http://sourceforge.net/projects/congruity"
@@ -20,6 +20,11 @@ DEPEND=">=dev-libs/libconcord-1.0[python]
>=dev-python/suds-0.4"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-mhgui-parse.patch"
+ epatch "${FILESDIR}/${P}-mhgui-debug.patch"
+}
+
src_install() {
emake DESTDIR="${ED}" PREFIX="/usr" \
RUN_UPDATE_DESKTOP_DB=0 \
diff --git a/media-tv/congruity/files/congruity-16-mhgui-debug.patch b/media-tv/congruity/files/congruity-16-mhgui-debug.patch
new file mode 100644
index 00000000..335a91d1
--- /dev/null
+++ b/media-tv/congruity/files/congruity-16-mhgui-debug.patch
@@ -0,0 +1,21 @@
+commit 7fe328417295f582bfcf82f4a4d039d1846e91ab
+Author: Scott Talbert <swt@techie.net>
+Date: Thu Jun 6 19:42:49 2013 -0400
+
+ Enable debug for Harmony 650 debugging.
+
+diff --git a/mhmanager.py b/mhmanager.py
+index 597e826..613a599 100644
+--- a/mhmanager.py
++++ b/mhmanager.py
+@@ -85,8 +85,8 @@ class MHPlugin(MessagePlugin):
+ self.fix_elements(None, operation.getChildren())
+
+
+-#logging.basicConfig(level=logging.INFO)
+-#logging.getLogger('suds.client').setLevel(logging.DEBUG)
++logging.basicConfig(level=logging.INFO)
++logging.getLogger('suds.client').setLevel(logging.DEBUG)
+ #logging.getLogger('suds.transport').setLevel(logging.DEBUG)
+ #logging.getLogger('suds.xsd.schema').setLevel(logging.DEBUG)
+ #logging.getLogger('suds.wsdl').setLevel(logging.DEBUG)
diff --git a/media-tv/congruity/files/congruity-16-mhgui-parse.patch b/media-tv/congruity/files/congruity-16-mhgui-parse.patch
new file mode 100644
index 00000000..95cd8e7e
--- /dev/null
+++ b/media-tv/congruity/files/congruity-16-mhgui-parse.patch
@@ -0,0 +1,43 @@
+commit 9b3e0e6198368ed4cb11c229e7faf986a053bdfc
+Author: Scott Talbert <swt@techie.net>
+Date: Wed Jun 5 20:57:31 2013 -0400
+
+ Made updates to Account XSD to match Logitech changes.
+
+ Signed-off-by: Scott Talbert <swt@techie.net>
+
+diff --git a/account.xsd b/account.xsd
+index 9b9680c..46e4dba 100644
+--- a/account.xsd
++++ b/account.xsd
+@@ -55,6 +55,7 @@
+
+ <complexType name="Remote">
+ <sequence>
++ <element name="ComputedProductSerial" type="xsd:string"/>
+ <element name="DateCreated" type="xsd:string"/>
+ <element name="FirstConnectDate" type="xsd:string"/>
+ <element name="FirstSyncDate" type="xsd:string"/>
+@@ -112,6 +113,14 @@
+ </sequence>
+ </complexType>
+
++ <complexType name="SetupSession">
++ <sequence>
++ <element name="Client" type="xsd:string" nillable="true"/>
++ <element name="IsStale" type="xsd:string"/>
++ <element name="Type" type="xsd:string"/>
++ </sequence>
++ </complexType>
++
+ <complexType name="Account">
+ <sequence>
+ <element name="AccountTypeId" type="xsd:string"/>
+@@ -124,6 +133,7 @@
+ <element name="LastSetupRating" type="xsd:string"/>
+ <element name="Properties" type="ns6:Properties"/>
+ <element name="Remotes" type="ns6:Remotes"/>
++ <element name="SetupSession" type="ns6:SetupSession"/>
+ <element name="Surfaces" type="ns6:Surfaces" nillable="true"/>
+ </sequence>
+ </complexType>