summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
commit8ba9011dae5fb85e1e53bb6adb122a5615fb32e3 (patch)
tree9923c0730cd78b86ec8c924d3cd55f25e147649e /mail-client
parentDel old ebuilds (diff)
downloadportage-8ba9011dae5fb85e1e53bb6adb122a5615fb32e3.tar.xz
move gentoofr overlay to ..
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/Manifest7
-rw-r--r--mail-client/mutt/files/8patch-1.5.6.dyc.source_stat61
-rw-r--r--mail-client/mutt/files/Muttrc19
-rw-r--r--mail-client/mutt/files/Muttrc.mbox9
-rw-r--r--mail-client/mutt/files/digest-mutt-1.5.8-r39
-rw-r--r--mail-client/mutt/files/patch-1.5.8.vvv.nntp-gentoo-r2.bz2bin0 -> 71752 bytes
-rw-r--r--mail-client/mutt/files/slang.patch19
-rw-r--r--mail-client/mutt/mutt-1.5.8-r3.ebuild150
8 files changed, 274 insertions, 0 deletions
diff --git a/mail-client/mutt/Manifest b/mail-client/mutt/Manifest
new file mode 100644
index 00000000..4eae8754
--- /dev/null
+++ b/mail-client/mutt/Manifest
@@ -0,0 +1,7 @@
+MD5 43bd93628259e1fb135a613e974315d1 mutt-1.5.8-r3.ebuild 4696
+MD5 6064ff5a3d1a71ccdb48f88872feb3a3 files/Muttrc 667
+MD5 30ce590d0284ffb0896857714c6a47d4 files/Muttrc.mbox 486
+MD5 fb20d001bb7102cf78f8e1c734eabbdf files/patch-1.5.8.vvv.nntp-gentoo-r2.bz2 71752
+MD5 d789f6060e71c1a95e52d74e15474096 files/digest-mutt-1.5.8-r3 659
+MD5 74ddaf505ea8bd19fbeb1330a23506ea files/8patch-1.5.6.dyc.source_stat 1531
+MD5 25e242fd402f42d5bd5230dbe9ea68a6 files/slang.patch 493
diff --git a/mail-client/mutt/files/8patch-1.5.6.dyc.source_stat b/mail-client/mutt/files/8patch-1.5.6.dyc.source_stat
new file mode 100644
index 00000000..da380763
--- /dev/null
+++ b/mail-client/mutt/files/8patch-1.5.6.dyc.source_stat
@@ -0,0 +1,61 @@
+? mutt/build
+? mutt/stamp-h1
+Index: mutt/init.c
+===================================================================
+RCS file: /home/roessler/cvs/mutt/init.c,v
+retrieving revision 3.19
+diff -u -r3.19 init.c
+--- mutt/init.c 1 Feb 2004 18:00:16 -0000 3.19
++++ mutt/init.c 6 Feb 2004 20:29:08 -0000
+@@ -1368,18 +1368,6 @@
+ char *linebuf = NULL;
+ size_t buflen;
+ pid_t pid;
+- struct stat s;
+-
+- if (stat (rcfile, &s) < 0)
+- {
+- snprintf (err->data, err->dsize, _("%s: stat: %s"), rcfile, strerror (errno));
+- return (-1);
+- }
+- if (!S_ISREG (s.st_mode))
+- {
+- snprintf (err->data, err->dsize, _("%s: not a regular file"), rcfile);
+- return (-1);
+- }
+
+ if ((f = mutt_open_read (rcfile, &pid)) == NULL)
+ {
+Index: mutt/muttlib.c
+===================================================================
+RCS file: /home/roessler/cvs/mutt/muttlib.c,v
+retrieving revision 3.18
+diff -u -r3.18 muttlib.c
+--- mutt/muttlib.c 1 Feb 2004 17:10:43 -0000 3.18
++++ mutt/muttlib.c 6 Feb 2004 20:29:09 -0000
+@@ -1134,6 +1134,8 @@
+ FILE *mutt_open_read (const char *path, pid_t *thepid)
+ {
+ FILE *f;
++ struct stat s;
++
+ int len = mutt_strlen (path);
+
+ if (path[len - 1] == '|')
+@@ -1149,6 +1151,16 @@
+ }
+ else
+ {
++ if (stat (path, &s) < 0)
++ {
++ mutt_error (_("%s: stat: %s"), path, strerror (errno));
++ return (NULL);
++ }
++ if (!S_ISREG (s.st_mode))
++ {
++ mutt_error (_("%s: not a regular file"), path);
++ return (NULL);
++ }
+ f = fopen (path, "r");
+ *thepid = -1;
+ }
diff --git a/mail-client/mutt/files/Muttrc b/mail-client/mutt/files/Muttrc
new file mode 100644
index 00000000..6f0d63e3
--- /dev/null
+++ b/mail-client/mutt/files/Muttrc
@@ -0,0 +1,19 @@
+# Some minimal Mutt settings, Gentoo-style. These reflect the Gentoo
+# predilection for maildir folders.
+#
+# Please don't add settings to this file to change other user
+# preferences (such as colors), since those can be hard for a user to
+# undo if their preference doesn't match yours! For example, it is
+# *impossible* currently in mutt to remove color settings from objects
+# other than the index.
+
+set mbox_type=Maildir
+set folder=~/.maildir
+set spoolfile=~/.maildir/
+set record=~/.maildir-sent/
+set move=no
+
+# Maybe we shouldn't set index_format here, but this is a recommended
+# one for maildir-style folders.
+
+set index_format="%4C %Z %{%b %d} %-16.16L %s"
diff --git a/mail-client/mutt/files/Muttrc.mbox b/mail-client/mutt/files/Muttrc.mbox
new file mode 100644
index 00000000..1382a374
--- /dev/null
+++ b/mail-client/mutt/files/Muttrc.mbox
@@ -0,0 +1,9 @@
+# Some minimal Mutt settings, Gentoo-style. Since mutt was installed
+# with USE=mbox, this file doesn't have any changes from the default
+# mutt settings, making it very minimal indeed...
+#
+# Please don't add settings to this file to change other user
+# preferences (such as colors), since those can be hard for a user to
+# undo if their preference doesn't match yours! For example, it is
+# *impossible* currently in mutt to remove color settings from objects
+# other than the index.
diff --git a/mail-client/mutt/files/digest-mutt-1.5.8-r3 b/mail-client/mutt/files/digest-mutt-1.5.8-r3
new file mode 100644
index 00000000..ad138ec6
--- /dev/null
+++ b/mail-client/mutt/files/digest-mutt-1.5.8-r3
@@ -0,0 +1,9 @@
+MD5 9b9bdef4ef7107332f8782b3a910d00e mutt-1.5.8i.tar.gz 3010088
+MD5 44df2038c3cb03b1f6f5d0b998a64aed patch-1.5.5.1.cd.edit_threads.9.5-gentoo-r1.bz2 6269
+MD5 c20f30c8cb6002a503aa373c5934f3bb patch-1.5.6.tt.assumed_charset.1.gz 4640
+MD5 994108508f9890329ff4ee07604a374d patch-1.5.8.rr.compressed.gz 10230
+MD5 1ea285e44d0fe45eb841559914b57170 patch-1.5.6.dw.mbox-hook.1 6445
+MD5 80e81a9df998d6c65821b21a864e45ed patch-1.5.8.vvv.nntp-gentoo.bz2 71780
+MD5 404cb8677bb50937405531931629562f mutt-1.5.7-mixmaster+nntp.patch 310
+MD5 8bd12eb073ef94712f3a88eb8493f195 mutt-cvs-header-cache.29 5120
+MD5 758dff57c494e86ac885ef2ecb736f11 patch-1.5.6.dw.pgp-timeout.1 1448
diff --git a/mail-client/mutt/files/patch-1.5.8.vvv.nntp-gentoo-r2.bz2 b/mail-client/mutt/files/patch-1.5.8.vvv.nntp-gentoo-r2.bz2
new file mode 100644
index 00000000..73601f10
--- /dev/null
+++ b/mail-client/mutt/files/patch-1.5.8.vvv.nntp-gentoo-r2.bz2
Binary files differ
diff --git a/mail-client/mutt/files/slang.patch b/mail-client/mutt/files/slang.patch
new file mode 100644
index 00000000..f3740bdc
--- /dev/null
+++ b/mail-client/mutt/files/slang.patch
@@ -0,0 +1,19 @@
+diff -Naurbd mutt-1.5.6~orig/menu.c mutt-1.5.6/menu.c
+--- mutt-1.5.6~orig/menu.c 2004-02-12 01:00:30.537293896 +0000
++++ mutt-1.5.6/menu.c 2004-02-12 01:00:35.748501672 +0000
+@@ -45,6 +45,7 @@
+ {
+ if (*s < M_TREE_MAX)
+ {
++#ifndef USE_SLANG_CURSES
+ if (do_color)
+ {
+ pair_content(PAIR_NUMBER(ColorDefs[MT_COLOR_TREE]), &f1, &b1);
+@@ -52,6 +53,7 @@
+ if (b1 == b2)
+ SETCOLOR (MT_COLOR_TREE);
+ }
++#endif
+ while (*s && *s < M_TREE_MAX)
+ {
+ switch (*s)
diff --git a/mail-client/mutt/mutt-1.5.8-r3.ebuild b/mail-client/mutt/mutt-1.5.8-r3.ebuild
new file mode 100644
index 00000000..acd75da9
--- /dev/null
+++ b/mail-client/mutt/mutt-1.5.8-r3.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.8-r2.ebuild,v 1.1 2005/03/17 22:36:34 agriffis Exp $
+
+inherit eutils flag-o-matic
+IUSE="cjk ssl nls slang crypt imap mbox nntp sasl buffysize vanilla"
+
+edit_threads_patch="patch-1.5.5.1.cd.edit_threads.9.5-gentoo-r1.bz2"
+compressed_patch="patch-${PV}.rr.compressed.gz"
+nntp_patch="patch-${PV}.vvv.nntp-gentoo.bz2"
+mbox_hook_patch="patch-1.5.6.dw.mbox-hook.1"
+header_cache_patch="mutt-cvs-header-cache.29"
+pgp_timeout_patch="patch-1.5.6.dw.pgp-timeout.1"
+assumed_charset_patch="patch-1.5.6.tt.assumed_charset.1.gz"
+
+DESCRIPTION="a small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org"
+SRC_URI="ftp://ftp.mutt.org/mutt/devel/mutt-${PV}i.tar.gz
+ !vanilla? (
+ mirror://gentoo/${edit_threads_patch}
+ http://www.emaillab.org/mutt/1.5/${assumed_charset_patch}
+ http://mutt.kiev.ua/download/${P}/${compressed_patch}
+ http://www.woolridge.ca/mutt/patches/${mbox_hook_patch}
+ nntp? (
+ mirror://gentoo/${nntp_patch}
+ mirror://gentoo/mutt-1.5.7-mixmaster+nntp.patch
+ )
+ http://wwwcip.informatik.uni-erlangen.de/~sithglan/mutt/${header_cache_patch}
+ http://www.woolridge.ca/mutt/patches/${pgp_timeout_patch}
+ )"
+# http://cedricduval.free.fr/mutt/patches/download/${edit_threads_patch}
+
+RDEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ !vanilla? ( sys-libs/gdbm )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+DEPEND="${RDEPEND}
+ net-mail/mailbase
+ !vanilla? ( sys-devel/automake sys-devel/autoconf )"
+
+SLOT="0"
+LICENSE="GPL-2"
+#KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~ia64 ~amd64 ~mips ~ppc64 ~ppc-macos"
+
+src_unpack() {
+ unpack ${P}i.tar.gz && cd ${S} || die "unpack failed"
+ if ! use vanilla; then
+ epatch ${DISTDIR}/${compressed_patch}
+ epatch ${DISTDIR}/${edit_threads_patch}
+ epatch ${DISTDIR}/${mbox_hook_patch}
+ epatch ${DISTDIR}/${header_cache_patch}
+ epatch ${DISTDIR}/${pgp_timeout_patch}
+ epatch ${DISTDIR}/${assumed_charset_patch}
+ epatch ${DISTDIR}/${auto_decode_patch}
+ if use nntp; then
+ nntp_patch=`echo ${nntp_patch} | sed -r 's/(.*).bz2/\1-r2.bz2/'` # Resolv #85715
+ epatch ${FILESDIR}/${nntp_patch}
+ # Allow mutt to build with mixmaster and nntp both enabled
+ epatch ${DISTDIR}/mutt-1.5.7-mixmaster+nntp.patch
+ fi
+
+ # The following steps are necessary for the nntp patch and the
+ # header_cache_patch
+ aclocal -I m4 || die "aclocal failed"
+ autoheader || die "autoheader failed"
+ emake -C m4 -f Makefile.am.in || die "emake in m4 failed"
+ automake --foreign || die "automake failed"
+ WANT_AUTOCONF=2.13 autoconf || die "autoconf failed"
+ fi
+}
+
+src_compile() {
+ local myconf="
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use_enable imap) \
+ $(use_enable crypt pgp) \
+ $(use_enable crypt smime) \
+ $(use_enable cjk default-japanese) \
+ $(use_with sasl sasl2) \
+ --enable-compressed \
+ --with-mixmaster \
+ --sysconfdir=/etc/mutt \
+ --with-docdir=/usr/share/doc/mutt-${PVR} \
+ --with-regex --enable-pop --enable-nfs-fix \
+ --disable-fcntl --enable-flock --enable-external-dotlock"
+
+ # See Bug #22787
+ unset WANT_AUTOCONF_2_5 WANT_AUTOCONF
+
+ # See Bug #11170
+ case ${ARCH} in
+ alpha|ppc) replace-flags "-O[3-9]" "-O2" ;;
+ esac
+
+ if use buffysize; then
+ ewarn "You're using --enable-buffy-size. This is just a workaround. Disable it if you don't need it."
+ myconf="${myconf} --enable-buffy-size"
+ fi
+
+ if use slang; then
+ myconf="${myconf} --with-slang"
+ ewarn "If you want a transparent background,"
+ ewarn "please merge mutt with USE=-slang."
+ else
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+ myconf="${myconf} --with-curses"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-maildir=/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ if ! use vanilla; then
+ # imap part of edit_threads patch
+ myconf="${myconf} $(use_enable imap imap-edit-threads)"
+
+ # rr.compressed patch
+ myconf="${myconf} --enable-compressed"
+
+ # nntp patch
+ myconf="${myconf} $(use_enable nntp)"
+
+ # maildir_header_cache_patch
+ myconf="${myconf} --enable-hcache"
+ fi
+
+ econf ${myconf}
+ emake || die "emake failed (myconf=${myconf})"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+ find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if use mbox; then
+ insinto /etc/mutt
+ newins ${FILESDIR}/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins ${FILESDIR}/Muttrc
+ fi
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}