summaryrefslogtreecommitdiff
path: root/mail-client/roundcube
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2009-04-17 14:48:24 +0200
committerBertrand Jacquin <beber@meleeweb.net>2009-04-17 14:48:24 +0200
commit71cb88b0186ee313afad187739be373d010ea085 (patch)
tree03c8a121e47eb5ff675818db57a37021bcd21aca /mail-client/roundcube
parentwdd: init script need 755 (diff)
downloadportage-71cb88b0186ee313afad187739be373d010ea085.tar.xz
roundcube: new release
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest4
-rw-r--r--mail-client/roundcube/roundcube-0.2.ebuild83
-rw-r--r--mail-client/roundcube/roundcube-0.2_beta2.ebuild83
3 files changed, 170 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 2f593bda..9c1225da 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -2,5 +2,9 @@ AUX postinstall-en.txt 2513 RMD160 c2a04efcdd4007642221797a10877c2fc57ad874 SHA1
AUX roundcube-0.1-no-sockets-check.patch 2435 RMD160 1d03b74d38693edc6f816f2e34422d2b46442751 SHA1 62a5d11dc2bb437543eb449e4e6f4014a95c3ccf SHA256 3075384ee99ce0b5f0077b6a56e2a140afb00af6e12d6e32863ec14d03cd8696
DIST roundcubemail-0.1.tar.gz 1406854 RMD160 225b3a37c70bcf3b471b7d650233aec30dae2f76 SHA1 8b5b516b41bad98c3bbaf0da0e70b0db82580424 SHA256 ea4f4b23b9a20308cc0b1fef3b7301700c9ce4544189007bc62756e8d5f67051
DIST roundcubemail-0.2-alpha.1.tar.gz 1378289 RMD160 b87768e5e11d474da9a8783c96b92354e47074a6 SHA1 af40c639d4815cc54b7287724925b807a52e8490 SHA256 abbfd96e4fdeb3183d842cb00c7c25abbff88ade98c4e352c125ea2ef008355a
+DIST roundcubemail-0.2-beta2.tar.gz 1611313 RMD160 348f59b578ca86b96a1aaf3e395d457a89e9096e SHA1 2f6e17d649111d204c6cc92cdc8fdf6461d5a797 SHA256 35a22dd75c42c54816616633112cae3605e953cd05937e1f6dc71a6837ba75ab
+DIST roundcubemail-0.2-stable.tar.gz 1672535 RMD160 13f252bf334d7fb7f84d3ba92d72ce54c595a4ca SHA1 8abefd7b442e0fa95b72d757091d60979054d624 SHA256 86de36fec5cfc4217d5376fa74e27645d3c414ad18fa8554abc909709f1a9107
EBUILD roundcube-0.1.ebuild 2754 RMD160 a3a6a933b79881d6eb0fbc8e6c4c78e9e3e63a13 SHA1 f63a4ddea99fd306eef8af6f1e0881f1d5edc5ed SHA256 87a066609833ec391a3cd461e24bb1fb803389108c2c7e06e123f61ef31a6c31
+EBUILD roundcube-0.2.ebuild 2728 RMD160 f0fd44440ecc493a02e0f92c5e774fb66e0cebdd SHA1 de49885916eedc30ce12436d8e99b0e5e248932c SHA256 6f6d83a795a4db1844e71a10f09207d3734b82d8a62d04f8b962fe80fc63b379
EBUILD roundcube-0.2_alpha.ebuild 2748 RMD160 136fa4fa9e9b9a35d36853305b119996befd6b67 SHA1 a93b51624135c5e266b38412322f57c0a3798739 SHA256 91a04a631a49353d2979941ba59a83d74a73ea11f7427e9d742c9411afe473f7
+EBUILD roundcube-0.2_beta2.ebuild 2727 RMD160 1ff1cdcd2aef597d2ff48ff1fb9e6a184c504c14 SHA1 9e1e73c33a5d062679c0a9caef0f220eef28ef42 SHA256 54abefa0c5fef72267953558c3f998ec9d050bf1123b03df2ec56c9c9ee59b39
diff --git a/mail-client/roundcube/roundcube-0.2.ebuild b/mail-client/roundcube/roundcube-0.2.ebuild
new file mode 100644
index 00000000..43b9b42e
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp depend.php depend.apache
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-0.2-stable"
+DESCRIPTION="A browser-based multilingual IMAP client using AJAX"
+HOMEPAGE="http://www.roundcube.net"
+RESTRICT="nomirror"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sqlite ssl spell"
+
+RDEPEND="dev-php/PEAR-PEAR"
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre session unicode"
+ use ldap && flags="${flags} ldap"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in postgres sqlite ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
+ fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+ use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
+ use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
+ use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}
diff --git a/mail-client/roundcube/roundcube-0.2_beta2.ebuild b/mail-client/roundcube/roundcube-0.2_beta2.ebuild
new file mode 100644
index 00000000..1af8c545
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.2_beta2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp depend.php depend.apache
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-0.2-beta2"
+DESCRIPTION="A browser-based multilingual IMAP client using AJAX"
+HOMEPAGE="http://www.roundcube.net"
+RESTRICT="nomirror"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sqlite ssl spell"
+
+RDEPEND="dev-php/PEAR-PEAR"
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre session unicode"
+ use ldap && flags="${flags} ldap"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in postgres sqlite ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
+ fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+ use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
+ use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
+ use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}