summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:22:40 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:02 +0100
commitf3a343a2a1f4b15e44c6e8e2bb257f07c1cb348b (patch)
treeb84b9e3194701dc52a56dd50b01870c3925d1f33 /flx
parentflx/initramfs: move to EAPI 7 (diff)
downloadportage-f3a343a2a1f4b15e44c6e8e2bb257f07c1cb348b.tar.xz
flx/init-scripts: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'flx')
-rw-r--r--flx/init-scripts/init-scripts-0.4.0.ebuild28
-rw-r--r--flx/init-scripts/init-scripts-9999.ebuild28
2 files changed, 26 insertions, 30 deletions
diff --git a/flx/init-scripts/init-scripts-0.4.0.ebuild b/flx/init-scripts/init-scripts-0.4.0.ebuild
index 7033d98a..c2a8794b 100644
--- a/flx/init-scripts/init-scripts-0.4.0.ebuild
+++ b/flx/init-scripts/init-scripts-0.4.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 eutils
DESCRIPTION="Formilux Tools"
@@ -14,19 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${PV}-network-Handle-unreacheable-prohibit-local-etc-iprou.patch"
- eapply "${FILESDIR}/${PV}-network-Handle-IPv6-sysctl.patch"
- eapply "${FILESDIR}/${PV}-network-Strip-spaces.patch"
- eapply "${FILESDIR}/${PV}-network-Remove-unused-code.patch"
- eapply "${FILESDIR}/${PV}-firewall-ip_conntrack-have-been-replaced-by-nf_connt.patch"
- eapply "${FILESDIR}/${PV}-firewall-white-space-cleanup.patch"
- eapply "${FILESDIR}/${PV}-firewall-conntrack-sysctl-ipv4-and-ipv6-are-common.patch"
- eapply "${FILESDIR}/${PV}-thttpd-Add-cgi-config-token.patch"
- eapply "${FILESDIR}/${PV}-Update-executable-path.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PV}-network-Handle-unreacheable-prohibit-local-etc-iprou.patch"
+ "${FILESDIR}/${PV}-network-Handle-IPv6-sysctl.patch"
+ "${FILESDIR}/${PV}-network-Strip-spaces.patch"
+ "${FILESDIR}/${PV}-network-Remove-unused-code.patch"
+ "${FILESDIR}/${PV}-firewall-ip_conntrack-have-been-replaced-by-nf_connt.patch"
+ "${FILESDIR}/${PV}-firewall-white-space-cleanup.patch"
+ "${FILESDIR}/${PV}-firewall-conntrack-sysctl-ipv4-and-ipv6-are-common.patch"
+ "${FILESDIR}/${PV}-thttpd-Add-cgi-config-token.patch"
+ "${FILESDIR}/${PV}-Update-executable-path.patch"
+)
src_install() {
cd "${S}/etc"
diff --git a/flx/init-scripts/init-scripts-9999.ebuild b/flx/init-scripts/init-scripts-9999.ebuild
index 9b3e0e50..6a904eef 100644
--- a/flx/init-scripts/init-scripts-9999.ebuild
+++ b/flx/init-scripts/init-scripts-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 eutils
DESCRIPTION="Formilux Tools"
@@ -13,19 +13,17 @@ SLOT="0"
KEYWORDS=""
IUSE="debug"
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${PV}-network-Handle-unreacheable-prohibit-local-etc-iprou.patch"
- eapply "${FILESDIR}/${PV}-network-Handle-IPv6-sysctl.patch"
- eapply "${FILESDIR}/${PV}-network-Strip-spaces.patch"
- eapply "${FILESDIR}/${PV}-network-Remove-unused-code.patch"
- eapply "${FILESDIR}/${PV}-firewall-ip_conntrack-have-been-replaced-by-nf_connt.patch"
- eapply "${FILESDIR}/${PV}-firewall-white-space-cleanup.patch"
- eapply "${FILESDIR}/${PV}-firewall-conntrack-sysctl-ipv4-and-ipv6-are-common.patch"
- eapply "${FILESDIR}/${PV}-thttpd-Add-cgi-config-token.patch"
- eapply "${FILESDIR}/${PV}-Update-executable-path.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PV}-network-Handle-unreacheable-prohibit-local-etc-iprou.patch"
+ "${FILESDIR}/${PV}-network-Handle-IPv6-sysctl.patch"
+ "${FILESDIR}/${PV}-network-Strip-spaces.patch"
+ "${FILESDIR}/${PV}-network-Remove-unused-code.patch"
+ "${FILESDIR}/${PV}-firewall-ip_conntrack-have-been-replaced-by-nf_connt.patch"
+ "${FILESDIR}/${PV}-firewall-white-space-cleanup.patch"
+ "${FILESDIR}/${PV}-firewall-conntrack-sysctl-ipv4-and-ipv6-are-common.patch"
+ "${FILESDIR}/${PV}-thttpd-Add-cgi-config-token.patch"
+ "${FILESDIR}/${PV}-Update-executable-path.patch"
+)
src_install() {
cd "${S}/etc"