summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-06-08 18:34:06 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-06-08 19:55:57 +0200
commitad294ee4c5bbec491d5b9ba81dcb75aa6466e520 (patch)
treea2515bee6b110673a0a66dd82bc7f7e21027bb59 /flx
parentsys-fs/mtd-utils: Fixes applied upstream, #446202 (diff)
downloadportage-ad294ee4c5bbec491d5b9ba81dcb75aa6466e520.tar.xz
flx/dfc: Move from sys-apps, move to EAPI=5, respect CFLAGS and LDFLAGS
Package-Manager: portage-2.1.12.3
Diffstat (limited to 'flx')
-rw-r--r--flx/dfc/ChangeLog20
-rw-r--r--flx/dfc/Manifest5
-rw-r--r--flx/dfc/dfc-9999.ebuild35
-rw-r--r--flx/dfc/files/9999-warning-cast.diff61
-rw-r--r--flx/dfc/files/remount-sstrip.diff8
-rw-r--r--flx/dfc/metadata.xml4
6 files changed, 133 insertions, 0 deletions
diff --git a/flx/dfc/ChangeLog b/flx/dfc/ChangeLog
new file mode 100644
index 00000000..15e39962
--- /dev/null
+++ b/flx/dfc/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for sys-apps/dfc
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 28 May 2013; Bertrand Jacquin <beber@meleeweb.net> +metadata.xml:
+ Add missing metadata.xml
+
+ 28 May 2013; Bertrand Jacquin <beber@meleeweb.net> dfc-9999.ebuild:
+ Fix quotes
+
+ 27 May 2013; Bertrand Jacquin <beber@meleeweb.net> dfc-9999.ebuild,
+ +files/9999-warning-cast.diff:
+ update to eclass git-2 and fix warnings
+
+*dfc-9999 (22 Jul 2011)
+
+ 22 Jul 2011; Bertrand Jacquin <beber@meleeweb.net> +dfc-9999.ebuild,
+ +files/remount-sstrip.diff:
+ busybox dfc
+
diff --git a/flx/dfc/Manifest b/flx/dfc/Manifest
new file mode 100644
index 00000000..a80f0f0e
--- /dev/null
+++ b/flx/dfc/Manifest
@@ -0,0 +1,5 @@
+AUX 9999-warning-cast.diff 2198 SHA256 91c5fe95e6dbd81c1a098a2e417ad50e9ebc1a6590daa7fde8c10afa6b0ec69b WHIRLPOOL ff101f6c68f7971dbeb98cd45aff92596b19926caa01a33ec33d1b0afbd03977d8cf2943aab0808829dbf6a566f1340a909cef5349949fa4b93a74e0920e2493
+AUX remount-sstrip.diff 370 SHA256 200399addf766d1871da02a52fa1f3fb9c246ecb6327d2af33b1c36bab21ba0e WHIRLPOOL 9556880a94e0fcbdf77d8b3f7b4968247cbcff7fa6dfe3d67946c9b4c5cb1ca3b9c1a67d7063449cdccfaee26652ccc2634305da29910c89736465aea5b9065c
+EBUILD dfc-9999.ebuild 620 SHA256 774aeb788022eabf799439b1fe7b868534e96e613ced3d2f6e9989352d4549d4 WHIRLPOOL e335ac0fb9a7e04d9cb269fb62dbba11f0df66e6864faf4aa7419856a3df5fd596d5eb94a47b3c4f84b765997aa1a95471367a777839bc63291e8ec2bea4c1d7
+MISC ChangeLog 580 SHA256 6cf10a66d35216f4d4f18221c74b88dd0d487d22109b76e15291736cb24d02c2 WHIRLPOOL ead42c5221fc30390e04a1a1dd8af1c8c8aed9cc00364f7f098fae787be4256aa3d330170de3e8b5fd782e528435b44f716af21baa8c5901e893a76022ccfc20
+MISC metadata.xml 139 SHA256 5cdc1888ebc8807b9a37b1d33429c61cabe7415a4f240e21a4c2ff8eca7a34ed WHIRLPOOL 620431014dd4fb752c3d46d11904ecb2c6d4525f5b4e30f4f778a3b74d3f7187ae4ccd856ebd7eabb48ce261b21849c732928fe647edce024a3fdc082d8f8630
diff --git a/flx/dfc/dfc-9999.ebuild b/flx/dfc/dfc-9999.ebuild
new file mode 100644
index 00000000..18158592
--- /dev/null
+++ b/flx/dfc/dfc-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit git-2 toolchain-funcs eutils
+
+DESCRIPTION="Formilux Tools"
+HOMEPAGE="http://master.formilux.org/git/people/ben/dfc.git"
+EGIT_REPO_URI="http://master.formilux.org/git/people/ben/dfc.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare ()
+{
+ epatch "${FILESDIR}/${PV}-warning-cast.diff"
+
+ sed -i \
+ -e "/^CFLAGS=/ s:=.*:=${CFLAGS}:" \
+ -e "/^LDFLAGS=/ s:=.*:=${LDFLAGS}:" \
+ Makefile
+
+ tc-export CC
+}
+
+src_install ()
+{
+ into /usr
+ dobin dfc
+}
diff --git a/flx/dfc/files/9999-warning-cast.diff b/flx/dfc/files/9999-warning-cast.diff
new file mode 100644
index 00000000..e26af997
--- /dev/null
+++ b/flx/dfc/files/9999-warning-cast.diff
@@ -0,0 +1,61 @@
+diff --git a/dfc.c b/dfc.c
+index 91eb5df..9a0ed57 100644
+--- a/dfc.c
++++ b/dfc.c
+@@ -12,7 +12,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#define _XOPEN_SOURCE /* glibc2 needs this */
++#define __USE_XOPEN /* glibc2 needs this */
+ #include <time.h>
+ #include <limits.h>
+ #include <unistd.h>
+@@ -307,7 +307,7 @@ time_t strptime_mktime(const char *s, const char *format, struct tm *tm) {
+ }
+ tm->tm_isdst = 0;
+
+- p = (char*)strptime(s, format, tm);
++ p = strptime((char *)s, format, tm);
+ if (!p || *p)
+ return ((time_t)-1);
+
+@@ -394,7 +394,7 @@ int main(int argc, char **argv) {
+ char *p;
+
+ if ((p = strchr(global_first_line_full_date, '='))) {
+- if (strptime(global_first_line_full_date, p+1, &ref_tm) == -1) {
++ if (strptime(global_first_line_full_date, p+1, &ref_tm) == (char *)-1) {
+ ERROR("bad reference time or format");
+ exit(2);
+ }
+@@ -479,7 +479,7 @@ int main(int argc, char **argv) {
+ if (date_field >= 0) {
+ // check date on group number 'date_field',
+ // global_date_filter_field need to set to enable this condition
+- if (!(ptmp = (void*)strptime(tmp + REG_PTR(m, date_field),
++ if (!(ptmp = strptime(tmp + REG_PTR(m, date_field),
+ global_input_date_format, &tm))) {
+ fprintf(stderr, "UNPARSABLE: %s", tmp + REG_PTR(m, date_field));
+ continue;
+@@ -487,7 +487,7 @@ int main(int argc, char **argv) {
+ }
+ else {
+ // single call to localtime at begin of line
+- if (!(ptmp = (void*)strptime(tmp, global_input_date_format, &tm))) {
++ if (!(ptmp = strptime(tmp, global_input_date_format, &tm))) {
+ fprintf(stderr, "UNPARSABLE: %s", tmp);
+ continue;
+ }
+@@ -607,9 +607,9 @@ int main(int argc, char **argv) {
+ }
+
+ if (global_track_past_return) {
+- fprintf(stderr, "NEGATIVE-PAST-RETURN (%d)\nL1: %sL2: %s",
++ fprintf(stderr, "NEGATIVE-PAST-RETURN (%ld)\nL1: %sL2: %s",
+ negative_tm_diff, negative_old_line, negative_cur_line);
+- fprintf(stderr, "POSITIVE-PAST-RETURN (%d)\nL1: %sL2: %s",
++ fprintf(stderr, "POSITIVE-PAST-RETURN (%ld)\nL1: %sL2: %s",
+ positive_tm_diff, positive_old_line, positive_cur_line);
+
+ }
diff --git a/flx/dfc/files/remount-sstrip.diff b/flx/dfc/files/remount-sstrip.diff
new file mode 100644
index 00000000..a9ca6ef5
--- /dev/null
+++ b/flx/dfc/files/remount-sstrip.diff
@@ -0,0 +1,8 @@
+--- remount/Makefile.ori 2009-04-24 13:54:14.000000000 +0200
++++ remount/Makefile 2009-04-24 13:54:59.000000000 +0200
+@@ -9,4 +9,4 @@
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
+ $(STRIP) -x --strip-unneeded -R .comment -R .note $@
+ $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
+- sstrip $@
++ -if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi
diff --git a/flx/dfc/metadata.xml b/flx/dfc/metadata.xml
new file mode 100644
index 00000000..097975e3
--- /dev/null
+++ b/flx/dfc/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>