summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-06 20:55:00 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-09-14 21:01:57 +0100
commit84a9a396eddd4653c648bf2282da2fcdbe6b55d9 (patch)
tree29958274e34a847c8bc815ad266843aa449ce69e /flx
parentflx/init-clamav: Move patch here (diff)
downloadportage-84a9a396eddd4653c648bf2282da2fcdbe6b55d9.tar.xz
flx/init-frox: Move patch here
Package-Manager: portage-2.2.28
Diffstat (limited to 'flx')
-rw-r--r--flx/init-frox/Manifest3
-rw-r--r--flx/init-frox/files/0.7-Add-initscript.patch25
-rw-r--r--flx/init-frox/init-frox-0.7.ebuild9
3 files changed, 34 insertions, 3 deletions
diff --git a/flx/init-frox/Manifest b/flx/init-frox/Manifest
index 289d64d4..7a5bb554 100644
--- a/flx/init-frox/Manifest
+++ b/flx/init-frox/Manifest
@@ -1,2 +1,3 @@
-EBUILD init-frox-0.7.ebuild 327 SHA256 ef65ac97205b82cc67999789ecb367416b36b3fb6383f17e69996bdb799f3c2c WHIRLPOOL 09d20b4994a11337b278765ecdf2b538dfc45a9c479c11edf43254370f2b2193419640f86f564d12fd30db9aa12afc02b74e678d7ddf2025b53744b5bc3830c7
+AUX 0.7-Add-initscript.patch 646 SHA256 5f4e972aa8c1c891719410f145e5f26231887da31a121a7ef3f3bdaca5537602 WHIRLPOOL 6ab1d282548e12ba8c37c1dc60319f8e22ca5c2ef1750e5f75342f526557ba2ac16a8b9e2bbbdde1c789678d3f352bd44d3685c755cbf115a6ed0148b92515f5
+EBUILD init-frox-0.7.ebuild 331 SHA256 fc7472c11ce8e90d616bf1d8af7796b6b06936374c8c923ed5e7a93094766837 WHIRLPOOL 21a234292cc2584cadf8686c8d840cbf0e6cf4d6af36907d1cb14f946390514cb09e3efddf113fab6213da25cc55d86332c6cf6f02fe1cdea34117be60a97dc2
MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/flx/init-frox/files/0.7-Add-initscript.patch b/flx/init-frox/files/0.7-Add-initscript.patch
new file mode 100644
index 00000000..6d67d3f7
--- /dev/null
+++ b/flx/init-frox/files/0.7-Add-initscript.patch
@@ -0,0 +1,25 @@
+From 19775e6fcc7a2c11a7bf83921c7737028f90299c Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 4 Dec 2011 01:24:13 +0100
+Subject: [PATCH] Add initscript
+
+---
+ add-ons/initscript | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+ create mode 100644 add-ons/initscript
+
+diff --git add-ons/initscript add-ons/initscript
+new file mode 100644
+index 0000000..2659875
+--- /dev/null
++++ add-ons/initscript
+@@ -0,0 +1,9 @@
++#!/bin/bash
++
++. $(dirname $0)/functions
++
++option bin reserved_option /usr/sbin/frox
++option config standard_option /etc/frox.conf
++option cmdline reserved_option '$bin -f $opt_config'
++
++load_config
diff --git a/flx/init-frox/init-frox-0.7.ebuild b/flx/init-frox/init-frox-0.7.ebuild
index fb5ccde1..703853f6 100644
--- a/flx/init-frox/init-frox-0.7.ebuild
+++ b/flx/init-frox/init-frox-0.7.ebuild
@@ -5,9 +5,14 @@
EAPI=6
inherit flx-init-scripts
-EGIT_REPO_URI="http://master.formilux.org/git/people/beber/pkg/frox.git"
EGIT_BRANCH="0.7-flx0"
-#EGIT_COMMIT="v0.7.18-flx0.1"
+EGIT_COMMIT="v0.7.18-flx0.1"
KEYWORDS="amd64 x86"
RDEPEND=">=net-ftp/frox-${PV}"
+
+src_prepare() {
+ default
+
+ epatch "${FILESDIR}/${PV}-Add-initscript.patch"
+}