summaryrefslogtreecommitdiff
path: root/flx/initramfs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-03 14:18:40 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-09-04 00:07:29 +0100
commit24b203f06d04624d622f8940a2f5012f7146f5e9 (patch)
tree605c1d59f8c9ecdf117ddad56f0679f0680649fc /flx/initramfs
parentflx/init-openvpn: Move to EAPI 6 (diff)
downloadportage-24b203f06d04624d622f8940a2f5012f7146f5e9.tar.xz
flx/initramfs: Move to EAPI 6
Package-Manager: portage-2.2.28
Diffstat (limited to 'flx/initramfs')
-rw-r--r--flx/initramfs/Manifest2
-rw-r--r--flx/initramfs/initramfs-0.ebuild13
2 files changed, 6 insertions, 9 deletions
diff --git a/flx/initramfs/Manifest b/flx/initramfs/Manifest
index 801693ce..5b98f9ad 100644
--- a/flx/initramfs/Manifest
+++ b/flx/initramfs/Manifest
@@ -1,2 +1,2 @@
-EBUILD initramfs-0.ebuild 1818 SHA256 5308a7f3558158e7f49aa8153a3190a7580a8ee401966393fcfc51d30035fa7f WHIRLPOOL 39a25ebe53bed089ab356e4e875309b42adaf7a0828e67fc85eda5bb2954a936a254f70c641d6657a61bd3c1966af443d334506cc777aa37aa74af36d66e2c0e
+EBUILD initramfs-0.ebuild 1818 SHA256 a2370e794deb800684dd866cf23e77e4af6a30879d29a9ddb72cca0d37979c3c WHIRLPOOL 117404606a3e553fbf42847aecd6019ff8bacfb6b20db20e45306617d4b7fc973140b493e09f5b7cd2b959de4ccb93bc2702cd2febcdb87261884e691b7be65e
MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/flx/initramfs/initramfs-0.ebuild b/flx/initramfs/initramfs-0.ebuild
index 607f8f07..92c98187 100644
--- a/flx/initramfs/initramfs-0.ebuild
+++ b/flx/initramfs/initramfs-0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit flx-tools
DESCRIPTION="build initramfs"
@@ -25,14 +25,12 @@ DEF_LZMA_FLAGS="--best"
DEF_LZO_FLAGS="--best"
DEF_XZ_FLAGS="--best"
-src_unpack ()
-{
+src_unpack () {
mkdir "${S}"
unpack_plist initramfs "${S}/fs"
}
-src_compile ()
-{
+src_compile () {
check_symbol "${S}/fs"
big_compress "${S}/fs"
@@ -76,8 +74,7 @@ src_compile ()
fi
}
-src_install ()
-{
+src_install () {
insinto /fs
doins initramfs.cpio