summaryrefslogtreecommitdiff
path: root/flx/init
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:08:17 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:01 +0100
commit92196a19e68bb74ae4fab5077c783d4f74e87592 (patch)
tree007cd6bba044e45ac02c17214f0d5db7d0d82414 /flx/init
parentflx/flx: move to EAPI 7 (diff)
downloadportage-92196a19e68bb74ae4fab5077c783d4f74e87592.tar.xz
flx/init: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'flx/init')
-rw-r--r--flx/init/init-0.1.35.ebuild17
-rw-r--r--flx/init/init-9999.ebuild15
2 files changed, 15 insertions, 17 deletions
diff --git a/flx/init/init-0.1.35.ebuild b/flx/init/init-0.1.35.ebuild
index 4b8f9c5c..892d16f7 100644
--- a/flx/init/init-0.1.35.ebuild
+++ b/flx/init/init-0.1.35.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 flag-o-matic toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
@@ -14,16 +14,15 @@ SLOT="0"
KEYWORDS="amd64 mips x86"
IUSE="debug static symlink"
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PV}-init-fix-a-major-bug-in-interactive-mode.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-init-fix-a-major-bug-in-interactive-mode.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}
@@ -41,7 +40,7 @@ src_install () {
into /
dosbin init/flx-init
use symlink \
- && dosym /sbin/flx-init /init
+ && dosym /sbin/flx-init /init
dodoc init/README{,.2} init/test.cfg
dodoc -r init/examples
diff --git a/flx/init/init-9999.ebuild b/flx/init/init-9999.ebuild
index d46a0bfc..1b94b64f 100644
--- a/flx/init/init-9999.ebuild
+++ b/flx/init/init-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 flag-o-matic toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
@@ -13,15 +13,14 @@ SLOT="0"
KEYWORDS=""
IUSE="debug static symlink"
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}
@@ -39,7 +38,7 @@ src_install () {
into /
dosbin init/flx-init
use symlink \
- && dosym /sbin/flx-init /init
+ && dosym /sbin/flx-init /init
dodoc init/README{,.2} init/test.cfg
dodoc -r init/examples