summaryrefslogtreecommitdiff
path: root/flx/init
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2023-01-21 16:46:11 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2023-01-21 17:16:14 +0000
commit4395f91951a7dd9534677ffa25a420a874942898 (patch)
treedbdd2c5240ecb7f01f0219d9d7db5fcb941b3cf3 /flx/init
parentflx/remount: deprecate eutils (diff)
downloadportage-4395f91951a7dd9534677ffa25a420a874942898.tar.xz
flx/init: deprecate eutils
Diffstat (limited to 'flx/init')
-rw-r--r--flx/init/files/0.1.35-init-implicit-declaration-of-makedev.patch34
-rw-r--r--flx/init/init-0.1.35.ebuild3
-rw-r--r--flx/init/init-9999.ebuild2
3 files changed, 37 insertions, 2 deletions
diff --git a/flx/init/files/0.1.35-init-implicit-declaration-of-makedev.patch b/flx/init/files/0.1.35-init-implicit-declaration-of-makedev.patch
new file mode 100644
index 00000000..5a69349f
--- /dev/null
+++ b/flx/init/files/0.1.35-init-implicit-declaration-of-makedev.patch
@@ -0,0 +1,34 @@
+From 8f86cd216563d5df08bd23f37fe84f7c25e116f3 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 21 Jan 2023 16:43:07 +0000
+Subject: [PATCH] init: implicit declaration of makedev
+
+---
+ init/init.c | 1 +
+ init/mkdev.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/init/init.c b/init/init.c
+index e0a45d94f09f..4d51701061e4 100644
+--- a/init/init.c
++++ b/init/init.c
+@@ -204,6 +204,7 @@ wrong for now:
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <linux/loop.h>
++#include <sys/sysmacros.h>
+
+ #ifndef MNT_DETACH
+ #define MNT_DETACH 2
+diff --git a/init/mkdev.c b/init/mkdev.c
+index 47e4aa09ed11..544db1e012f4 100644
+--- a/init/mkdev.c
++++ b/init/mkdev.c
+@@ -49,6 +49,7 @@
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+ #include <linux/loop.h>
++#include <sys/sysmacros.h>
+
+
+ //#ifdef DEBUG
diff --git a/flx/init/init-0.1.35.ebuild b/flx/init/init-0.1.35.ebuild
index 892d16f7..23e9a750 100644
--- a/flx/init/init-0.1.35.ebuild
+++ b/flx/init/init-0.1.35.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 flag-o-matic toolchain-funcs eutils
+inherit git-r3 flag-o-matic toolchain-funcs
DESCRIPTION="Formilux Tools"
HOMEPAGE="http://git.formilux.org/?p=dist/src/flxutils.git"
@@ -18,6 +18,7 @@ PATCHES=(
"${FILESDIR}/${PV}-init-fix-a-major-bug-in-interactive-mode.patch"
"${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
"${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+ "${FILESDIR}/${PV}-init-implicit-declaration-of-makedev.patch"
)
src_prepare () {
diff --git a/flx/init/init-9999.ebuild b/flx/init/init-9999.ebuild
index 1b94b64f..a6458fbe 100644
--- a/flx/init/init-9999.ebuild
+++ b/flx/init/init-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 flag-o-matic toolchain-funcs eutils
+inherit git-r3 flag-o-matic toolchain-funcs
DESCRIPTION="Formilux Tools"
HOMEPAGE="http://git.formilux.org/?p=dist/src/flxutils.git"