summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-08-28 17:52:41 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-08-28 17:57:06 +0100
commitbed73bb3090d6baf4e197ce6c93dd39679d30a69 (patch)
tree86090c508c86e98b7137e30c04f31511871e76af /eclass
parenteclass/linux-build: Use kernel_is instead of KV comparison (diff)
downloadportage-bed73bb3090d6baf4e197ce6c93dd39679d30a69.tar.xz
eclass/linux-build: Adjust make opt since upstream commit a436bb7b80638 "kbuild: use relative path more to include Makefile"
Diffstat (limited to 'eclass')
-rw-r--r--eclass/linux-build.eclass5
1 files changed, 2 insertions, 3 deletions
diff --git a/eclass/linux-build.eclass b/eclass/linux-build.eclass
index 109a937e..a2e5dfd1 100644
--- a/eclass/linux-build.eclass
+++ b/eclass/linux-build.eclass
@@ -246,9 +246,8 @@ _linux-build_src_prepare_build() {
linux-build_src_prepare() {
bopt=(
- -C "${BUILDDIR}"
- -f "${SRCDIR}/Makefile"
- KBUILD_SRC="${SRCDIR}"
+ -C "${SRCDIR}"
+ KBUILD_OUTPUT="${BUILDDIR}"
KCONFIG_CONFIG="${BUILDDIR}/.config"
KBUILD_BUILD_USER="${KBUILD_BUILD_USER:-${PORTAGE_USERNAME}}"