summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-06-14 22:27:33 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-06-14 22:34:57 +0200
commit63ee9d23fbc48488d27a39b19698e9a656afb5a5 (patch)
treeb6b3e39bb95633b0925d9dd61bcd761c6388100d /dev-util
parentsys-kernel/stable-sources: Version bump (diff)
downloadportage-63ee9d23fbc48488d27a39b19698e9a656afb5a5.tar.xz
dev-util/mingw64-runtime: Add a live ebuild that fix issue with WINHTTP_AUTO_DETECT_TYPE_DHCP not declared in 2.0.7 nor 2.0.8
Original from http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-2.0.7.ebuild?revision=1.1 Package-Manager: portage-2.1.12.4
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw64-runtime/ChangeLog8
-rw-r--r--dev-util/mingw64-runtime/Manifest3
-rw-r--r--dev-util/mingw64-runtime/metadata.xml5
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-9999.ebuild78
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/ChangeLog b/dev-util/mingw64-runtime/ChangeLog
new file mode 100644
index 00000000..1834d2f9
--- /dev/null
+++ b/dev-util/mingw64-runtime/ChangeLog
@@ -0,0 +1,8 @@
+*mingw64-runtime-9999 (14 Jun 2013)
+
+ 14 Jun 2013; Bertrand Jacquin <beber@meleeweb.net> +metadata.xml,
+ +mingw64-runtime-9999.ebuild:
+ dev-util/mingw64-runtime: Add a live ebuild that fix issue with
+ WINHTTP_AUTO_DETECT_TYPE_DHCP not declared in 2.0.7 nor 2.0.8 Original from
+ http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-
+ util/mingw64-runtime/mingw64-runtime-2.0.7.ebuild?revision=1.1
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
new file mode 100644
index 00000000..f441b1b9
--- /dev/null
+++ b/dev-util/mingw64-runtime/Manifest
@@ -0,0 +1,3 @@
+EBUILD mingw64-runtime-9999.ebuild 2038 SHA256 7ece7b932b8aae3ecf30adc3d4a33adf1a378ac25256257818348170b9430fbd WHIRLPOOL be0101f2cfd9846561a0413b44b7ce3a7cf61d960fe132ddfb61d68faf9b68a3647dbdca98f6e41a5b102ac3354b4c37189877331afb66aea3c18faf513e03ba
+MISC ChangeLog 410 SHA256 a7d3a488bb2a80db3ce58b2bf1978b890e89a28327f1342daa0af58437c76605 WHIRLPOOL d73075b0d8c3c414a111d46ddfe5a73e3ddf0d5e26cfec8567c53235801af60e7cc6eb16c878dc5b228f6a02e1b3d35b5ae03acae8975abdcb14b0be1fd4eff2
+MISC metadata.xml 166 SHA256 7718b1e4a7ccc7422ac9730badfcc4e207f1c85bd8af8a3c81badcfc014fb6c2 WHIRLPOOL 1b204335aaaca5d2403af9fb268c9cf94f6ded2ef0b63138cf3cace16132cdaf7d3224e79eb6471c37b7be6dfae0348d7ba37b622619c30db2a7efebc4fd6b6b
diff --git a/dev-util/mingw64-runtime/metadata.xml b/dev-util/mingw64-runtime/metadata.xml
new file mode 100644
index 00000000..12f988b0
--- /dev/null
+++ b/dev-util/mingw64-runtime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>toolchain</herd>
+</pkgmetadata>
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-9999.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-9999.ebuild
new file mode 100644
index 00000000..749ee1f0
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-9999.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit flag-o-matic eutils subversion
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+ESVN_REPO_URI="https://mingw-w64.svn.sourceforge.net/svnroot/mingw-w64/trunk"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+S=${WORKDIR}/mingw-w64-v${PV}
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_compile() {
+ S="${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
+ cd "${S}"
+
+ # install the local headers as the crt step wants latest
+ pushd ../mingw-w64-headers >/dev/null
+ CHOST=${CTARGET} econf --enable-sdk || die
+ emake install DESTDIR="${WORKDIR}/sysroot" || die
+ popd >/dev/null
+
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ append-cppflags -isystem "${WORKDIR}/sysroot/usr/${CTARGET}/include"
+ CHOST=${CTARGET} econf --without-sysroot
+ emake || die
+}
+
+src_install() {
+ S="${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
+ cd "${S}"
+
+ insinto /usr/${CTARGET}/usr/include
+ doins -r "${WORKDIR}"/sysroot/usr/include/* || die
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+ just_headers && return 0
+
+ sysroot="${D}"
+ is_crosscompile && sysroot="${sysroot}/usr/${CTARGET}"
+
+ emake install DESTDIR="${sysroot}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${D}"/usr/doc
+}