summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-05-02 00:05:11 +0200
committerBertrand Jacquin <beber@meleeweb.net>2006-05-02 00:05:11 +0200
commit519f0960249486f504fbdd172bb99f06e2ad71d3 (patch)
tree9abc5ed5ebb07202d4f2dc50647f34c24333f29e /dev-util
parentusb-pwc-re: in portage now, delete (diff)
downloadportage-519f0960249486f504fbdd172bb99f06e2ad71d3.tar.xz
add a git git version
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/Manifest15
-rw-r--r--dev-util/git/files/digest-git-99991
-rw-r--r--dev-util/git/files/git-daemon.confd12
-rw-r--r--dev-util/git/files/git-daemon.initd22
-rw-r--r--dev-util/git/git-9999.ebuild116
5 files changed, 166 insertions, 0 deletions
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
new file mode 100644
index 00000000..d9d531d9
--- /dev/null
+++ b/dev-util/git/Manifest
@@ -0,0 +1,15 @@
+AUX git-daemon.confd 376 RMD160 70cbd0b87cbd2ce6b494f07ead732f33f7ea623f SHA1 3a00fa3af96d83bec1589d7ef53eff01ea838ea1 SHA256 266045958a3a4072529f25208d1f84a178bbb10aa0b6fa19543f7a62f9a5e3fe size 376
+MD5 5c96e23fef078682e648254d9197f618 files/git-daemon.confd 376
+RMD160 70cbd0b87cbd2ce6b494f07ead732f33f7ea623f files/git-daemon.confd 376
+SHA256 266045958a3a4072529f25208d1f84a178bbb10aa0b6fa19543f7a62f9a5e3fe files/git-daemon.confd 376
+AUX git-daemon.initd 526 RMD160 1ee04d8a5636593b41d2864afbad076ee6d770aa SHA1 7f35b65575a880f10d4c2f355e3feca589ee6839 SHA256 8915a900a602df046f091154fed378cb4ab62983a6ab2857653933a02e6f86ec size 526
+MD5 ad6b9193f41375013fad4455bf1acda7 files/git-daemon.initd 526
+RMD160 1ee04d8a5636593b41d2864afbad076ee6d770aa files/git-daemon.initd 526
+SHA256 8915a900a602df046f091154fed378cb4ab62983a6ab2857653933a02e6f86ec files/git-daemon.initd 526
+EBUILD git-9999.ebuild 3370 RMD160 ddbb22646761309f9fafe5a68de66d3ada1c31c6 SHA1 45418e5b5a503ab01de2fb574a843fce8f3ff503 SHA256 844e5d61925d78274245d9434969f494ec277d1eef441167364b28562168f82b size 3370
+MD5 9f4db8eabe8af967f4e537e3dab0ec50 git-9999.ebuild 3370
+RMD160 ddbb22646761309f9fafe5a68de66d3ada1c31c6 git-9999.ebuild 3370
+SHA256 844e5d61925d78274245d9434969f494ec277d1eef441167364b28562168f82b git-9999.ebuild 3370
+MD5 68b329da9893e34099c7d8ad5cb9c940 files/digest-git-9999 1
+RMD160 c0da025038ed83c687ddc430da9846ecb97f3998 files/digest-git-9999 1
+SHA256 01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b files/digest-git-9999 1
diff --git a/dev-util/git/files/digest-git-9999 b/dev-util/git/files/digest-git-9999
new file mode 100644
index 00000000..8b137891
--- /dev/null
+++ b/dev-util/git/files/digest-git-9999
@@ -0,0 +1 @@
+
diff --git a/dev-util/git/files/git-daemon.confd b/dev-util/git/files/git-daemon.confd
new file mode 100644
index 00000000..ace9cbd8
--- /dev/null
+++ b/dev-util/git/files/git-daemon.confd
@@ -0,0 +1,12 @@
+# conf.d file for git-daemon
+#
+# Please check man 1 git-daemon for more information about the options
+# git-daemon accepts.
+#
+# Meaningful options are:
+# --syslog --- Enables syslog logging
+# --verbose --- Enables verbose logging
+# --export-all --- Exports all repositories
+# --port=XXXX --- Starts in port XXXX instead of 9418
+#
+GITDAEMON_OPTS="--syslog"
diff --git a/dev-util/git/files/git-daemon.initd b/dev-util/git/files/git-daemon.initd
new file mode 100644
index 00000000..2563c414
--- /dev/null
+++ b/dev-util/git/files/git-daemon.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/files/git-daemon.initd,v 1.1 2005/10/05 15:05:04 ferdy Exp $
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting git-daemon"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/bin/git-daemon -- ${GITDAEMON_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stoping git-daemon"
+ start-stop-daemon --stop --quiet --name git-daemon
+ eend $?
+}
diff --git a/dev-util/git/git-9999.ebuild b/dev-util/git/git-9999.ebuild
new file mode 100644
index 00000000..77ac83b7
--- /dev/null
+++ b/dev-util/git/git-9999.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.3.1.ebuild,v 1.1 2006/04/25 20:17:11 ferdy Exp $
+
+inherit python toolchain-funcs eutils git
+
+EGIT_REPO_URI="git+ssh://guybrush.ath.cx/var/git/public/git/git.git"
+EGIT_PROJECT="git.git"
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozsha1 ppcsha1 doc curl X webdav elibc_uclibc"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ doc? ( app-text/asciidoc app-text/xmlto )
+ webdav? ( dev-libs/expat )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ X? ( dev-lang/tk )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile Documentation/Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} prefix=/usr || die "make failed"
+ emake ${MY_MAKEOPTS} prefix=/usr doc || die "make doc failed"
+}
+
+src_install() {
+ make ${MY_MAKEOPTS} DESTDIR=${D} prefix=/usr install || die "make install failed"
+ make ${MY_MAKEOPTS} DESTDIR=${D} prefix=/usr install-doc || die "make install-doc failed"
+
+ use X || rm ${D}/usr/bin/gitk
+
+ doman ${WORKDIR}/${PN}-man-${DOC_VER}/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r ${WORKDIR}/${PN}-html-${DOC_VER}/* ${D}/usr/share/doc/${PF}/html
+ fi
+
+ newinitd "${FILESDIR}/git-daemon.initd" git-daemon
+ newconfd "${FILESDIR}/git-daemon.confd" git-daemon
+}
+
+src_test() {
+ cd ${S}
+ make ${MY_MAKEOPTS} test || die "tests failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before"
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before"
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite"
+ einfo
+}