summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2015-04-19 20:44:54 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-04-19 20:58:19 +0100
commit444d3c400c41747824f7a651892ea0387e5e6b74 (patch)
tree55374f4cb8b1862c5c6190f7b56b50d8026e7aad /dev-util
parentprofiles/server: KEYWORD dev-php/pecl-zendopcache (diff)
downloadportage-444d3c400c41747824f7a651892ea0387e5e6b74.tar.xz
dev-util/cpplint: Add snapshot
Package-Manager: portage-2.2.14
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cpplint/ChangeLog5
-rw-r--r--dev-util/cpplint/Manifest3
-rw-r--r--dev-util/cpplint/cpplint-20141204.ebuild30
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-util/cpplint/ChangeLog b/dev-util/cpplint/ChangeLog
index 79147fcf..dcca4899 100644
--- a/dev-util/cpplint/ChangeLog
+++ b/dev-util/cpplint/ChangeLog
@@ -1,3 +1,8 @@
+*cpplint-20141204 (19 Apr 2015)
+
+ 19 Apr 2015; Bertrand Jacquin <bertrand@jacquin.bzh> +cpplint-20141204.ebuild:
+ dev-util/cpplint: Add snapshot
+
25 Jan 2015; Bertrand Jacquin <bertrand@jacquin.bzh> metadata.xml:
Update email address
diff --git a/dev-util/cpplint/Manifest b/dev-util/cpplint/Manifest
index dddf584e..9f334151 100644
--- a/dev-util/cpplint/Manifest
+++ b/dev-util/cpplint/Manifest
@@ -1,3 +1,4 @@
+EBUILD cpplint-20141204.ebuild 667 SHA256 c52780e47b3e38997aa3fa80010cfc8b04d81e9116b0ffa36a2e802ca885c0cc WHIRLPOOL 5253ca41f1b7e1fdb8ba33d84be9d407b61bd2bfebe6d10fa24a388d413164ae59e48aed1207c275b5d5e73dce2ba03b6638f964d1294095a419c675b999bd94
EBUILD cpplint-9999.ebuild 661 SHA256 2c771ec69dccf3131e68fea7e36644926ac60e56fe9b72ecec078584807f5fa3 WHIRLPOOL c76e2746f804a50ff289bbf0300dd567429965c0e6d530d839556629a7342d95ae792db9a875e28f3aa60c774b0364d9647ed459c02a7c72ff6f490324eb8520
-MISC ChangeLog 367 SHA256 3fdb1a84109fe8eaf3587f33c4931e54a0e169b2539195ca32325055f8c4ddf9 WHIRLPOOL a036b294153b7035eecd56e19c1217c2e5629e828878784d6628fba738f74f854b0e3935851d98df367c234f654e73329004d0fbec6c6fb7b97ead1a8eb3ba3b
+MISC ChangeLog 515 SHA256 0df145dbdc7e2c6211a0a264047173e15a118692b8ebbdf17727afc5c92e290f WHIRLPOOL a598f0318c4b0af8c369aeaba1f388db02f20e33416c095812968aba6b5e0947d26f44794e43b9b8e959775da5d5baf0316877a4ee8c2c772c69296c0bb877d4
MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/dev-util/cpplint/cpplint-20141204.ebuild b/dev-util/cpplint/cpplint-20141204.ebuild
new file mode 100644
index 00000000..a6b17d74
--- /dev/null
+++ b/dev-util/cpplint/cpplint-20141204.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 subversion
+
+DESCRIPTION="Checker to make sure a C++ file follows Google's C++ style guide"
+HOMEPAGE="https://code.google.com/p/google-styleguide"
+ESVN_REPO_URI="http://google-styleguide.googlecode.com/svn/trunk/${PN}"
+
+LICENSE="cpplint"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+src_test() {
+ einfo "Running ${EPYTHON} cpplint_unittest.py"
+ ${EPYTHON} cpplint_unittest.py --verbose \
+ || die "cpplint_unittest.py failed"
+}
+
+src_install() {
+ python_doscript cpplint.py
+
+ dodoc README
+}