summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-02 23:26:19 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-09-04 00:07:25 +0100
commit0f76fffa40f53bb526311dbd9153ed48df70fd6d (patch)
tree72aa7877bd7ed9164dd721c70c528360378c0f54 /dev-util
parentdev-util/coverity: Move to EAPI 6 (diff)
downloadportage-0f76fffa40f53bb526311dbd9153ed48df70fd6d.tar.xz
dev-util/cpplint: Move to EAPI 6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cpplint/Manifest4
-rw-r--r--dev-util/cpplint/cpplint-20150520.ebuild16
-rw-r--r--dev-util/cpplint/cpplint-9999.ebuild16
3 files changed, 24 insertions, 12 deletions
diff --git a/dev-util/cpplint/Manifest b/dev-util/cpplint/Manifest
index f7fd2d72..04537184 100644
--- a/dev-util/cpplint/Manifest
+++ b/dev-util/cpplint/Manifest
@@ -1,3 +1,3 @@
-EBUILD cpplint-20150520.ebuild 848 SHA256 fa22181efd8fe491765369d23f41101a9a65f906b22efe1418da7e6654938f22 WHIRLPOOL 0cf3cdfc9ee72ffa4c407f5200a310cb4e784fb68cd57d671f47a9f1b59c17b1d4fa32cd587f222a2e6ac15a711dd6f93c482956b97bceab6fdc927efd94e73c
-EBUILD cpplint-9999.ebuild 787 SHA256 eab36eafbea0020b8eedc66883a335ebd79b9d4aa4409a5ae28e7e59263967d0 WHIRLPOOL a02ab93b01caf991248b6915e8d3ac899c5308ce591a9cbdd306f4c80464cdba7a06d1ebb1abf2aabee64554b4c677456aa0258892794443ba01ef07da05da98
+EBUILD cpplint-20150520.ebuild 1073 SHA256 29e9ea47e11f97a009b682af49ba91633e8b8073133c61ccaadf6e8cc0bc94d0 WHIRLPOOL 317f7b06ed75e3847498c5885d5ffcab77d6971e7752d59bf5982c5eb997fb0257fe4edf974a4e5af29abc1322dcd559143d466eec6a4e8bff4bca4e07c252c4
+EBUILD cpplint-9999.ebuild 1012 SHA256 800b8db1460740e8bbea3ccfbfc837eb987933157f4ac70c48f215507d4f2238 WHIRLPOOL ecc4ccbe24b49b9b8edafed822824a2898587eed2282f38b0f8c910458562100bfdb1b1dafd2651428ac9d72725481f326510f5b17a2fc9a8cef4c0ace54a5ff
MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/dev-util/cpplint/cpplint-20150520.ebuild b/dev-util/cpplint/cpplint-20150520.ebuild
index 93392849..ecaeddc1 100644
--- a/dev-util/cpplint/cpplint-20150520.ebuild
+++ b/dev-util/cpplint/cpplint-20150520.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -18,6 +18,13 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
+HTML_DOCS=(
+ include/
+ angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html pyguide.html xmlstyle.html
+ javaguide.css styleguide.css
+ javaguidelink.png jsoncstyleguide_example_01.png jsoncstyleguide_example_02.png
+)
+
src_test() {
cd "${PN}"
@@ -27,13 +34,12 @@ src_test() {
}
src_install() {
+ default
+
python_doscript "${PN}/cpplint.py"
dodoc README.md "${PN}/README"
- dohtml *.html *.css *.png
- dohtml -r include
-
insinto /usr/share/vim/vimfiles/syntax
doins google_python_style.vim
}
diff --git a/dev-util/cpplint/cpplint-9999.ebuild b/dev-util/cpplint/cpplint-9999.ebuild
index d940f575..1cde4c50 100644
--- a/dev-util/cpplint/cpplint-9999.ebuild
+++ b/dev-util/cpplint/cpplint-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -17,6 +17,13 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
+HTML_DOCS=(
+ include/
+ angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html pyguide.html xmlstyle.html
+ javaguide.css styleguide.css
+ javaguidelink.png jsoncstyleguide_example_01.png jsoncstyleguide_example_02.png
+)
+
src_test() {
cd "${PN}"
@@ -26,13 +33,12 @@ src_test() {
}
src_install() {
+ default
+
python_doscript "${PN}/cpplint.py"
dodoc README.md "${PN}/README"
- dohtml *.html *.css *.png
- dohtml -r include
-
insinto /usr/share/vim/vimfiles/syntax
doins google_python_style.vim
}