summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-01-10 17:31:36 +0000
committerBertrand Jacquin <beber@meleeweb.net>2006-01-10 17:31:36 +0000
commit0396742f20d46d976f35651c81432e19652919d3 (patch)
tree614d01137a3f276372b3378a53b9c1c5697a7c88 /dev-util
parentmore files need to move (diff)
downloadportage-0396742f20d46d976f35651c81432e19652919d3.tar.xz
make eclipse compile
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-cdt/ChangeLog36
-rw-r--r--dev-util/eclipse-cdt/Manifest4
-rw-r--r--dev-util/eclipse-cdt/eclipse-cdt-2.0-r3.ebuild72
-rw-r--r--dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0-r31
-rw-r--r--dev-util/eclipse-cdt/metadata.xml21
5 files changed, 134 insertions, 0 deletions
diff --git a/dev-util/eclipse-cdt/ChangeLog b/dev-util/eclipse-cdt/ChangeLog
new file mode 100644
index 00000000..e591c4aa
--- /dev/null
+++ b/dev-util/eclipse-cdt/ChangeLog
@@ -0,0 +1,36 @@
+# ChangeLog for dev-util/eclipse-cdt
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-cdt/ChangeLog,v 1.7 2004/12/21 21:47:05 karltk Exp $
+
+ 25 Nov 2004; Karl Trygve Kalleberg <karltk@gentoo.org> eclipse-cdt-2.0-r2.ebuild:
+ Changed dep to 3.0.0, so that it at least compiles again.
+
+ 28 Sep 2004; Sven Wegener <swegener@gentoo.org> :
+ Gentoo Technologies, Inc. -> Gentoo Foundation
+
+*eclipse-cdt-2.0-r2 (14 Sep 2004)
+
+ 14 Sep 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-cdt-2.0-r2.ebuild: Now requires 3.0, since we haven't tested on
+ 3.1 yet. Fixes #63905.
+
+*eclipse-cdt-2.0-r2 (21 Aug 2004)
+
+ 21 Aug 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ Removed CVS connetions, reworked the .tar.bz2 snapshot, now uses eclipse-ext
+ properly. Still ugly, but apperas to work somewhat on x86. Removed old
+ revisions.
+
+*eclipse-cdt-2.0-r1 (30 Jul 2004)
+
+ 30 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ Minor fixes.
+
+ 28 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org> eclipse-cdt-2.0.ebuild:
+ Fixed depends.
+
+*eclipse-cdt-2.0 (27 Jul 2004)
+
+ 27 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org> eclipse-cdt-2.0.ebuild:
+ Initial import. Ebuild submitted by myself. Needs a lot of work still.
+
diff --git a/dev-util/eclipse-cdt/Manifest b/dev-util/eclipse-cdt/Manifest
new file mode 100644
index 00000000..d941e61b
--- /dev/null
+++ b/dev-util/eclipse-cdt/Manifest
@@ -0,0 +1,4 @@
+MD5 d5aae5b5354f9deb9b334a325c02a1ac ChangeLog 1312
+MD5 b47e9a0b49779d682f8aa15638305cbf eclipse-cdt-2.0-r3.ebuild 2082
+MD5 73535641ec7f807fbc5f8b321f5dd386 files/digest-eclipse-cdt-2.0-r3 78
+MD5 76bafb39ef6b0c48d76cd8c5917fe441 metadata.xml 687
diff --git a/dev-util/eclipse-cdt/eclipse-cdt-2.0-r3.ebuild b/dev-util/eclipse-cdt/eclipse-cdt-2.0-r3.ebuild
new file mode 100644
index 00000000..704b037f
--- /dev/null
+++ b/dev-util/eclipse-cdt/eclipse-cdt-2.0-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-cdt/eclipse-cdt-2.0-r2.ebuild,v 1.6 2004/11/25 13:51:32 karltk Exp $
+
+inherit eclipse-ext
+
+DESCRIPTION="Eclipse C/C++ Development Tools"
+HOMEPAGE="http://www.eclipse.org/cdt"
+SRC_URI="http://dev.gentoo.org/~karltk/projects/eclipse/distfiles/eclipse-cdt-2.0-gentoo-1.tar.bz2"
+LICENSE="CPL-1.0"
+SLOT="2"
+KEYWORDS="-* ~x86"
+IUSE=""
+DEPEND="=dev-util/eclipse-sdk-3.0.0*
+ x11-misc/lndir"
+
+# karltk: A lot more work to do:
+# - add back other arches
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir -p ${S}/results/eclipse-copy
+ (
+ cd ${S}/results/eclipse-copy
+ lndir -silent /usr/lib/eclipse-3
+ # getProtectionDomain().getCodeSource() my buttocks...
+ rm startup.jar ; cp /usr/lib/eclipse-3/startup.jar .
+ )
+ mkdir -p ${S}/results/final-result
+ touch ${S}/results/final-result/compilelog.txt
+
+ sed -e "s/name=\"buildId\" value=\"[^\"]*\"/name=\"buildId\" value=\"${P}_gentoo\"/" \
+ -e 's:name="zipsdir" value="[^"]*":name="zipsdir" value="${buildDirectory}/final-result":' \
+ -i build.xml
+
+ sed -e "s:ECLIPSE_HOME=.*:ECLIPSE_HOME=${S}/results/eclipse-copy:" \
+ -i build.sh
+
+ sed -e "s:buildLabel=.*:buildLabel=final-result:" \
+ -i platform/build.properties \
+ -i sdk/build.properties
+}
+
+src_compile() {
+ # Use java-utils
+ addwrite /proc/cpuinfo
+ einfo "Building native code"
+ (
+ cd results/plugins/org.eclipse.cdt.core.linux/library || die
+ make ARCH=x86 all || die "Failed to compile platform-specific code"
+ )
+ einfo "Building Java code"
+ ./build.sh || die "Failed to compile"
+
+ finalzip=results/final-result/org.eclipse.cdt-2.1.0-eclipse-cdt-2.0_gentoo-linux.x86.zip
+ if [ ! -f ${finalzip} ] ; then
+ die "Compilation of final SDK zip failed"
+ fi
+
+ unzip ${finalzip} -d results/final-result/
+}
+
+src_install() {
+ eclipse-ext_require-slot 3
+
+ eclipse-ext_create-ext-layout source
+
+ eclipse-ext_install-features results/final-result/eclipse/features/*
+ eclipse-ext_install-plugins results/final-result/eclipse/plugins/*
+}
+
diff --git a/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0-r3 b/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0-r3
new file mode 100644
index 00000000..8c1f17be
--- /dev/null
+++ b/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0-r3
@@ -0,0 +1 @@
+MD5 6f398d3fcec4dd7097b65c639e50ef97 eclipse-cdt-2.0-gentoo-1.tar.bz2 6767450
diff --git a/dev-util/eclipse-cdt/metadata.xml b/dev-util/eclipse-cdt/metadata.xml
new file mode 100644
index 00000000..a5a5dd54
--- /dev/null
+++ b/dev-util/eclipse-cdt/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>dev-tools</herd>
+
+<longdescription>
+The CDT (C/C++ Development Tools) Project is working towards providing a fully
+functional C and C++ Integrated Development Environment (IDE) for the Eclipse
+platform.
+
+Features:
+* C/C++ Editor (basic functionality, syntax highlighting, code completion etc.)
+* C/C++ Debugger (APIs &amp; Default implementation, using GDB)
+* C/C++ Launcher (APIs &amp; Default implementation, launches and external application)
+* Parser
+* Search Engine
+* Content Assist Provider
+* Makefile generator
+</longdescription>
+</pkgmetadata>