summaryrefslogtreecommitdiff
path: root/dev-util/cpplint
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:42:07 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:42:07 +0000
commitf749afe4a6ab082bb57148b544427159037d3edb (patch)
treef48f8b1f0b9079a0bdb66aa22800dd23ec2b2b5f /dev-util/cpplint
parentdev-python/typer: disable py3.8 (diff)
downloadportage-f749afe4a6ab082bb57148b544427159037d3edb.tar.xz
dev-util/cpplint: enable python3.11
Diffstat (limited to 'dev-util/cpplint')
-rw-r--r--dev-util/cpplint/cpplint-20200102.ebuild6
-rw-r--r--dev-util/cpplint/cpplint-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/cpplint/cpplint-20200102.ebuild b/dev-util/cpplint/cpplint-20200102.ebuild
index 26197e3e..fffe787e 100644
--- a/dev-util/cpplint/cpplint-20200102.ebuild
+++ b/dev-util/cpplint/cpplint-20200102.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_8,3_9} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-single-r1 git-r3
@@ -17,6 +17,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RDEPEND="${PYTHON_DEPS}"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
HTML_DOCS=(
include/
angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html xmlstyle.html
diff --git a/dev-util/cpplint/cpplint-9999.ebuild b/dev-util/cpplint/cpplint-9999.ebuild
index afd5b03f..66b297e1 100644
--- a/dev-util/cpplint/cpplint-9999.ebuild
+++ b/dev-util/cpplint/cpplint-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_8,3_9} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-single-r1 git-r3
@@ -16,6 +16,10 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
+RDEPEND="${PYTHON_DEPS}"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
HTML_DOCS=(
include/
angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html xmlstyle.html