summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2007-10-09 16:08:03 +0200
committerBertrand Jacquin <beber@meleeweb.net>2007-10-09 16:08:03 +0200
commit4283f195842b1bbea6b145bb10381f78a00c808e (patch)
treef305888217eac42b4acc2d4987c3c96f322fbb58 /dev-ruby
parentDelete old and uneccessary digest, skel, etc (diff)
downloadportage-4283f195842b1bbea6b145bb10381f78a00c808e.tar.xz
meleeweb version of rmagick
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/Manifest8
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.15.103
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.10.ebuild76
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/rmagick/Manifest b/dev-ruby/rmagick/Manifest
new file mode 100644
index 00000000..c3327d3d
--- /dev/null
+++ b/dev-ruby/rmagick/Manifest
@@ -0,0 +1,8 @@
+DIST RMagick-1.15.10.tar.bz2 972865 RMD160 ce2b32d64dbeed0dc3ae5e7ec3e4066d65bf1356 SHA1 b1713cfed6e35e9c4ce9137dcef093ed4026a108 SHA256 07596567b01108876c6397a57160acf3da2d0e33b38e077158a0c08fd1a1e971
+EBUILD rmagick-1.15.10.ebuild 2666 RMD160 16eec86ea6e369d80af290d969acb15a28221752 SHA1 7190c28f1465ad17bebbffa81e6d22551abddac5 SHA256 edc724573ba541452fc280afee23c479f7b0cdc5e4ade155b94bfb5222663b1b
+MD5 dc3a3d4f38fc0e3934b771fecb126af7 rmagick-1.15.10.ebuild 2666
+RMD160 16eec86ea6e369d80af290d969acb15a28221752 rmagick-1.15.10.ebuild 2666
+SHA256 edc724573ba541452fc280afee23c479f7b0cdc5e4ade155b94bfb5222663b1b rmagick-1.15.10.ebuild 2666
+MD5 37fbe5374c8efbea6f32d3bdf6d9b67c files/digest-rmagick-1.15.10 250
+RMD160 2ff25b134bfb313dac8bd2c73c2ca48f4b666ce1 files/digest-rmagick-1.15.10 250
+SHA256 7166b1213f284416781c8c720cdc36f37b91452587ce3a3f258ac32f64c52f12 files/digest-rmagick-1.15.10 250
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.10 b/dev-ruby/rmagick/files/digest-rmagick-1.15.10
new file mode 100644
index 00000000..f1957942
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.15.10
@@ -0,0 +1,3 @@
+MD5 f8c410056395ea4efa09389497c5042f RMagick-1.15.10.tar.bz2 972865
+RMD160 ce2b32d64dbeed0dc3ae5e7ec3e4066d65bf1356 RMagick-1.15.10.tar.bz2 972865
+SHA256 07596567b01108876c6397a57160acf3da2d0e33b38e077158a0c08fd1a1e971 RMagick-1.15.10.tar.bz2 972865
diff --git a/dev-ruby/rmagick/rmagick-1.15.10.ebuild b/dev-ruby/rmagick/rmagick-1.15.10.ebuild
new file mode 100644
index 00000000..a4e12334
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.15.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.10.ebuild,v 1.7 2007/10/02 15:52:19 armin76 Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/25348/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="alpha ~amd64 hppa ia64 mips ppc ~ppc64 sparc x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+
+ # X-MW: Noisy files
+ rm -r ${D}/usr/share/RMagick
+}