summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2015-10-04 10:31:40 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-10-04 10:39:00 +0100
commite57f345e5a6044701b9d82557070a361faa90d80 (patch)
tree3649eec8fd9351963edf7edc51e8b397476fe365 /dev-python
parentmetadata: refresh cache (diff)
downloadportage-e57f345e5a6044701b9d82557070a361faa90d80.tar.xz
dev-python/python-efl: Python bindings for the EFL
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-efl/ChangeLog6
-rw-r--r--dev-python/python-efl/Manifest6
-rw-r--r--dev-python/python-efl/metadata.xml8
-rw-r--r--dev-python/python-efl/python-efl-1.12.0.ebuild25
-rw-r--r--dev-python/python-efl/python-efl-1.15.0.ebuild25
5 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/python-efl/ChangeLog b/dev-python/python-efl/ChangeLog
new file mode 100644
index 00000000..a07815c5
--- /dev/null
+++ b/dev-python/python-efl/ChangeLog
@@ -0,0 +1,6 @@
+*python-efl-1.12.0 (04 Oct 2015)
+*python-efl-1.15.0 (04 Oct 2015)
+
+ 04 Oct 2015; Bertrand Jacquin <bertrand@jacquin.bzh> +metadata.xml,
+ +python-efl-1.12.0.ebuild, +python-efl-1.15.0.ebuild:
+ dev-python/python-efl: Python bindings for the EFL
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
new file mode 100644
index 00000000..ad370996
--- /dev/null
+++ b/dev-python/python-efl/Manifest
@@ -0,0 +1,6 @@
+DIST python-efl-1.12.0.tar.bz2 10240276 SHA256 4f5ed74734a6a1b0589598234f3926b93fbf7dd92d06011f44fca398cdfcf1b6 WHIRLPOOL 93fde3e2e57a0efe011172e861aa182a84a34a5a6b4200f057222589812de941bed8d8a8861e90133bb50d77eb1692093dc508517c58c8e5985fe7fffa5ca442
+DIST python-efl-1.15.0.tar.bz2 11356701 SHA256 5f4ba892b5f0648da1e5256ef048b9fb2283254c5121260a9ce03d966c4f2f56 WHIRLPOOL c3560f29343cff7bbc1cdfab6324c2c94447d4360314c98814f93894c003d2ff49ab9ec9d0e51495accf941cde5cc71de7d693adef43431a702acce538b2effd
+EBUILD python-efl-1.12.0.ebuild 577 SHA256 e387feff7a793f0bf0f488cc19285afb9edb285ee910f7dedc04dfd45e030788 WHIRLPOOL 862a5040befc4ecfbee513d3959f539bd0b4da8395b02a57ffa4a10f3f2180b41a1964f42efa5bf547ece64ce292bd6ced265e22bda668dc762bac0eb690058e
+EBUILD python-efl-1.15.0.ebuild 577 SHA256 e387feff7a793f0bf0f488cc19285afb9edb285ee910f7dedc04dfd45e030788 WHIRLPOOL 862a5040befc4ecfbee513d3959f539bd0b4da8395b02a57ffa4a10f3f2180b41a1964f42efa5bf547ece64ce292bd6ced265e22bda668dc762bac0eb690058e
+MISC ChangeLog 246 SHA256 a931b57077e090e8f300ee8108b49701461a1e844344be5cadf82b1219da492b WHIRLPOOL 78b62e48e6a06ac9a5be21d2504b505e5253d973772df261b1c6b3c9879a1eaaae28881e50fe7162e2a4bf143a5bf88f48ad038ec8cac2561df2c91d0e26c679
+MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/dev-python/python-efl/metadata.xml b/dev-python/python-efl/metadata.xml
new file mode 100644
index 00000000..b5e02a8f
--- /dev/null
+++ b/dev-python/python-efl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-efl/python-efl-1.12.0.ebuild b/dev-python/python-efl/python-efl-1.12.0.ebuild
new file mode 100644
index 00000000..9e30b6bc
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.12.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the EFL"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="http://download.enlightenment.org/rel/bindings/python/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/efl-${PV}:0
+ >=media-libs/elementary-${PV}:0
+ >=dev-python/dbus-python-0.83.0:0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-python/python-efl/python-efl-1.15.0.ebuild b/dev-python/python-efl/python-efl-1.15.0.ebuild
new file mode 100644
index 00000000..9e30b6bc
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.15.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the EFL"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="http://download.enlightenment.org/rel/bindings/python/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/efl-${PV}:0
+ >=media-libs/elementary-${PV}:0
+ >=dev-python/dbus-python-0.83.0:0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"