summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-06-02 23:02:57 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-06-02 23:10:01 +0100
commitb789e3d5d97209217af0cef440db71dae7fbd840 (patch)
treeb3863e5e9ec9a0f11aeaa2367bee5324990fcc87 /dev-python
parentdev-python/shamir-mnemonic: version bump (diff)
downloadportage-b789e3d5d97209217af0cef440db71dae7fbd840.tar.xz
dev-python/trezor: version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trezor/Manifest2
-rw-r--r--dev-python/trezor/trezor-0.12.2.ebuild (renamed from dev-python/trezor/trezor-0.12.1.ebuild)6
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/trezor/Manifest b/dev-python/trezor/Manifest
index f8356750..5b3773cd 100644
--- a/dev-python/trezor/Manifest
+++ b/dev-python/trezor/Manifest
@@ -1 +1 @@
-DIST trezor-0.12.1.tar.gz 14611559 BLAKE2B 480e3b76fc681b58c04e8e1004e65288588732d4b07482e54712973352836001915cc69546671922a0754211d394d8b2e1c7fe7497426b7bc9b4a8d6f6280cae SHA512 097543ef83c4c990b82a33624d00cd745fc1e4e47169e81f8d3f76577e7b2f43cce69e5aea0b7f3aa89620af214bb365fb84aca4cfe49d17b65ecb7bdf73c71f
+DIST trezor-0.12.2.tar.gz 14653943 BLAKE2B 9ae8d7a9191124d8f83cda2983e7b1de7ed281b9442a3327204eb0caf6a51333976468c2c1679fdb01d08494f9d4691cd7c5b501bb74961ca4a0f2b4f1c10a80 SHA512 917745e4e806f2bfff58fb4e6e2749b84a72554a2f8cd17a1898d294f5269fc1146d991ec3443154dc1da5b353619803e9e3db2c4dc5a7815626c5a7cdbf754b
diff --git a/dev-python/trezor/trezor-0.12.1.ebuild b/dev-python/trezor/trezor-0.12.2.ebuild
index 22bbf4c6..9b80ba41 100644
--- a/dev-python/trezor/trezor-0.12.1.ebuild
+++ b/dev-python/trezor/trezor-0.12.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
inherit distutils-r1 bash-completion-r1
DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
@@ -17,12 +17,12 @@ IUSE=""
DEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
>=dev-python/mnemonic-0.17[${PYTHON_USEDEP}]
- >=dev-python/shamir-mnemonic-0.1.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
>=dev-python/click-7[${PYTHON_USEDEP}]
>=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]
>=dev-python/construct-2.9[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ dev-python/attrs:=[${PYTHON_USEDEP}]
>=dev-python/hidapi-0.7.99_p20[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
BDEPEND=""