summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-08-18 21:41:33 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-08-21 21:59:44 +0200
commit91e0ec9663daf36d94ab889b15e27349eb9b1dda (patch)
treeb5b25b748fc2728bb4fe967e698bf95f290ea5d3 /dev-python
parentwww-apps/phabricator: Formatting (diff)
downloadportage-91e0ec9663daf36d94ab889b15e27349eb9b1dda.tar.xz
dev-python/matplotlib: now upstream, bug 479970
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib/ChangeLog12
-rw-r--r--dev-python/matplotlib/Manifest4
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.0.ebuild194
-rw-r--r--dev-python/matplotlib/metadata.xml22
4 files changed, 0 insertions, 232 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
deleted file mode 100644
index 59900229..00000000
--- a/dev-python/matplotlib/ChangeLog
+++ /dev/null
@@ -1,12 +0,0 @@
- 17 Aug 2013; Bertrand Jacquin <beber@meleeweb.net>
- -files/matplotlib-1.2.0-setup.patch:
- dev-python/matplotlib: Remove unused patch
-
- 15 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> matplotlib-1.3.0.ebuild:
- dev-python/matplotlib: Python 3.1 is now deprecated, see #480070
-
-*matplotlib-1.3.0 (07 Aug 2013)
-
- 07 Aug 2013; Bertrand Jacquin <beber@meleeweb.net>
- +files/matplotlib-1.2.0-setup.patch, +matplotlib-1.3.0.ebuild, +metadata.xml:
- dev-python/matplotlib: Version bump, see #479970
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
deleted file mode 100644
index 6979f78a..00000000
--- a/dev-python/matplotlib/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST matplotlib-1.3.0.tar.gz 42098180 SHA256 3e37044911245d7d881ddab0152cfec463c597b9a207c7f87021b8f40e1cbd98 WHIRLPOOL f144b12ec8c0900ae20d39e0b01376ba52886dd7ded2d0b36a16ff0d59c0f9af946c95e3bb3fec7e4a589326ec6986afee70ff0905739e1912469122f45029a6
-EBUILD matplotlib-1.3.0.ebuild 4717 SHA256 fcbafc30bf56962517b1130dd13c3b2b101d45501fd267b6c8f5ff284e8360ad WHIRLPOOL 328319246c3812ce622decce92a03df824ab71a08677e61773bfa6eb9910115e76cf8ccb366aa81fbb95d963276194922af05a93e458ce6f03ebe84b28cb2e29
-MISC ChangeLog 501 SHA256 e0b20d76cacf9e0b2eb5f106a6e6638d0cfb71a7ea0fefe700a8fb7e952b8f52 WHIRLPOOL 35371ef83b2ab628950067d2540325bd03308bc61f6368efd9b2f08671e350e20003d3e307e3e8d2e847dcb7144d06378a718b87522cbfe018c25b069d103880
-MISC metadata.xml 810 SHA256 9415358b60b2d0db41f7b11813f4467eb39517b12a575420f57c19df8425e2af WHIRLPOOL f0d50fb7848ec3afada2784af0cdeba1637bd12b3614b1914ad8f01219026294042d31e22185498876d2b9ef028c789d487f6db354b6701a80263a60911af3ea
diff --git a/dev-python/matplotlib/matplotlib-1.3.0.ebuild b/dev-python/matplotlib/matplotlib-1.3.0.ebuild
deleted file mode 100644
index d9a038b8..00000000
--- a/dev-python/matplotlib/matplotlib-1.3.0.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.4 2013/06/09 17:47:12 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils flag-o-matic
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk gtk3 latex qt4 test tk"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python{3_2,3_3})
-COMMON_DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk[${PY2_USEDEP}] )
- dev-python/wxpython:2.8[${PY2_USEDEP}]"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PY2_USEDEP},${PY32_USEDEP}]
- dev-python/ipython
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/pyparsing[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- )
- qt4? ( || ( dev-python/PyQt4[X,${PYTHON_USEDEP}] dev-python/pyside[X,${PYTHON_USEDEP}] ) )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-REQUIRED_USE="doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- ${PY2_FLAGS}"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
- sed -i -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF || die
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- $(use_setup cairo)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if [[ ${EPYTHON} == python3* ]]; then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- wx = True
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- unset DISPLAY # bug #278524
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "
-import sys, matplotlib as m
-sys.exit(0 if m.test(verbosity=2) else 1)
-" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/matplotlib/metadata.xml b/dev-python/matplotlib/metadata.xml
deleted file mode 100644
index 54901601..00000000
--- a/dev-python/matplotlib/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <longdescription lang="en">
- matplotlib is an interactive library for plotting and doing basic
- data analysis in python with a syntax similar to matlab. It provides a
- variety of backends and hard copy formats for almost ready
- publication plots.
- </longdescription>
- <use>
- <flag name="excel">
- Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit
- </flag>
- <flag name="gtk3">
- Use <pkg>x11-libs/gtk+:3</pkg> instead of <pkg>x11-libs/gtk+:2</pkg>
- </flag>
- </use>
- <upstream>
- <remote-id type="pypi">matplotlib</remote-id>
- </upstream>
-</pkgmetadata>