summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-07-02 22:40:30 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-07-02 22:59:46 +0100
commit6a00093e75c1eda190e0515b95e1930a40f1ec9f (patch)
tree699bfe5861f090f9a43a488cf841d1617a924398 /dev-python
parentnet-p2p/bisq: version bump (diff)
downloadportage-6a00093e75c1eda190e0515b95e1930a40f1ec9f.tar.xz
dev-python/mistune: The fastest markdown parser in pure Python
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/metadata.xml13
-rw-r--r--dev-python/mistune/mistune-0.8.4-r1.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
new file mode 100644
index 00000000..8cd63131
--- /dev/null
+++ b/dev-python/mistune/Manifest
@@ -0,0 +1 @@
+DIST mistune-0.8.4.tar.gz 58322 BLAKE2B e65d45c5c95706a49a7fd407afe5f10e82a475766ca272ec3bebba8c89e670fe6efced7b09537efb69d3fd36e75091e370170a15ad7488b5cbe9186e2ccaf4db SHA512 36c3ef5d5537f5cceaa43e4da20a84b27c378cb744a93f0380024faefde490bcb42c453f79002ca049083fc437278f4afb3e10de5462f9eeb9077ca2a2fcaea7
diff --git a/dev-python/mistune/metadata.xml b/dev-python/mistune/metadata.xml
new file mode 100644
index 00000000..bd94a62c
--- /dev/null
+++ b/dev-python/mistune/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">mistune</remote-id>
+ <remote-id type="github">lepture/mistune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mistune/mistune-0.8.4-r1.ebuild b/dev-python/mistune/mistune-0.8.4-r1.ebuild
new file mode 100644
index 00000000..9a918abf
--- /dev/null
+++ b/dev-python/mistune/mistune-0.8.4-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests nose