summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-10-10 01:28:10 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2017-10-10 01:36:57 +0100
commit5d260f686df11d5752782d393e806b72b4fc20b1 (patch)
treecdd0d1cf8bdfe604672707ef64662f50c972c273 /dev-python
parentdev-python/mnemonic: Mnemonic code for generating deterministic keys, BIP39 (diff)
downloadportage-5d260f686df11d5752782d393e806b72b4fc20b1.tar.xz
dev-python/hidapi: Python wrapper for the dev-libs/hidapi
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hidapi/hidapi-0.7.99_p20.ebuild29
-rw-r--r--dev-python/hidapi/metadata.xml8
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/hidapi/hidapi-0.7.99_p20.ebuild b/dev-python/hidapi/hidapi-0.7.99_p20.ebuild
new file mode 100644
index 00000000..9d759332
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.7.99_p20.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit git-r3 distutils-r1
+
+DESCRIPTION="Python wrapper for the dev-libs/hidapi"
+HOMEPAGE="https://trezor.io"
+EGIT_REPO_URI="https://github.com/trezor/cython-hidapi.git"
+EGIT_COMMIT="505b20dd90fcf741dbf02ec6627c502567b289fd"
+EGIT_SUBMODULES=()
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/hidapi
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.24.0"
+
+src_configure() {
+ mydistutilsargs=(
+ --with-system-hidapi
+ )
+}
diff --git a/dev-python/hidapi/metadata.xml b/dev-python/hidapi/metadata.xml
new file mode 100644
index 00000000..82f7232e
--- /dev/null
+++ b/dev-python/hidapi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>