summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-08-22 23:58:04 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 00:21:13 +0100
commit571dc4efc8347fda9af82bb528a6d5b39d11b152 (patch)
tree81e39bff54640057c323afb650746aa675774ff6 /dev-python
parentapp-crypt/bip32utils: add support for python3.8 (diff)
downloadportage-571dc4efc8347fda9af82bb528a6d5b39d11b152.tar.xz
dev-python/trezor: version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trezor/Manifest3
-rw-r--r--dev-python/trezor/trezor-0.11.3.ebuild35
-rw-r--r--dev-python/trezor/trezor-0.12.1.ebuild (renamed from dev-python/trezor/trezor-0.12.0.ebuild)3
3 files changed, 2 insertions, 39 deletions
diff --git a/dev-python/trezor/Manifest b/dev-python/trezor/Manifest
index c57ad356..f8356750 100644
--- a/dev-python/trezor/Manifest
+++ b/dev-python/trezor/Manifest
@@ -1,2 +1 @@
-DIST trezor-0.11.3.tar.gz 5656969 BLAKE2B 745ce6b58d9adb612f8a8b5e55435ffa98bc6acf7b6e0e5437dfc24df284c1ef801dc57d0ec443fc118cde40cfaa652fc8c5632c6d5b2f3518a51fcb93fd4e44 SHA512 95a96704212af7191ed3fb43666122edd1a49bd3f3f9ea95b72051217bc5e25d4ad148228f607bc15875814e6d17a6b92fc550ea0770a1860eb2d9bd7fbce976
-DIST trezor-0.12.0.tar.gz 6022185 BLAKE2B 4a28561a046b439c3aaad3913d12bf40cbdb096f60f59eea2fcb337a115a79c74f59e6d80e84e43592cbf36ba930e16439c2763658d3c411e6528de2f04d2c57 SHA512 2e335c3f35c8c20f57a05f2b631dc0d6b3d13e40515a0db1544f9d224d3d25104fca0614215256b58c5105d6051047e9902aa4f54092cbdb92fedd5b169ae6fa
+DIST trezor-0.12.1.tar.gz 14611559 BLAKE2B 480e3b76fc681b58c04e8e1004e65288588732d4b07482e54712973352836001915cc69546671922a0754211d394d8b2e1c7fe7497426b7bc9b4a8d6f6280cae SHA512 097543ef83c4c990b82a33624d00cd745fc1e4e47169e81f8d3f76577e7b2f43cce69e5aea0b7f3aa89620af214bb365fb84aca4cfe49d17b65ecb7bdf73c71f
diff --git a/dev-python/trezor/trezor-0.11.3.ebuild b/dev-python/trezor/trezor-0.11.3.ebuild
deleted file mode 100644
index 1a668e57..00000000
--- a/dev-python/trezor/trezor-0.11.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
-HOMEPAGE="https://trezor.io"
-SRC_URI="https://github.com/trezor/trezor-firmware/archive/python/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
- >=dev-python/mnemonic-0.17[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-7[${PYTHON_USEDEP}]
- >=dev-python/pyblake2-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]
- >=dev-python/construct-2.9[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-3.6[${PYTHON_USEDEP}]
- >=dev-python/hidapi-0.7.99_p20[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-S="${WORKDIR}/trezor-firmware-python-v${PV}/python"
-
-python_install_all() {
- newbashcomp bash_completion.d/trezorctl.sh trezorctl
- distutils-r1_python_install_all
-}
diff --git a/dev-python/trezor/trezor-0.12.0.ebuild b/dev-python/trezor/trezor-0.12.1.ebuild
index cf2ab671..ef58bec4 100644
--- a/dev-python/trezor/trezor-0.12.0.ebuild
+++ b/dev-python/trezor/trezor-0.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1 bash-completion-r1
DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
@@ -20,7 +20,6 @@ DEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
>=dev-python/shamir-mnemonic-0.1.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
>=dev-python/click-7[${PYTHON_USEDEP}]
- >=dev-python/pyblake2-0.9.3[${PYTHON_USEDEP}]
>=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]
>=dev-python/construct-2.9[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]