summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:17:15 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:21:27 +0000
commit26fb6c4ec3adec617b0679ddb5aa34276816ff62 (patch)
treec2fabcf134b25fe75e98251ed6bcdc44f75284df /dev-python
parentdev-python/btchip-python: disable py3.8 (diff)
downloadportage-26fb6c4ec3adec617b0679ddb5aa34276816ff62.tar.xz
dev-python/dateparser: enable py3.10, py3.9 and disable py3.8
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dateparser/dateparser-1.1.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/dateparser/dateparser-1.1.1.ebuild b/dev-python/dateparser/dateparser-1.1.1.ebuild
index edd1c7b7..c5f50182 100644
--- a/dev-python/dateparser/dateparser-1.1.1.ebuild
+++ b/dev-python/dateparser/dateparser-1.1.1.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8,11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Python parser for human readable dates"
@@ -19,3 +20,5 @@ RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/regex[${PYTHON_USEDEP}]
dev-python/tzlocal[${PYTHON_USEDEP}]"
BDEPEND=""
+
+distutils_enable_tests pytest