summaryrefslogtreecommitdiff
path: root/dev-python/blurhash-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2024-03-11 19:58:15 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2024-03-11 22:24:05 +0000
commit2b674604832aaa8fb227fee47f059c317a03cf61 (patch)
treee99b150cf93ae44ed115c294f4ed856fb32ebfc5 /dev-python/blurhash-python
parentdev-python/pickle-secure: new package, add 0.99.9 (diff)
downloadportage-2b674604832aaa8fb227fee47f059c317a03cf61.tar.xz
dev-python/blurhash-python: new package, add 1.2.2
Diffstat (limited to 'dev-python/blurhash-python')
-rw-r--r--dev-python/blurhash-python/Manifest1
-rw-r--r--dev-python/blurhash-python/blurhash-python-1.2.2.ebuild27
-rw-r--r--dev-python/blurhash-python/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/blurhash-python/Manifest b/dev-python/blurhash-python/Manifest
new file mode 100644
index 00000000..64a06dec
--- /dev/null
+++ b/dev-python/blurhash-python/Manifest
@@ -0,0 +1 @@
+DIST blurhash-python-1.2.2.tar.gz 178331 BLAKE2B 186083c90d39703ea48060e742f9aed8de35b540adcbec13e82d7a81dac4f7c2206ce94c91396bb8540a919a0a3f5a1f0f6b3d62948f3aa7558e0ef51e6a4f89 SHA512 e6c345c29087d732a481df34a1c72a496f94a948e49d72f78e8c4f7d807f21d6a53d9f17d029fea7acee7d6f7afdfe90c5ee817323c7336b553e8fa41479e683
diff --git a/dev-python/blurhash-python/blurhash-python-1.2.2.ebuild b/dev-python/blurhash-python/blurhash-python-1.2.2.ebuild
new file mode 100644
index 00000000..035ee3a5
--- /dev/null
+++ b/dev-python/blurhash-python/blurhash-python-1.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Encoder for the BlurHash algorithm"
+HOMEPAGE="https://pypi.org/project/blurhash-python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/blurhash-python/metadata.xml b/dev-python/blurhash-python/metadata.xml
new file mode 100644
index 00000000..aee5553c
--- /dev/null
+++ b/dev-python/blurhash-python/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">blurhash-python</remote-id>
+ </upstream>
+</pkgmetadata>