summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-02 23:07:48 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-09-04 00:07:23 +0100
commit1aa43fb787d9d48aff49ed9be217226551e5b486 (patch)
treec4645ffb3ed3b7f49b190f2defefeeedee564ac2 /dev-php
parentdev-perl/VMware-vSphere-Perl-SDK: Move to EAPI 6 (diff)
downloadportage-1aa43fb787d9d48aff49ed9be217226551e5b486.tar.xz
dev-php/libphutil: Move to EAPI 6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/libphutil/Manifest4
-rw-r--r--dev-php/libphutil/libphutil-20160709.ebuild9
-rw-r--r--dev-php/libphutil/libphutil-9999.ebuild11
3 files changed, 15 insertions, 9 deletions
diff --git a/dev-php/libphutil/Manifest b/dev-php/libphutil/Manifest
index abf37591..01029ca5 100644
--- a/dev-php/libphutil/Manifest
+++ b/dev-php/libphutil/Manifest
@@ -1,5 +1,5 @@
AUX 20160709-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch 2155 SHA256 ed7e0c81f1cca4d6b2e14d8229e521302e0f656f9a1b742e478d2c2d036b6962 WHIRLPOOL bf0008faee1cf53a9a729ce9df486eadd40c16258c0ef0faf010c6cee14460bc253f2956dc75c8bc5a796727d9b0f877fa56ebcf0ef161649966d99fa14740b0
AUX 9999-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch 2155 SHA256 2c0f08539c617ac9bfcd91a5f91acd9c184e47273155f936084e837ebf8e6d31 WHIRLPOOL df831a1942dc5270ab4998352dc2386aa497b9910b39075df806adbf65b75c1c24c605a3b2494d08f7f4a223a2b7232bfe089cd334b47fe1155ec6a020ea255c
-EBUILD libphutil-20160709.ebuild 3405 SHA256 c153853ad138a7c635f39ba71491c9cafd64c1d84d8006a522ce21f5699222e6 WHIRLPOOL 7783785814050bbd6661fbd4d84493c814e551ab1a7a521dd8fbfdb9a96c66073a163302c03b447a9fe98148654a26253d9c2846bc0273a2ac0a3c02a43b5dd7
-EBUILD libphutil-9999.ebuild 3319 SHA256 9289172eb40a64b64d3be2ee6831e992662600f3085e4dcf31898c52707f505e WHIRLPOOL 6ed35dda61752b5b1ff861b6a73fda329d994180232036e266e347ed713e84d9a322a4f6d5c28d3af349bad8a719f5e23595615e692d14fc60978012f5eb6571
+EBUILD libphutil-20160709.ebuild 3445 SHA256 6b82b3b24e3993882f5c33a008bf6a97231e759b222d76ff95c46d75f8171baa WHIRLPOOL 8dd8cb877dd7fe2b7befbc5767091b7524cecdb9d35c43466f2063bfebf8e6d3a03592820aba43d28bce5a59e3a0e1615dd2dc59b8ab41ea324b3f8095363674
+EBUILD libphutil-9999.ebuild 3363 SHA256 51ec62b0993bdfc2a815d89f90aca9cc6cea8d1feadf93791dbf52816c76d38d WHIRLPOOL 0543f90706f8b515e92a3a8d539bfd9a31db074576f893d013898babfa99879b9a7e461ca374afbc8faffbe8dbfe2d7d40fba21ef1cb4f97fb631f6b86b8072a
MISC metadata.xml 256 SHA256 6ca43960767ca28661abf97c85263db77fe7643902be2ce777c61aa688d8ea2d WHIRLPOOL cef8582829111be09e651eb819e6d1ea59c9c4386b842169ccd46a14c8e3ccb090486fecd61c5fd4aa47998cacc69cdc1fb5ca6bb6325a4da1ebfd0b6eebda7b
diff --git a/dev-php/libphutil/libphutil-20160709.ebuild b/dev-php/libphutil/libphutil-20160709.ebuild
index 92d9d82a..2f9c0499 100644
--- a/dev-php/libphutil/libphutil-20160709.ebuild
+++ b/dev-php/libphutil/libphutil-20160709.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Collection of utility classes and functions for PHP used by phabricator"
@@ -21,12 +21,15 @@ DEPEND="virtual/awk:0
sys-devel/bison:0
>=sys-devel/flex-2.5.35:0
=www-client/arcanist-20160701:0
- dev-lang/php[cli]
+ >=dev-lang/php-5.2.3[cli]
+ <dev-lang/php-7:*
)"
RDEPEND=">=dev-lang/php-5.2.3[curl,iconv,json,mysql,mysqli,pcntl,ssl?,unicode]
- <dev-lang/php-7"
+ <dev-lang/php-7:*"
src_prepare() {
+ default
+
git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
epatch "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"
diff --git a/dev-php/libphutil/libphutil-9999.ebuild b/dev-php/libphutil/libphutil-9999.ebuild
index 1d6a45f0..50ba3ed4 100644
--- a/dev-php/libphutil/libphutil-9999.ebuild
+++ b/dev-php/libphutil/libphutil-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Collection of utility classes and functions for PHP used by phabricator"
@@ -19,12 +19,15 @@ DEPEND="virtual/awk:0
sys-devel/bison:0
>=sys-devel/flex-2.5.35:0
=www-client/arcanist-${PV}:0
- dev-lang/php[cli]
+ >=dev-lang/php-5.2.3:*[cli]
+ <dev-lang/php-7:*
)"
-RDEPEND=">=dev-lang/php-5.2.3[curl,iconv,json,mysql,mysqli,pcntl,ssl?,unicode]
- <dev-lang/php-7"
+RDEPEND=">=dev-lang/php-5.2.3:*[curl,iconv,json,mysql,mysqli,pcntl,ssl?,unicode]
+ <dev-lang/php-7:*"
src_prepare() {
+ default
+
git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
epatch "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"