summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-08-15 21:59:01 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 00:21:12 +0100
commitd675a822d890fc8bf76710fdc1b0612b96fedd6b (patch)
tree297e7394ce5b3208bf2509ea7f79d17cc5aeda44 /dev-libs
parentsys-kernel/stable-sources: version bump (diff)
downloadportage-d675a822d890fc8bf76710fdc1b0612b96fedd6b.tar.xz
dev-libs/randomx: version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/randomx/Manifest1
-rw-r--r--dev-libs/randomx/randomx-1.1.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/randomx/Manifest b/dev-libs/randomx/Manifest
index 5d313a54..46317053 100644
--- a/dev-libs/randomx/Manifest
+++ b/dev-libs/randomx/Manifest
@@ -1 +1,2 @@
DIST randomx-1.1.7.tar.gz 162740 BLAKE2B 6aa5d710e2d2dc8b74b457aec7bf6e0cc70eec6b7b41ae1d644ae5c4fcff032292f03be123f64ba92383acecc82124a3ebcabb2fdcb021b24ff06e778936085d SHA512 5987ebb26750b30cffcf8b345c94ee38f49b69f3fbc7f5b3fdd32e98c704ce2bf16a2dace523bfe2b6e9a46d4faa3c6f3317c6b435f0515aa518c920dce061be
+DIST randomx-1.1.8.tar.gz 163477 BLAKE2B 482f38a7e9f7b03ec5bd40ff923a1a1e575ed0c30431dcbecfe1072cdb10ccc93b61cf9d2177f4549e284125e17386e0314cb39734b22dc150193bd5d28bb813 SHA512 f41f13ba7b979a969e9d60e6c44cf289802e7459d6d817a64377428c3e833ea2f71a8a1e6559682ecc0ec2a33f958bb5b727d7faa28cb6ff69a524d713969bce
diff --git a/dev-libs/randomx/randomx-1.1.8.ebuild b/dev-libs/randomx/randomx-1.1.8.ebuild
new file mode 100644
index 00000000..aa119054
--- /dev/null
+++ b/dev-libs/randomx/randomx-1.1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-multilib
+
+DESCRIPTION="Proof-of-work algorithm that is optimized for general-purpose CPUs"
+HOMEPAGE="https://github.com/tevador/RandomX"
+SRC_URI="https://github.com/tevador/RandomX/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-util/cmake-2.8.7"
+
+S="${WORKDIR}/RandomX-${PV}"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ -DARCH=native
+ )
+
+ cmake-multilib_src_configure
+}