summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2023-12-15 18:12:41 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2023-12-15 18:12:41 +0000
commitd2c87734068d1506ac902999e98b4f509ef9f550 (patch)
tree9d3ca1ac2dc1de8aad9adf5664f2083caef37473 /dev-libs
parentsys-kernel/stable-sources: add 6.6.7, drop 6.6.6 (diff)
downloadportage-d2c87734068d1506ac902999e98b4f509ef9f550.tar.xz
dev-libs/randomx: backport gcc 13 fix
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/randomx/files/1.1.10-Fixed-GCC-13-compilation.patch21
-rw-r--r--dev-libs/randomx/randomx-1.1.10.ebuild4
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/randomx/files/1.1.10-Fixed-GCC-13-compilation.patch b/dev-libs/randomx/files/1.1.10-Fixed-GCC-13-compilation.patch
new file mode 100644
index 00000000..45be4fc6
--- /dev/null
+++ b/dev-libs/randomx/files/1.1.10-Fixed-GCC-13-compilation.patch
@@ -0,0 +1,21 @@
+From 43db7e290e33da122777dc04e411648507db44ab Mon Sep 17 00:00:00 2001
+From: SChernykh <sergey.v.chernykh@gmail.com>
+Date: Mon, 15 May 2023 09:45:20 +0200
+Subject: [PATCH] Fixed GCC 13 compilation
+
+---
+ src/tests/utility.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/tests/utility.hpp b/src/tests/utility.hpp
+index 92723b9795d6..ceb33d9fd7c7 100644
+--- a/src/tests/utility.hpp
++++ b/src/tests/utility.hpp
+@@ -32,6 +32,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ #include <cstdlib>
+ #include <iostream>
+ #include <fstream>
++#include <cstdint>
+
+ constexpr char hexmap[] = "0123456789abcdef";
+ inline void outputHex(std::ostream& os, const char* data, int length) {
diff --git a/dev-libs/randomx/randomx-1.1.10.ebuild b/dev-libs/randomx/randomx-1.1.10.ebuild
index 495b5dec..a9362807 100644
--- a/dev-libs/randomx/randomx-1.1.10.ebuild
+++ b/dev-libs/randomx/randomx-1.1.10.ebuild
@@ -21,6 +21,10 @@ S="${WORKDIR}/RandomX-${PV}"
CMAKE_BUILD_TYPE=Release
+PATCHES=(
+ "${FILESDIR}/${PV}-Fixed-GCC-13-compilation.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DARCH=native