summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2018-01-15 21:49:22 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-03-07 01:30:10 +0000
commitbdc04163322c039a8faea8a5dafeeb545aec1ff1 (patch)
tree973b07d74e48307d7b175610278e3382e0f3e52a /dev-libs
parentprofiles/enlightenment/build/crossdev: Switch to virtual/wine (diff)
downloadportage-bdc04163322c039a8faea8a5dafeeb545aec1ff1.tar.xz
dev-libs/wayland-protocols: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/metadata.xml8
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
new file mode 100644
index 00000000..05b8cee3
--- /dev/null
+++ b/dev-libs/wayland-protocols/Manifest
@@ -0,0 +1 @@
+DIST wayland-protocols-1.12.tar.xz 98920 BLAKE2B f6625f91ce5ba9e4ef88b296969e67d99f2889e405f3a416ab00c62d866a78fb554ff9baccfcd8cad2662ab0e5c7908866a9a04a1f16ec36c8a5af250c42564d SHA512 84f913aeaf9786c5ddff4952fa4c318435569ccdc00c625f088b1dc9d6e61f3c439b2d217db9fcf2f0c37da954e266314749e2c3130bf3328cffdc3bdce5695a
diff --git a/dev-libs/wayland-protocols/metadata.xml b/dev-libs/wayland-protocols/metadata.xml
new file mode 100644
index 00000000..e943b72b
--- /dev/null
+++ b/dev-libs/wayland-protocols/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild
new file mode 100644
index 00000000..7e102274
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}