summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-05-24 16:38:53 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-06-02 23:06:10 +0100
commit5fd0424e49b4f98bf3d3fc5bdf7f3a602c261411 (patch)
tree26ed515844662fcc9eb54b087f49a9d040cc7e1c /dev-libs
parentfactory-default/net-misc/openssh: bump defaults (diff)
downloadportage-5fd0424e49b4f98bf3d3fc5bdf7f3a602c261411.tar.xz
dev-libs/randomx: add sysctl for hugepages
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/randomx/files/60-randomx.conf1
-rw-r--r--dev-libs/randomx/randomx-1.1.9.ebuild7
2 files changed, 8 insertions, 0 deletions
diff --git a/dev-libs/randomx/files/60-randomx.conf b/dev-libs/randomx/files/60-randomx.conf
new file mode 100644
index 00000000..1e761b86
--- /dev/null
+++ b/dev-libs/randomx/files/60-randomx.conf
@@ -0,0 +1 @@
+vm.nr_hugepages = 2048
diff --git a/dev-libs/randomx/randomx-1.1.9.ebuild b/dev-libs/randomx/randomx-1.1.9.ebuild
index 44cdd359..fa7d7189 100644
--- a/dev-libs/randomx/randomx-1.1.9.ebuild
+++ b/dev-libs/randomx/randomx-1.1.9.ebuild
@@ -28,3 +28,10 @@ src_configure() {
cmake-multilib_src_configure
}
+
+src_install() {
+ cmake-multilib_src_install
+
+ insinto /usr/lib/sysctl.d
+ doins "${FILESDIR}/60-${PN}.conf"
+}