summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2023-10-26 09:04:14 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2023-10-26 09:04:46 +0100
commit36ec4cd3b0370e5f657e5d834b7993df58565045 (patch)
tree79d61808aa75efc1b9aba758f5c625ab06147a84 /dev-libs
parentnet-p2p/c-lightning: version bump (diff)
downloadportage-36ec4cd3b0370e5f657e5d834b7993df58565045.tar.xz
dev-libs/randomx: add 1.2.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/randomx/Manifest1
-rw-r--r--dev-libs/randomx/randomx-1.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/randomx/Manifest b/dev-libs/randomx/Manifest
index 12c64ed2..a90a4cfa 100644
--- a/dev-libs/randomx/Manifest
+++ b/dev-libs/randomx/Manifest
@@ -1 +1,2 @@
DIST randomx-1.1.10.tar.gz 163987 BLAKE2B cbb4757648d54fc8d3d75aaaf668e365900dc9bcd8b53e9afe975e1d288ce36207327608f69eaae16f31d79547355876e86b647f3cd3444cdfa08a1846862932 SHA512 b35210dab4e45165d3a83b1fd873a29872358ae2076f960c41f652a57e5576f872e4b4ebc4cec1937f2a9f31cfa9fd936b30eb2d1e382349097797812d6b5a5c
+DIST randomx-1.2.1.tar.gz 181224 BLAKE2B 8090e40fd3fca72778ba0d1c7fec4284fde47d3f692f11ed5e8c176abc069a155f3a9c9556aa85e4c88f456aee20d6f4615ec6a2f5b6b4944c66351839e49e2d SHA512 61aea021dcc2e43360cf20e741401a0379cd9b16774cd6bc477b5f64c8c642e61a1a9e5ad17b734b5450a01ed66ef8297d675beb0f6a2461d89fac1930f35c16
diff --git a/dev-libs/randomx/randomx-1.2.1.ebuild b/dev-libs/randomx/randomx-1.2.1.ebuild
new file mode 100644
index 00000000..3b5920ca
--- /dev/null
+++ b/dev-libs/randomx/randomx-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Proof-of-work algorithm that is optimized for general-purpose CPUs"
+HOMEPAGE="https://github.com/tevador/RandomX"
+SRC_URI="https://github.com/tevador/RandomX/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-util/cmake-3.5"
+
+S="${WORKDIR}/RandomX-${PV}"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ -DARCH=native
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/lib/sysctl.d
+ doins "${FILESDIR}/60-${PN}.conf"
+}