summaryrefslogtreecommitdiff
path: root/dev-dotnet
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-01-04 12:26:32 +0000
committerBertrand Jacquin <beber@meleeweb.net>2006-01-04 12:26:32 +0000
commit44a1306a492ed291d5e0ff77d3c69bc6008b7d41 (patch)
tree3dd9a358e3f1e2177f7cbb5015a38643f82f6932 /dev-dotnet
parentadd usb-pwc-re (diff)
downloadportage-44a1306a492ed291d5e0ff77d3c69bc6008b7d41.tar.xz
add vte-sharp (fix compil)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/vte-sharp/Manifest3
-rw-r--r--dev-dotnet/vte-sharp/files/digest-vte-sharp-2.4.0-r12
-rw-r--r--dev-dotnet/vte-sharp/files/vte-sharp-gtk_fix.patch24
-rw-r--r--dev-dotnet/vte-sharp/vte-sharp-2.4.0-r1.ebuild47
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-dotnet/vte-sharp/Manifest b/dev-dotnet/vte-sharp/Manifest
new file mode 100644
index 00000000..b0141f54
--- /dev/null
+++ b/dev-dotnet/vte-sharp/Manifest
@@ -0,0 +1,3 @@
+MD5 2bdfcdc0386e5d88b68abb8880d5e0a2 files/digest-vte-sharp-2.4.0-r1 147
+MD5 c9e17d97ce39c82ba7fb4066ca01badb files/vte-sharp-gtk_fix.patch 1287
+MD5 9ebe6b70b3aca4ece12807eba2bfbd26 vte-sharp-2.4.0-r1.ebuild 1348
diff --git a/dev-dotnet/vte-sharp/files/digest-vte-sharp-2.4.0-r1 b/dev-dotnet/vte-sharp/files/digest-vte-sharp-2.4.0-r1
new file mode 100644
index 00000000..0b56480b
--- /dev/null
+++ b/dev-dotnet/vte-sharp/files/digest-vte-sharp-2.4.0-r1
@@ -0,0 +1,2 @@
+MD5 e5d2c99f4db7eef6207abbc446a77844 gtk-sharp-2.4.0-configurable.diff.gz 1340
+MD5 9c2e4283a104479d4c7f404142042f3a gtk-sharp-2.4.0.tar.gz 2127668
diff --git a/dev-dotnet/vte-sharp/files/vte-sharp-gtk_fix.patch b/dev-dotnet/vte-sharp/files/vte-sharp-gtk_fix.patch
new file mode 100644
index 00000000..a344fb06
--- /dev/null
+++ b/dev-dotnet/vte-sharp/files/vte-sharp-gtk_fix.patch
@@ -0,0 +1,24 @@
+diff -ruN gtk-sharp-2.4.0.orig/vte/glue/Makefile.am gtk-sharp-2.4.0/vte/glue/Makefile.am
+--- gtk-sharp-2.4.0.orig/vte/glue/Makefile.am 2005-05-17 02:07:27.000000000 +0700
++++ gtk-sharp-2.4.0/vte/glue/Makefile.am 2005-12-29 00:07:37.000000000 +0600
+@@ -14,7 +14,7 @@
+
+ libvtesharpglue_2_la_LIBADD = $(VTE_LIBS)
+
+-INCLUDES = $(VTE_DEPENDENCIES_CFLAGS) -I$(top_srcdir)
++INCLUDES = $(VTE_DEPENDENCIES_CFLAGS) -I$(top_srcdir) $(GTK_CFLAGS)
+
+ libvtesharpglue.dll: $(libvtesharpglue_2_la_OBJECTS) libvtesharpglue.rc libvtesharpglue.def
+ ./build-dll libvtesharpglue-2 $(VERSION)
+diff -ruN gtk-sharp-2.4.0.orig/vte/glue/Makefile.in gtk-sharp-2.4.0/vte/glue/Makefile.in
+--- gtk-sharp-2.4.0.orig/vte/glue/Makefile.in 2005-12-28 23:31:08.000000000 +0600
++++ gtk-sharp-2.4.0/vte/glue/Makefile.in 2005-12-29 00:07:51.000000000 +0600
+@@ -61,7 +61,7 @@
+ libvtesharpglue_2_la_OBJECTS = $(am_libvtesharpglue_2_la_OBJECTS) \
+ $(nodist_libvtesharpglue_2_la_OBJECTS)
+ @ENABLE_VTE_TRUE@am_libvtesharpglue_2_la_rpath = -rpath $(libdir)
+-DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
++DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) $(GTK_CFLAGS)
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
diff --git a/dev-dotnet/vte-sharp/vte-sharp-2.4.0-r1.ebuild b/dev-dotnet/vte-sharp/vte-sharp-2.4.0-r1.ebuild
new file mode 100644
index 00000000..f8632bae
--- /dev/null
+++ b/dev-dotnet/vte-sharp/vte-sharp-2.4.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/vte-sharp/vte-sharp-2.4.0.ebuild,v 1.2 2005/11/26 19:22:58 herbs Exp $
+
+
+inherit gtk-sharp-component
+
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=x11-libs/vte-0.11.10"
+
+GTK_SHARP_COMPONENT_SLOT="2"
+GTK_SHARP_COMPONENT_SLOT_DEC="-2.0"
+GTK_SHARP_COMPONENT_BUILD_DEPS="gnome art"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/vte-sharp-gtk_fix.patch
+
+ # Make the components configurable
+ epatch ${WORKDIR}/${MY_P}-configurable.diff
+ aclocal || die "aclocal failed"
+ # See bug #73563, comment #9
+ libtoolize --copy --force || die "libtoolize failed"
+ automake || die "automake failed"
+
+ # fixes support with pkgconfig-0.17, bug #92503
+ sed -i -e 's/\<PKG_PATH\>/GTK_SHARP_PKG_PATH/g' configure.in
+
+ # Use correct libdir in pkgconfig files
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/*/{,GConf}/*.pc.in || die
+
+ autoconf || die "autoconf failed"
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" ${S}/Makefile.in || die
+
+ cd ${S}/${GTK_SHARP_COMPONENT_BUILD_DIR}
+
+ gtk-sharp-component_fix_makefiles
+}