summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-03-09 23:27:00 +0100
committerBertrand Jacquin <beber@meleeweb.net>2006-03-09 23:27:00 +0100
commit0950fef66025dc93c8457b869e74066e5a95eacf (patch)
tree1523e903551d383176983020ff93690828faae54 /app-office
parentjava: deleting stuff (diff)
downloadportage-0950fef66025dc93c8457b869e74066e5a95eacf.tar.xz
add lyx 1.4.0
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/Manifest6
-rw-r--r--app-office/lyx/files/digest-lyx-1.4.012
-rw-r--r--app-office/lyx/lyx-1.4.0.ebuild156
3 files changed, 174 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
new file mode 100644
index 00000000..1566160a
--- /dev/null
+++ b/app-office/lyx/Manifest
@@ -0,0 +1,6 @@
+MD5 629ba1ec1f2bb554bfc60cb26e5b6753 files/digest-lyx-1.4.0 901
+RMD160 973b746481dfa68e4df0e63ac6c11bdb326925a9 files/digest-lyx-1.4.0 901
+SHA256 767c176fb22fc3601c52bd5aac1c252d6b99243269b36be2516dbb67252f369a files/digest-lyx-1.4.0 901
+MD5 fffbfa04924ef31e1a8475f647254de5 lyx-1.4.0.ebuild 3760
+RMD160 5227e02d4ff03eb9ab4d9c49124d3727fd0745f8 lyx-1.4.0.ebuild 3760
+SHA256 548a8e85217eb743fd66d58d1f271fd19ae78791ecf605e8dad087af4ea649be lyx-1.4.0.ebuild 3760
diff --git a/app-office/lyx/files/digest-lyx-1.4.0 b/app-office/lyx/files/digest-lyx-1.4.0
new file mode 100644
index 00000000..53e67918
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.4.0
@@ -0,0 +1,12 @@
+MD5 f1df2f1426cca24c0dafa1dc1a832e6a hebrew.bind 45
+RMD160 1621bd311aa053798815fd6c795406a505761531 hebrew.bind 45
+SHA256 fc3b1e19560f7a22af1c6bca13c0c0d7786d6453e292201645abff54fd0b67dd hebrew.bind 45
+MD5 0f3275e403be5fdbd14117dd8a26675f latex-xft-fonts-0.1.tar.gz 91730
+RMD160 0a516eeba71ddc474e97f315e45e41028efa2e4d latex-xft-fonts-0.1.tar.gz 91730
+SHA256 78bceea8a055bc43bd0d246ae8e69f81d2f161ae4d8f1aaaa2dfff9e293ae964 latex-xft-fonts-0.1.tar.gz 91730
+MD5 5ab37471339ff7dbc8f0c43282746cb0 lyx-1.4.0.tar.bz2 6736577
+RMD160 c35bf24c58820b826514c7590dc594b520267dc5 lyx-1.4.0.tar.bz2 6736577
+SHA256 09eeb2acc4676b5c400d841d3225f20c1475e16554f86a3958ddbf7c5ad0d2a6 lyx-1.4.0.tar.bz2 6736577
+MD5 a0e3948595801a90d32d8b712596a5fe preferences 1669
+RMD160 26986d7bcc48c4ecf60f84d95490148a5e171785 preferences 1669
+SHA256 41867ac67bc729d1057253bf305aced1ff666ee4d648dfefc99fd0c3c0501d43 preferences 1669
diff --git a/app-office/lyx/lyx-1.4.0.ebuild b/app-office/lyx/lyx-1.4.0.ebuild
new file mode 100644
index 00000000..2be8110a
--- /dev/null
+++ b/app-office/lyx/lyx-1.4.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit kde-functions eutils libtool flag-o-matic
+
+MY_P=${P/_/}
+
+DESCRIPTION="WYSIWYM frontend for LaTeX"
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${MY_P}.tar.bz2
+ http://movementarian.org/latex-xft-fonts-0.1.tar.gz
+ http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
+ http://www.math.tau.ac.il/~dekelts/lyx/files/preferences"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="cups debug gtk nls qt"
+
+RDEPEND="
+ || (
+ virtual/x11
+ (
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft
+ )
+ )
+ virtual/ghostscript
+ virtual/pdfviewer
+ virtual/psviewer
+ virtual/aspell-dict
+ dev-tex/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/sgmltools-lite
+ app-text/noweb
+ dev-tex/chktex"
+
+# these dependencies need looking at.
+# does lyx only need qt to compile but not run ?
+# I'll look into it <obz@gentoo.org>
+DEPEND="${RDEPEND}
+ || (
+ virtual/x11
+ (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-proto/xproto
+ )
+ )
+ virtual/tetex
+ >=dev-lang/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus
+ >=sys-devel/autoconf-2.58
+ qt? =x11-libs/qt-3*
+ !qt? =x11-libs/xforms-1*
+ gtk? (
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libglademm-2.4
+ =x11-libs/xforms-1*
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2 || die "unpacking lyx failed"
+ unpack latex-xft-fonts-0.1.tar.gz || die "unpacking xft-fonts failed"
+ cd ${S}
+ elibtoolize || die "elibtoolize failed "
+}
+
+src_compile() {
+ local myconf=""
+
+ if use qt ; then
+ set-qtdir 3 ;
+ myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
+ ## GTK is not feature complete, leave it out by default
+ #elif use gtk ; then
+ # myconf="$myconf --with-frontend=gtk"
+ else
+ myconf="$myconf --with-frontend=xforms"
+ fi
+
+ export WANT_AUTOCONF=2.5
+
+ local flags="${CXXFLAGS} $(test_flag -fno-stack-protector) $(test_flag -fno-stack-protector-all)"
+ unset CFLAGS
+ unset CXXFLAGS
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ ${myconf} \
+ --enable-optimization="${flags/-Os}" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING \
+ ANNOUNCE ABOUT-NLS ${DISTDIR}/preferences
+
+ insinto /usr/share/lyx/bind
+ doins ${DISTDIR}/hebrew.bind
+
+ domenu ${FILESDIR}/lyx.desktop
+
+ # install the latex-xft fonts, which should fix
+ # the problems outlined in bug #15629
+ # <obz@gentoo.org>
+ cd ${WORKDIR}/latex-xft-fonts-0.1
+ make DESTDIR=${D} install || die "Font installation failed"
+
+ mkfontscale ${D}/usr/share/fonts/latex-xft-fonts
+ mkfontdir -e /usr/share/fonts/encodings \
+ -e /usr/share/fonts/encodings/large \
+ -e /usr/X11R6/$(get_libdir)/X11/fonts/encodings \
+ ${D}/usr/share/fonts/latex-xft-fonts
+ HOME=/root fc-cache -f ${D}/usr/share/fonts/latex-xft-fonts
+
+ # fix for bug 91108
+ dodir /usr/share/texmf/tex/latex
+ cd ${D}/usr/share/texmf/tex/latex
+ ln -s ../../../lyx/tex lyx
+}
+
+pkg_postinst() {
+
+ # fix for bug 91108
+ texhash
+
+ einfo ""
+ einfo "How to use Hebrew in LyX:"
+ einfo "1. emerge app-text/ivritex."
+ einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
+ einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
+ einfo "for instructions on using lyx's own preferences dialog to equal effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo ""
+
+ use qt || use gtk || (
+ einfo ""
+ einfo "If you have a multi-head setup not using xinerama you can only use lyx"
+ einfo "on the 2nd head if not using qt (maybe due to a xforms bug). See bug #40392."
+ einfo ""
+ )
+}