summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2023-05-12 23:28:01 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2023-05-12 23:30:09 +0100
commit5e61a353fe21eb7d455ff59b5df137b43f1d1b68 (patch)
tree9f49251a4ae65804d93be4b35700558c51809286 /app-misc
parentfactory-default/net-misc/openssh: specify RevokedHostKeys (diff)
downloadportage-5e61a353fe21eb7d455ff59b5df137b43f1d1b68.tar.xz
app-misc/gloriousctl: new package, add 9999
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gloriousctl/gloriousctl-9999.ebuild33
-rw-r--r--app-misc/gloriousctl/metadata.xml11
2 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/gloriousctl/gloriousctl-9999.ebuild b/app-misc/gloriousctl/gloriousctl-9999.ebuild
new file mode 100644
index 00000000..eaa0455c
--- /dev/null
+++ b/app-misc/gloriousctl/gloriousctl-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A utility to adjust the settings of Model O/D mice"
+HOMEPAGE="https://github.com/enkore/gloriousctl"
+EGIT_REPO_URI="https://github.com/enkore/${PN}.git"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="dev-libs/hidapi"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare () {
+ default
+
+ sed -i \
+ -e 's/gcc/$(CC)/' "${S}/Makefile" \
+ || die
+
+ tc-export CC
+}
+
+src_install() {
+ into /
+ dobin "${PN}"
+ dodoc README.md
+}
diff --git a/app-misc/gloriousctl/metadata.xml b/app-misc/gloriousctl/metadata.xml
new file mode 100644
index 00000000..7afe2ff6
--- /dev/null
+++ b/app-misc/gloriousctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">enkore/gloriousctl</remote-id>
+ </upstream>
+</pkgmetadata>