summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2011-08-06 17:01:43 +0200
committerBertrand Jacquin <beber@meleeweb.net>2011-08-06 17:01:43 +0200
commit6bd76ce7e394d8aa868b9ee6cc4eab807daaf552 (patch)
tree1cc155b27eca0ad1e4ca4f689ee61669bc04ac46 /app-crypt
parentnet-misc/openvpn-gui: Fix Manifest (diff)
downloadportage-6bd76ce7e394d8aa868b9ee6cc4eab807daaf552.tar.xz
app-crypt/pvk: Converts PVK files to PEM files and back again
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pvk/Manifest2
-rw-r--r--app-crypt/pvk/pvk-0.12.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/pvk/Manifest b/app-crypt/pvk/Manifest
new file mode 100644
index 00000000..559f2cc5
--- /dev/null
+++ b/app-crypt/pvk/Manifest
@@ -0,0 +1,2 @@
+DIST pvksrc.tgz.bin 7463 RMD160 5ead53c4d6e85b174dabb37681cc8152f9b26c6f SHA1 3ce4c9f340346497397b634007f4e433850cccb9 SHA256 181d83f4f44ba01ecc4d9d115152cc01e42d837aad9f5127201594dba12a1fa0
+EBUILD pvk-0.12.ebuild 667 RMD160 1d4099ef35bee79c0f375e8146167a24daa37deb SHA1 06cb65c47e963e0ae98fe97ccebb6b567061677f SHA256 a6a557adb8e00a71182298ad1d5681117e371c060f1a88ab12bd38807fa5a056
diff --git a/app-crypt/pvk/pvk-0.12.ebuild b/app-crypt/pvk/pvk-0.12.ebuild
new file mode 100644
index 00000000..de22ce1a
--- /dev/null
+++ b/app-crypt/pvk/pvk-0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit toolchain-funcs
+
+DESCRIPTION="Converts PVK files to PEM files and back again"
+HOMEPAGE="http://www.drh-consultancy.demon.co.uk/pvk.html"
+SRC_URI="http://www.drh-consultancy.demon.co.uk/${PN}src.tgz.bin"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack () {
+ tar xof ${DISTDIR}/${A} || die "failure unpacking ${A}"
+}
+
+src_compile () {
+ tc-export CC
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ || die "emake fail"
+}
+
+src_install () {
+ dobin pvk
+
+ dodoc README
+}