summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-06-23 23:50:57 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-06-23 23:50:57 +0100
commit1298dc39a62bfae5f5ea936cb9b4b8567345fe78 (patch)
treec974ac8adef2f0762f2823ff554ccdc03baa4881 /app-crypt
parentprofiles: Update LINGUAS (diff)
downloadportage-1298dc39a62bfae5f5ea936cb9b4b8567345fe78.tar.xz
app-crypt/scute: A PKCS #11 module for OpenPGP smartcards
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/scute/Manifest3
-rw-r--r--app-crypt/scute/files/scute-1.4.0-tests.patch13
-rw-r--r--app-crypt/scute/metadata.xml34
-rw-r--r--app-crypt/scute/scute-9999.ebuild49
4 files changed, 99 insertions, 0 deletions
diff --git a/app-crypt/scute/Manifest b/app-crypt/scute/Manifest
new file mode 100644
index 00000000..1cd7c59e
--- /dev/null
+++ b/app-crypt/scute/Manifest
@@ -0,0 +1,3 @@
+AUX scute-1.4.0-tests.patch 472 SHA256 82e01d265fae09d8693b78bca7dc66540e6c0b6e67b6f45b4789d2a342bd29ad WHIRLPOOL dae6bb4a8650c19007d41216239da910b81cd6cd580736dc0b88c244712ea3549ed9abca8d6728363e7fc013d759bc88657da35890afb576f6c327ccbaea735a
+EBUILD scute-9999.ebuild 1232 SHA256 71d5df5065741ca90e95b8661e21b00283e3c571f0aa5dc530f3635a56031a0c WHIRLPOOL a20d850d0f9f3fda4bb69967a4d5f53dfedaad5dd0e649da22a57d4becdad600712543cfbffc2aba934cb5387edd352839e9102ff1896310cefe48c7f0fd003f
+MISC metadata.xml 1217 SHA256 87f3310ed4e15aa1293474f47876d8003a8d5470197a5b8b45dc8d1bab7e4088 WHIRLPOOL 16afc15d73580a4f02af63ba1214fb5ed750c1f66cffd694a7e4021940ff71289ed8fd64e98f35df766be84fa413666edcfc54d7be5e70d2bce588000d9b8cde
diff --git a/app-crypt/scute/files/scute-1.4.0-tests.patch b/app-crypt/scute/files/scute-1.4.0-tests.patch
new file mode 100644
index 00000000..f06591f7
--- /dev/null
+++ b/app-crypt/scute/files/scute-1.4.0-tests.patch
@@ -0,0 +1,13 @@
+Index: scute-1.4.0/tests/Makefile.am
+===================================================================
+--- scute-1.4.0.orig/tests/Makefile.am
++++ scute-1.4.0/tests/Makefile.am
+@@ -35,7 +35,7 @@ TESTS = t-link t-getfunctionlist t-initi
+ t-opensession t-closeallsessions t-getsessioninfo \
+ t-findobjects t-getattribute t-auth
+
+-noinst_PROGRAMS = $(TESTS)
++check_PROGRAMS = $(TESTS)
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src
+ LDADD = ../src/libscute.la
diff --git a/app-crypt/scute/metadata.xml b/app-crypt/scute/metadata.xml
new file mode 100644
index 00000000..a5c9d6eb
--- /dev/null
+++ b/app-crypt/scute/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lucas.yamanishi@gmail.com</email>
+ <name>Lucas Yamanishi</name>
+ <description>Proxy maintainer.</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>flameeyes@gentoo.org</email>
+ <description>Proxying maintainer.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Scute is a PKCS #11 module that adds support for the OpenPGP
+ smartcard card to the Mozilla Network Security Services (NSS).
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>mb@g10code.de</email>
+ <name>Marcus Brinkmann</name>
+ </maintainer>
+ <changelog>http://git.gnupg.org/cgi-bin/gitweb.cgi?p=scute.git;a=blob_plain;f=ChangeLog;hb=HEAD</changelog>
+ <doc lang="en">http://www.scute.org/documentation.xhtml</doc>
+ <bugs-to>https://bugs.g10code.com/gnupg/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/scute/scute-9999.ebuild b/app-crypt/scute/scute-9999.ebuild
new file mode 100644
index 00000000..0869c8e9
--- /dev/null
+++ b/app-crypt/scute/scute-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils libtool multilib git-r3
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+EGIT_REPO_URI="git://git.gnupg.org/scute.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+DEPEND="
+ >=dev-libs/libgpg-error-1.14
+ >=dev-libs/libassuan-2.0.0
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Don't build tests during src_compile.
+ epatch "${FILESDIR}"/scute-1.4.0-tests.patch
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --enable-maintainer-mode \
+ --libdir=/usr/$(get_libdir)/pkcs11 \
+ --with-gpgsm=/usr/bin/gpgsm \
+ --with-gpg-agent=/usr/bin/gpg-agent
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ find "${ED}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}