summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2024-11-30 16:19:24 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2024-11-30 16:20:05 +0000
commitf6397bb8b62a2334b3a022c23efad7bf0d6a3535 (patch)
tree7195f90d05326e7e52e2d85e8d180555403395b6
parentnet-p2p/bisq: add 1.9.18, drop 1.9.17 (diff)
downloadportage-f6397bb8b62a2334b3a022c23efad7bf0d6a3535.tar.xz
dev-python/thumbhash: new package, add 0.1.2
-rw-r--r--dev-python/thumbhash/Manifest1
-rw-r--r--dev-python/thumbhash/metadata.xml11
-rw-r--r--dev-python/thumbhash/thumbhash-0.1.2.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/thumbhash/Manifest b/dev-python/thumbhash/Manifest
new file mode 100644
index 00000000..3f32a4c4
--- /dev/null
+++ b/dev-python/thumbhash/Manifest
@@ -0,0 +1 @@
+DIST thumbhash-0.1.2.tar.gz 13766 BLAKE2B c2fc4c7b1cd23f4a69f24cf31599b8ba03c4b2021cd4beb7e2ba6967d43e1fd699ef596bd5be31ce7fc28c96a9eecbe176016f61b1835af81d76ffcd6ce3b972 SHA512 e4c2d753929589ae131ec957e467c72ed8e3786778a650bf8ea226851a599d4bceded71fe5551e493e5835be683aca94c28249e9bfb7fce5ef4a21c0d10f6eb7
diff --git a/dev-python/thumbhash/metadata.xml b/dev-python/thumbhash/metadata.xml
new file mode 100644
index 00000000..2cccc3d5
--- /dev/null
+++ b/dev-python/thumbhash/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">thumbhash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/thumbhash/thumbhash-0.1.2.ebuild b/dev-python/thumbhash/thumbhash-0.1.2.ebuild
new file mode 100644
index 00000000..1f01569d
--- /dev/null
+++ b/dev-python/thumbhash/thumbhash-0.1.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python port of the thumbhash encoder"
+HOMEPAGE="https://pypi.org/project/thumbhash/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest