summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2023-09-18 23:35:28 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2023-09-18 23:37:42 +0100
commitee473455a59ae4d02b6f151794ea26769220475d (patch)
treef6ecc2152d356b02abdccd1e116ea8da7ad3731b
parentprofiles/desktop: add media-fonts/intel-one-mono to @system set (diff)
downloadportage-ee473455a59ae4d02b6f151794ea26769220475d.tar.xz
net-proxy/dnsproxy: new package, add 0.54.0
-rw-r--r--net-proxy/dnsproxy/Manifest2
-rw-r--r--net-proxy/dnsproxy/dnsproxy-0.54.0.ebuild29
-rw-r--r--net-proxy/dnsproxy/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/Manifest b/net-proxy/dnsproxy/Manifest
new file mode 100644
index 00000000..b45365e6
--- /dev/null
+++ b/net-proxy/dnsproxy/Manifest
@@ -0,0 +1,2 @@
+DIST dnsproxy-0.54.0-deps.tar.xz 41263236 BLAKE2B 1af22f62d8ebfe704f8777795e0876042f31c67d13ec9960175e55b7c34cbbbf1fde04e1f8b8df856f3a03db0a2aa7e731273925fbf7edc421e1e5776bfd7df7 SHA512 8f3072375545c0ad19cbab5406ca3fe8a97ea8f739a1b1bcb1f5df260bb15352d9dafef5cfebce5cdf9cbfb793991eaa0f7bfaa218eb2fecc0af5486f10353fa
+DIST dnsproxy-0.54.0.tar.gz 8143519 BLAKE2B 5d0e73cb8f6ba5cdcfc5412de60ef2efb8d59291a62fc36f9577ab9772a65f0d4e9033da019aa6243a0bd9a94a9920be572cec2ad51cf736c815a2c1370f84cc SHA512 e89546f420501c59687b564bec7b39f2dcbbbde003cc3edc74c1454a83d0994aeb0b629baac6d0265a38efe90111c09d674d1780b5ae0e647681bcfe1933561f
diff --git a/net-proxy/dnsproxy/dnsproxy-0.54.0.ebuild b/net-proxy/dnsproxy/dnsproxy-0.54.0.ebuild
new file mode 100644
index 00000000..dba7b87f
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-0.54.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Simple DNS proxy with DoH, DoT, DoQ and DNSCrypt support"
+HOMEPAGE="https://github.com/AdguardTeam/dnsproxy"
+SRC_URI="https://github.com/AdguardTeam/dnsproxy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://beber.meleeweb.net/gentoo/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="adguard"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ ego build || die
+}
+
+src_install() {
+ dobin "${S}/${PN}"
+
+ insinto /etc/dnsproxy
+ newins "${S}/config.yaml.dist" config.yaml
+}
diff --git a/net-proxy/dnsproxy/metadata.xml b/net-proxy/dnsproxy/metadata.xml
new file mode 100644
index 00000000..506eb1f1
--- /dev/null
+++ b/net-proxy/dnsproxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AdguardTeam/dnsproxy</remote-id>
+ </upstream>
+</pkgmetadata>