summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:19:34 +0200
committerBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:19:34 +0200
commite274b48527c06745383d1d3836718f4c22200feb (patch)
treebed8d5fab9488f66a272a3a1cb5df18155538cea
parentnet-dialup/rp-pppoe: #374667 (diff)
downloadportage-e274b48527c06745383d1d3836718f4c22200feb.tar.xz
net-analyzer/arpoison: #375655
https://bugs.gentoo.org/show_bug.cgi?id=375655
-rw-r--r--net-analyzer/arpoison/Manifest2
-rw-r--r--net-analyzer/arpoison/arpoison-0.6.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/arpoison/Manifest b/net-analyzer/arpoison/Manifest
new file mode 100644
index 00000000..d2f93d53
--- /dev/null
+++ b/net-analyzer/arpoison/Manifest
@@ -0,0 +1,2 @@
+DIST arpoison-0.6.tar.gz 8646 RMD160 295ee00c10c27528b8242f6838c25c9011065b33 SHA1 d73e1f849efa633a30eb417e1eff00a7603d0964 SHA256 2922a7f98901a2eb3b26822e576ef22a64d3585fb69c4c3c4c32c2ca3993e537
+EBUILD arpoison-0.6.ebuild 827 RMD160 b18e0bb26a726be197b33ecd991412d779667a22 SHA1 7ae109945bb104659184f65f9406604332c487a5 SHA256 eb3e92e108fef83427e544df0db6403c1d9fa52b0938036a37c8a3081f8aac2d
diff --git a/net-analyzer/arpoison/arpoison-0.6.ebuild b/net-analyzer/arpoison/arpoison-0.6.ebuild
new file mode 100644
index 00000000..8ef3116b
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpoison/arpoison-0.6.ebuild,v 1.8 2008/12/05 00:16:47 darkside Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=net-libs/libnet-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s|\(-Wall\)|\1 ${CFLAGS}|" \
+ -e "s|gcc|$(tc-getCC)|" \
+ -e "s|libnet-config|${ROOT}usr/bin/libnet-config|g" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README TODO
+}