summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-03-09 22:31:01 +0100
committerBertrand Jacquin <beber@meleeweb.net>2006-03-09 22:31:01 +0100
commitdccdfebad96605245430f64c710ea7d567c60206 (patch)
tree1a8901f49f481bf0cf982e737e6637a36618da2b
parentjava: del things are in portage (diff)
downloadportage-dccdfebad96605245430f64c710ea7d567c60206.tar.xz
java: deleting stuff
-rw-r--r--dev-java/ant-core/Manifest15
-rw-r--r--dev-java/ant-core/ant-core-1.6.5-r2.ebuild78
-rw-r--r--dev-java/ant-core/files/1.6.5-ant169
-rw-r--r--dev-java/ant-core/files/build.sh-exit-fix.patch11
-rw-r--r--dev-java/ant-core/files/digest-ant-core-1.6.5-r23
-rw-r--r--dev-java/ant-core/files/gcj-ecj.patch143
-rw-r--r--dev-java/ant-tasks/Manifest9
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.6.5.ebuild109
-rw-r--r--dev-java/ant-tasks/files/digest-ant-tasks-1.6.53
-rw-r--r--dev-java/ant-tasks/files/gcj-ecj.patch143
10 files changed, 0 insertions, 683 deletions
diff --git a/dev-java/ant-core/Manifest b/dev-java/ant-core/Manifest
deleted file mode 100644
index cb4f7ae0..00000000
--- a/dev-java/ant-core/Manifest
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 0f26c6e18fef6650b998a813483bdc9a ant-core-1.6.5-r2.ebuild 2046
-RMD160 7cb5dac991b97af3c31f0cb4ab82c1c26b052ef7 ant-core-1.6.5-r2.ebuild 2046
-SHA256 f0eca38a737735498e7ef4dc85f7ba18b2f22cf6d5854a79514cb90ad766d85f ant-core-1.6.5-r2.ebuild 2046
-MD5 851886c1a13240befce87e1577f057f1 files/1.6.5-ant 5063
-RMD160 82bfc6233cbb7e8f05099af12564a2cc27c2b53c files/1.6.5-ant 5063
-SHA256 d9a45d747aae54531f3cc4018e1d17d1dc6bacbc64051d50f1d217dce376b942 files/1.6.5-ant 5063
-MD5 ea37e3a5b2edbe1b1fca02ba48c4ea47 files/build.sh-exit-fix.patch 345
-RMD160 4c4cfdfb1b13b9cc55f279a5765afda6da9f6f4d files/build.sh-exit-fix.patch 345
-SHA256 bafac89599d2d5bbb8f17060e39922a01891826251925e39be2df38170d88e2b files/build.sh-exit-fix.patch 345
-MD5 31de0486a830c545c91a089241b3bb9a files/digest-ant-core-1.6.5-r2 268
-RMD160 3a54cfc35c821291722b58076e3524c513ee1dc2 files/digest-ant-core-1.6.5-r2 268
-SHA256 6d25121ad88d0c2a4d0822cff5bb2d50c9f6886369b452882476811f65c1b8f5 files/digest-ant-core-1.6.5-r2 268
-MD5 088a62691ccd652637b52e0ce56ce892 files/gcj-ecj.patch 5170
-RMD160 8f3aca3faafb87597cd85af616cf687e2e6c161a files/gcj-ecj.patch 5170
-SHA256 983729b9873b7fb4f2a5bb0d664e594968413f62aeb214ca5a5a8b362f44bc75 files/gcj-ecj.patch 5170
diff --git a/dev-java/ant-core/ant-core-1.6.5-r2.ebuild b/dev-java/ant-core/ant-core-1.6.5-r2.ebuild
deleted file mode 100644
index bc0d6f23..00000000
--- a/dev-java/ant-core/ant-core-1.6.5-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.5-r2.ebuild,v 1.2 2006/02/05 11:05:30 blubb Exp $
-
-inherit java-pkg eutils toolchain-funcs
-
-MY_PN=${PN/-core}
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/apache-${MY_PN}-${PV}-src.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc gcj source"
-
-DEPEND="virtual/libc
- !<dev-java/ant-1.5.4-r2
- >=virtual/jdk-1.4
- !<dev-java/ant-tasks-${PV}
- source? ( app-arch/zip )"
-RDEPEND=">=virtual/jdk-1.4
- >=dev-java/java-config-1.2"
-
-S="${WORKDIR}/apache-ant-${MY_PV}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
- epatch ${FILESDIR}/build.sh-exit-fix.patch
- use gcj && epatch ${FILESDIR}/gcj-ecj.patch
-}
-
-src_compile() {
- addwrite "/proc/self/maps"
- if [[ $(tc-arch) == "ppc" ]] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
-
-
- local myc
- myc="${myc} -Ddist.dir=${D}/usr/share/${PN}"
- myc="${myc} -Djavac.target=1.4"
- echo $CLASSPATH
- CLASSPATH="." ./build.sh -Ddist.dir=${D}/usr/share/${PN} || die
-
- use doc && ./build.sh dist_javadocs
-}
-
-src_install() {
- newbin ${FILESDIR}/${PV/_*}-ant ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin ${S}/src/script/${each}
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- dodir /etc/env.d
- echo "ANT_HOME=\"/usr/share/${PN}\"" > ${D}/etc/env.d/20ant
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- use source && java-pkg_dosrc src/main/*
-
- dodoc README WHATSNEW KEYS
- use doc && dohtml welcome.html
- use doc && java-pkg_dohtml -r docs/*
- use doc && java-pkg_dohtml -r dist/docs/manual/api/*
-}
diff --git a/dev-java/ant-core/files/1.6.5-ant b/dev-java/ant-core/files/1.6.5-ant
deleted file mode 100644
index 8b7755b4..00000000
--- a/dev-java/ant-core/files/1.6.5-ant
+++ /dev/null
@@ -1,169 +0,0 @@
-#! /bin/bash
-
-# Copyright 2001-2004 The Apache Software Foundation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.5-ant,v 1.5 2005/12/21 20:45:29 betelgeuse Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-
-if [ -z $JAVA_HOME ] ; then
- if [ -f $HOME/.gentoo/java-env ] ; then
- source $HOME/.gentoo/java-env
- else
- JAVA_HOME=`java-config --jdk-home`
- CLASSPATH=`java-config --classpath`:${CLASSPATH}
- fi
-fi
-
-if [ -z $JAVA_HOME ] ; then
- echo 'Error: No JDK found!'
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-JAVACMD="`java-config --java`"
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# add in the dependency .jar files
-LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=log4j,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils-1.6,commons-collections,commons-logging,commons-net,jakarta-oro-2.0,jdepend,jsch,jakarta-regexp-1.3,rhino-1.5,jython,jta,sun-jaf-bin,sun-javamail-bin 2> /dev/null`"
-
-if [ -n "$JAVA_HOME" ] ; then
- if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
- fi
-
- if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
- fi
-
-else
- echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
- echo " If build fails because sun.* classes could not be found"
- echo " you will need to set the JAVA_HOME environment variable"
- echo " to the installation directory of java."
- echo " Try using java-config script"
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-# 2002-11-02, karltk@gentoo.org:
-# The Blackdown JDK on PPC hiccups with native threads
-#
-if [ "`arch`" == "ppc" ] ; then
- export THREADS_FLAG="green"
-fi
-
-
-ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -cp \"$CLASSPATH\" $ant_exec_args"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/build.sh-exit-fix.patch b/dev-java/ant-core/files/build.sh-exit-fix.patch
deleted file mode 100644
index 53170617..00000000
--- a/dev-java/ant-core/files/build.sh-exit-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.sh.orig 2003-04-16 11:28:29.000000000 +0200
-+++ build.sh 2003-07-02 16:10:06.000000000 +0200
-@@ -18,7 +18,7 @@
-
- if test ! -f bootstrap/lib/ant.jar -o ! -x bootstrap/bin/ant -o ! -x bootstrap/bin/antRun ; then
- echo Bootstrap FAILED
-- exit
-+ exit 1
- fi
-
- LOCALCLASSPATH=lib/xercesImpl.jar:lib/xml-apis.jar:bootstrap/lib/ant.jar
diff --git a/dev-java/ant-core/files/digest-ant-core-1.6.5-r2 b/dev-java/ant-core/files/digest-ant-core-1.6.5-r2
deleted file mode 100644
index 6bc546eb..00000000
--- a/dev-java/ant-core/files/digest-ant-core-1.6.5-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 80a7ad191c40b7d8c82533524b282b6b apache-ant-1.6.5-src.tar.bz2 6283500
-RMD160 4680b53cd72d4915b9ca2bbe2131a71fcf505a84 apache-ant-1.6.5-src.tar.bz2 6283500
-SHA256 f3ef501f06bf1dac88981038ebd5311c738bf2d50d220de85c3e6c7656169d59 apache-ant-1.6.5-src.tar.bz2 6283500
diff --git a/dev-java/ant-core/files/gcj-ecj.patch b/dev-java/ant-core/files/gcj-ecj.patch
deleted file mode 100644
index 98debf5b..00000000
--- a/dev-java/ant-core/files/gcj-ecj.patch
+++ /dev/null
@@ -1,143 +0,0 @@
---- build.sh.orig 2006-02-22 00:24:13.000000000 +0100
-+++ build.sh 2006-02-22 00:26:46.000000000 +0100
-@@ -41,5 +41,5 @@
- ANT_INSTALL="-emacs"
- fi
-
--bootstrap/bin/ant -lib lib/optional "$ANT_INSTALL" $*
-+bootstrap/bin/ant -lib lib/optional -Dbuild.compiler=ecj "$ANT_INSTALL" $*
-
---- bootstrap.sh.orig 2006-02-22 17:06:18.000000000 +0100
-+++ bootstrap.sh 2006-02-22 17:05:45.000000000 +0100
-@@ -126,7 +126,7 @@
-
- echo ... Compiling Ant Classes
-
--"${JAVAC}" $BOOTJAVAC_OPTS -d ${CLASSDIR} ${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java \
-+${JAVAC} $BOOTJAVAC_OPTS -d ${CLASSDIR} ${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java \
- ${TOOLS}/ant/util/regexp/RegexpMatcher.java \
- ${TOOLS}/ant/util/regexp/RegexpMatcherFactory.java \
- ${TOOLS}/ant/types/*.java \
-@@ -150,7 +150,7 @@
-
- echo ... Building Ant Distribution
-
--"${JAVACMD}" -classpath "${CLASSPATH}" -Dant.home=. $ANT_OPTS org.apache.tools.ant.Main -emacs "$@" bootstrap
-+"${JAVACMD}" -classpath "${CLASSPATH}" -Dbuild.compiler=ecj -Dant.home=. $ANT_OPTS org.apache.tools.ant.Main -emacs "$@" bootstrap
- ret=$?
- if [ $ret != 0 ]; then
- echo ... Failed Building Ant Distribution !
---- src/main/org/apache/tools/ant/taskdefs/compilers/CompilerAdapterFactory.java.orig 2006-02-22 16:43:17.000000000 +0100
-+++ src/main/org/apache/tools/ant/taskdefs/compilers/CompilerAdapterFactory.java 2006-02-22 16:43:41.000000000 +0100
-@@ -120,6 +120,9 @@
- if (compilerType.equalsIgnoreCase("kjc")) {
- return new Kjc();
- }
-+ if (compilerType.equalsIgnoreCase("ecj")) {
-+ return new Ecj();
-+ }
- if (compilerType.equalsIgnoreCase("gcj")) {
- return new Gcj();
- }
---- /dev/null 2005-12-16 14:04:54.000000000 +0100
-+++ src/main/org/apache/tools/ant/taskdefs/compilers/Ecj.java 2006-02-22 16:45:18.000000000 +0100
-@@ -0,0 +1,99 @@
-+/*
-+ * Copyright 2001-2005 The Apache Software Foundation
-+ *
-+ * Licensed under the Apache License, Version 2.0 (the "License");
-+ * you may not use this file except in compliance with the License.
-+ * You may obtain a copy of the License at
-+ *
-+ * http://www.apache.org/licenses/LICENSE-2.0
-+ *
-+ * Unless required by applicable law or agreed to in writing, software
-+ * distributed under the License is distributed on an "AS IS" BASIS,
-+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+ * See the License for the specific language governing permissions and
-+ * limitations under the License.
-+ *
-+ */
-+
-+package org.apache.tools.ant.taskdefs.compilers;
-+
-+
-+import org.apache.tools.ant.BuildException;
-+import org.apache.tools.ant.Project;
-+import org.apache.tools.ant.types.Commandline;
-+import org.apache.tools.ant.types.Path;
-+
-+/**
-+ * The implementation of the ecj compiler.
-+ * This is primarily a cut-and-paste from the jikes.
-+ *
-+ * @since Ant 1.4
-+ */
-+public class Ecj extends DefaultCompilerAdapter {
-+
-+ /**
-+ * Performs a compile using the ecj compiler.
-+ */
-+ public boolean execute() throws BuildException {
-+ Commandline cmd;
-+ attributes.log("Using ecj compiler", Project.MSG_VERBOSE);
-+ cmd = setupECJCommand();
-+
-+ int firstFileName = cmd.size();
-+ logAndAddFilesToCompile(cmd);
-+
-+ return
-+ executeExternalCompile(cmd.getCommandline(), firstFileName) == 0;
-+ }
-+
-+ protected Commandline setupECJCommand() {
-+ Commandline cmd = new Commandline();
-+ Path classpath = new Path(project);
-+
-+ // ecj doesn't support bootclasspath dir (-bootclasspath)
-+ // so we'll emulate it for compatibility and convenience.
-+ if (bootclasspath != null) {
-+ classpath.append(bootclasspath);
-+ }
-+
-+ // ecj doesn't support an extension dir (-extdir)
-+ // so we'll emulate it for compatibility and convenience.
-+ classpath.addExtdirs(extdirs);
-+
-+ classpath.append(getCompileClasspath());
-+
-+ // Gcj has no option for source-path so we
-+ // will add it to classpath.
-+ if (compileSourcepath != null) {
-+ classpath.append(compileSourcepath);
-+ } else {
-+ classpath.append(src);
-+ }
-+
-+ cmd.setExecutable("ecj");
-+
-+ if (destDir != null) {
-+ cmd.createArgument().setValue("-d");
-+ cmd.createArgument().setFile(destDir);
-+
-+ if (!destDir.exists() && !destDir.mkdirs()) {
-+ throw new BuildException("Can't make output directories. "
-+ + "Maybe permission is wrong. ");
-+ }
-+ }
-+
-+ cmd.createArgument().setValue("-classpath");
-+ cmd.createArgument().setPath(classpath);
-+
-+ if (encoding != null) {
-+ cmd.createArgument().setValue("-encoding " + encoding);
-+ }
-+ if (debug) {
-+ cmd.createArgument().setValue("-g");
-+ }
-+
-+ addCurrentCompilerArgs(cmd);
-+
-+ return cmd;
-+ }
-+}
diff --git a/dev-java/ant-tasks/Manifest b/dev-java/ant-tasks/Manifest
deleted file mode 100644
index ee153de9..00000000
--- a/dev-java/ant-tasks/Manifest
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 720eb8fe7b1a68dfa1edeb0fdbd0f340 ant-tasks-1.6.5.ebuild 3393
-RMD160 17fd2d9fa69dc60b09a3bf938e3399648e7165d7 ant-tasks-1.6.5.ebuild 3393
-SHA256 0f8bcf8b6fec802fcaa43541e7d687416bfbf310fd888a205bb3d230c4606ce3 ant-tasks-1.6.5.ebuild 3393
-MD5 31de0486a830c545c91a089241b3bb9a files/digest-ant-tasks-1.6.5 268
-RMD160 3a54cfc35c821291722b58076e3524c513ee1dc2 files/digest-ant-tasks-1.6.5 268
-SHA256 6d25121ad88d0c2a4d0822cff5bb2d50c9f6886369b452882476811f65c1b8f5 files/digest-ant-tasks-1.6.5 268
-MD5 088a62691ccd652637b52e0ce56ce892 files/gcj-ecj.patch 5170
-RMD160 8f3aca3faafb87597cd85af616cf687e2e6c161a files/gcj-ecj.patch 5170
-SHA256 983729b9873b7fb4f2a5bb0d664e594968413f62aeb214ca5a5a8b362f44bc75 files/gcj-ecj.patch 5170
diff --git a/dev-java/ant-tasks/ant-tasks-1.6.5.ebuild b/dev-java/ant-tasks/ant-tasks-1.6.5.ebuild
deleted file mode 100644
index 4e61d372..00000000
--- a/dev-java/ant-tasks/ant-tasks-1.6.5.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.6.5.ebuild,v 1.4 2005/09/10 16:01:53 axxo Exp $
-
-inherit java-pkg eutils
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Apache ANT Optional Tasks Jar Files"
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64"
-IUSE="gcj javamail noantlr nobcel nobeanutils nobsh nobsf nocommonsnet nocommonslogging nojdepend nojsch nojython nolog4j nooro noregexp norhino noxalan noxerces"
-
-RDEPEND=">=virtual/jre-1.4
- =dev-java/ant-core-${PV}*
- !dev-java/ant-optional
- >=dev-java/junit-3.8
- !nolog4j? ( >=dev-java/log4j-1.2.8 )
- !noxerces? ( >=dev-java/xerces-2.6.2-r1 )
- !noxalan? ( >=dev-java/xalan-2.5.2 )
- !nobsh? ( >=dev-java/bsh-1.2-r7 )
- !nobsf? ( >=dev-java/bsf-2.3.0-r2 )
- !noantlr? ( >=dev-java/antlr-2.7.2 )
- !nobeanutils? ( =dev-java/commons-beanutils-1.6* )
- !nocommonslogging? ( >=dev-java/commons-logging-1.0.3 )
- !nocommonsnet? ( >=dev-java/commons-net-1.1.0 )
- !nobcel? ( >=dev-java/bcel-5.1 )
- !nooro? ( >=dev-java/jakarta-oro-2.0.8-r1 )
- !norhino? ( =dev-java/rhino-1.5* )
- !nojdepend? ( >=dev-java/jdepend-2.6 )
- !nojsch? ( >=dev-java/jsch-0.1.12 )
- !noregexp? ( >=dev-java/jakarta-regexp-1.3-r2 )
- !nojython? ( >=dev-java/jython-2.1-r5 )
- javamail? ( >=dev-java/sun-javamail-bin-1.3 )"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/java-config-1.2
- ${RDEPEND}"
-
-S="${WORKDIR}/apache-ant-${MY_PV}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use gcj && epatch ${FILESDIR}/gcj-ecj.patch
-}
-
-src_compile() {
- addwrite "/proc/self/maps"
- export JAVA_HOME=${JDK_HOME}
- if [ `arch` == "ppc" ] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
-
- local p="ant-core,junit" libs
- use noantlr || p="${p},antlr"
- use nobcel || p="${p},bcel"
- use nobeanutils || p="${p},commons-beanutils-1.6"
- use nobsh || p="${p},bsh"
- use nobsf || p="${p},bsf-2.3"
- use nocommonslogging || p="${p},commons-logging"
- use nocommonsnet || p="${p},commons-net"
- use nojdepend || p="${p},jdepend"
- use nojsch || p="${p},jsch"
- use nojython || p="${p},jython"
- use nolog4j || p="${p},log4j"
- use nooro || p="${p},jakarta-oro-2.0"
- use noregexp || p="${p},jakarta-regexp-1.3"
- use norhino || p="${p},rhino-1.5"
- use noxalan || p="${p},xalan"
- use noxerces || p="${p},xerces-2"
-
- use javamail && p="${p},sun-javamail-bin,sun-jaf-bin"
-
- local ant_flags=""
- use gcj && ant_flags="-Dbuild.compiler=ecj"
- CLASSPATH="." ant -Dant.install=${ANT_HOME} -lib $(java-pkg_getjars ${p}) ${ant_flags} \
- || die "build failed"
-}
-
-src_install() {
- dodir /usr/share/ant-core/lib
- for jar in build/lib/ant-*.jar; do
- [[ "$(basename ${jar})" == "ant-launcher.jar" ]] && continue
- java-pkg_dojar ${jar}
- dosym /usr/share/${PN}/lib/$(basename ${jar}) /usr/share/ant-core/lib/
- done
-}
-
-pkg_postinst() {
- local noset=false
- for x in ${IUSE} ; do
- if [ "${x:0:2}" == "no" ] ; then
- use ${x} && noset=true
- fi
- done
- if [ ${noset} == "true" ]; then
- ewarn "You have disabled some of the ant tasks. Be advised that this may"
- ewarn "break building some of the Java packages!!"
- ewarn ""
- ewarn "We can only offer very limited support in cases where dev-java/ant-tasks"
- ewarn "has been build with essential features disabled."
- fi
-}
diff --git a/dev-java/ant-tasks/files/digest-ant-tasks-1.6.5 b/dev-java/ant-tasks/files/digest-ant-tasks-1.6.5
deleted file mode 100644
index 6bc546eb..00000000
--- a/dev-java/ant-tasks/files/digest-ant-tasks-1.6.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 80a7ad191c40b7d8c82533524b282b6b apache-ant-1.6.5-src.tar.bz2 6283500
-RMD160 4680b53cd72d4915b9ca2bbe2131a71fcf505a84 apache-ant-1.6.5-src.tar.bz2 6283500
-SHA256 f3ef501f06bf1dac88981038ebd5311c738bf2d50d220de85c3e6c7656169d59 apache-ant-1.6.5-src.tar.bz2 6283500
diff --git a/dev-java/ant-tasks/files/gcj-ecj.patch b/dev-java/ant-tasks/files/gcj-ecj.patch
deleted file mode 100644
index 98debf5b..00000000
--- a/dev-java/ant-tasks/files/gcj-ecj.patch
+++ /dev/null
@@ -1,143 +0,0 @@
---- build.sh.orig 2006-02-22 00:24:13.000000000 +0100
-+++ build.sh 2006-02-22 00:26:46.000000000 +0100
-@@ -41,5 +41,5 @@
- ANT_INSTALL="-emacs"
- fi
-
--bootstrap/bin/ant -lib lib/optional "$ANT_INSTALL" $*
-+bootstrap/bin/ant -lib lib/optional -Dbuild.compiler=ecj "$ANT_INSTALL" $*
-
---- bootstrap.sh.orig 2006-02-22 17:06:18.000000000 +0100
-+++ bootstrap.sh 2006-02-22 17:05:45.000000000 +0100
-@@ -126,7 +126,7 @@
-
- echo ... Compiling Ant Classes
-
--"${JAVAC}" $BOOTJAVAC_OPTS -d ${CLASSDIR} ${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java \
-+${JAVAC} $BOOTJAVAC_OPTS -d ${CLASSDIR} ${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java \
- ${TOOLS}/ant/util/regexp/RegexpMatcher.java \
- ${TOOLS}/ant/util/regexp/RegexpMatcherFactory.java \
- ${TOOLS}/ant/types/*.java \
-@@ -150,7 +150,7 @@
-
- echo ... Building Ant Distribution
-
--"${JAVACMD}" -classpath "${CLASSPATH}" -Dant.home=. $ANT_OPTS org.apache.tools.ant.Main -emacs "$@" bootstrap
-+"${JAVACMD}" -classpath "${CLASSPATH}" -Dbuild.compiler=ecj -Dant.home=. $ANT_OPTS org.apache.tools.ant.Main -emacs "$@" bootstrap
- ret=$?
- if [ $ret != 0 ]; then
- echo ... Failed Building Ant Distribution !
---- src/main/org/apache/tools/ant/taskdefs/compilers/CompilerAdapterFactory.java.orig 2006-02-22 16:43:17.000000000 +0100
-+++ src/main/org/apache/tools/ant/taskdefs/compilers/CompilerAdapterFactory.java 2006-02-22 16:43:41.000000000 +0100
-@@ -120,6 +120,9 @@
- if (compilerType.equalsIgnoreCase("kjc")) {
- return new Kjc();
- }
-+ if (compilerType.equalsIgnoreCase("ecj")) {
-+ return new Ecj();
-+ }
- if (compilerType.equalsIgnoreCase("gcj")) {
- return new Gcj();
- }
---- /dev/null 2005-12-16 14:04:54.000000000 +0100
-+++ src/main/org/apache/tools/ant/taskdefs/compilers/Ecj.java 2006-02-22 16:45:18.000000000 +0100
-@@ -0,0 +1,99 @@
-+/*
-+ * Copyright 2001-2005 The Apache Software Foundation
-+ *
-+ * Licensed under the Apache License, Version 2.0 (the "License");
-+ * you may not use this file except in compliance with the License.
-+ * You may obtain a copy of the License at
-+ *
-+ * http://www.apache.org/licenses/LICENSE-2.0
-+ *
-+ * Unless required by applicable law or agreed to in writing, software
-+ * distributed under the License is distributed on an "AS IS" BASIS,
-+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+ * See the License for the specific language governing permissions and
-+ * limitations under the License.
-+ *
-+ */
-+
-+package org.apache.tools.ant.taskdefs.compilers;
-+
-+
-+import org.apache.tools.ant.BuildException;
-+import org.apache.tools.ant.Project;
-+import org.apache.tools.ant.types.Commandline;
-+import org.apache.tools.ant.types.Path;
-+
-+/**
-+ * The implementation of the ecj compiler.
-+ * This is primarily a cut-and-paste from the jikes.
-+ *
-+ * @since Ant 1.4
-+ */
-+public class Ecj extends DefaultCompilerAdapter {
-+
-+ /**
-+ * Performs a compile using the ecj compiler.
-+ */
-+ public boolean execute() throws BuildException {
-+ Commandline cmd;
-+ attributes.log("Using ecj compiler", Project.MSG_VERBOSE);
-+ cmd = setupECJCommand();
-+
-+ int firstFileName = cmd.size();
-+ logAndAddFilesToCompile(cmd);
-+
-+ return
-+ executeExternalCompile(cmd.getCommandline(), firstFileName) == 0;
-+ }
-+
-+ protected Commandline setupECJCommand() {
-+ Commandline cmd = new Commandline();
-+ Path classpath = new Path(project);
-+
-+ // ecj doesn't support bootclasspath dir (-bootclasspath)
-+ // so we'll emulate it for compatibility and convenience.
-+ if (bootclasspath != null) {
-+ classpath.append(bootclasspath);
-+ }
-+
-+ // ecj doesn't support an extension dir (-extdir)
-+ // so we'll emulate it for compatibility and convenience.
-+ classpath.addExtdirs(extdirs);
-+
-+ classpath.append(getCompileClasspath());
-+
-+ // Gcj has no option for source-path so we
-+ // will add it to classpath.
-+ if (compileSourcepath != null) {
-+ classpath.append(compileSourcepath);
-+ } else {
-+ classpath.append(src);
-+ }
-+
-+ cmd.setExecutable("ecj");
-+
-+ if (destDir != null) {
-+ cmd.createArgument().setValue("-d");
-+ cmd.createArgument().setFile(destDir);
-+
-+ if (!destDir.exists() && !destDir.mkdirs()) {
-+ throw new BuildException("Can't make output directories. "
-+ + "Maybe permission is wrong. ");
-+ }
-+ }
-+
-+ cmd.createArgument().setValue("-classpath");
-+ cmd.createArgument().setPath(classpath);
-+
-+ if (encoding != null) {
-+ cmd.createArgument().setValue("-encoding " + encoding);
-+ }
-+ if (debug) {
-+ cmd.createArgument().setValue("-g");
-+ }
-+
-+ addCurrentCompilerArgs(cmd);
-+
-+ return cmd;
-+ }
-+}