summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-06-15 03:31:40 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-06-15 21:15:48 +0100
commitd12ca15d3073a30c4d2ef03e4892f292d7a20efd (patch)
tree6a42b1af6af2484f82ba42a3830225f6cf877e54
parentnet-p2p/monero: Version bump (diff)
downloadportage-d12ca15d3073a30c4d2ef03e4892f292d7a20efd.tar.xz
net-p2p/monero-gui: Version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--net-p2p/monero-gui/Manifest1
-rw-r--r--net-p2p/monero-gui/monero-gui-0.14.1.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-p2p/monero-gui/Manifest b/net-p2p/monero-gui/Manifest
index 5569711d..e6156a91 100644
--- a/net-p2p/monero-gui/Manifest
+++ b/net-p2p/monero-gui/Manifest
@@ -1 +1,2 @@
DIST monero-gui-0.14.0.0.tar.gz 4101218 BLAKE2B 3456a8222b1e1abb41ac9c8019832243c5c88a6300fa19417af1e95009044e3172cae05b53c8d4076fd295c6ce6e402a39d3e239dab73713ef955656a842822a SHA512 5a73bcf368cb92d292a7c6728c296a9583c514e9505f8f3394d30efc591b153886bf88efd2062b9b83a824bab0d42d9ee027164b3a3078a415280d3204fad57e
+DIST monero-gui-0.14.1.0.tar.gz 4459985 BLAKE2B 0b80dc15ada31de2b10332bbccbdeabfd727ab45802c8c30f8e382c4142a722427819e11c6746547b6c220530ec8b5050aa3c3cb306650a2f5ce9afc8dd861b8 SHA512 e694734a2bf36eb5955307a3a9a13a420c6f09ce43baa65c3c39d169d51ef6f5fc7744cef91d6e4167166125cf1959af356dde3501f973a92cb9b2ca2742a25b
diff --git a/net-p2p/monero-gui/monero-gui-0.14.1.0.ebuild b/net-p2p/monero-gui/monero-gui-0.14.1.0.ebuild
new file mode 100644
index 00000000..19f66dfb
--- /dev/null
+++ b/net-p2p/monero-gui/monero-gui-0.14.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils toolchain-funcs
+
+DESCRIPTION="GUI for net-p2p/monero"
+HOMEPAGE="https://getmonero.org"
+SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="qrcode smartcard unwind"
+
+COMMON_DEPEND="net-p2p/monero:=[qt5,smartcard?,unwind?]
+ dev-db/lmdb:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtxmlpatterns:5[qml]
+ dev-qt/qtwidgets:5
+ dev-libs/boost:=
+ dev-libs/openssl:0
+ unwind? ( sys-libs/libunwind[lzma] )
+ qrcode? (
+ dev-qt/qtmultimedia:5
+ media-gfx/zbar
+ )
+ smartcard? (
+ dev-libs/hidapi:=
+ virtual/libusb:=
+ dev-libs/protobuf:=
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtgraphicaleffects:5
+ media-fonts/fontawesome"
+
+src_prepare () {
+ cat > "${S}/version.js" <<-EOF || die
+ var GUI_VERSION = "${PV}"
+ var GUI_MONERO_VERSION = "${PV}"
+ EOF
+
+ export AR=$(tc-getAR)
+ export CC=$(tc-getCC)
+ export CXX=$(tc-getCXX)
+
+ default
+}
+
+src_configure () {
+ local myconf=( "release" )
+
+ if use qrcode ; then
+ myconf+=( "WITH_SCANNER" )
+ fi
+
+ if ! use unwind ; then
+ myconf+=( "libunwind_off" )
+ fi
+
+ # CONFIG is expected to be a single argument,
+ eqmake5 "CONFIG+=${myconf[*]}"
+}
+
+src_compile () {
+ emake -C src/zxcvbn-c
+
+ default
+}
+
+src_install () {
+ dobin release/bin/monero-wallet-gui
+ dodoc README.md
+}