summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-03-04 21:56:42 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-03-04 21:56:42 +0000
commitc9f280c5e033847f39f9a5897048138796e00dcc (patch)
tree2ec6cd556b43be11a3aece4cc46420d90b882abf
parentajout des skel (diff)
downloadportage-c9f280c5e033847f39f9a5897048138796e00dcc.tar.xz
+ qq ebuild perso
+ license boinc - skel
-rw-r--r--perso/app-portage/portagesql/ChangeLog8
-rw-r--r--perso/app-portage/portagesql/Manifest5
-rw-r--r--perso/app-portage/portagesql/files/digest-portagesql-0.11
-rw-r--r--perso/app-portage/portagesql/files/init-portage-db.sql26
-rw-r--r--perso/app-portage/portagesql/metadata.xml10
-rw-r--r--perso/app-portage/portagesql/portagesql-0.1.ebuild49
-rw-r--r--perso/header.txt1
-rw-r--r--perso/licenses/boinc-1.0337
-rw-r--r--perso/skel.ChangeLog1
-rw-r--r--perso/skel.ebuild1
-rw-r--r--perso/skel.metadata.xml1
11 files changed, 436 insertions, 4 deletions
diff --git a/perso/app-portage/portagesql/ChangeLog b/perso/app-portage/portagesql/ChangeLog
new file mode 100644
index 00000000..77557a91
--- /dev/null
+++ b/perso/app-portage/portagesql/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-portage/portagesql
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+
+*portagesql-0.1 (16 Feb 2005)
+
+ 16 Feb 2005; Bertrand Jacquin <beber.gentoo@gmail.com>
+ portagesql-0.1.ebuild, init-portage-db.sql:
+ New Ebuild.
diff --git a/perso/app-portage/portagesql/Manifest b/perso/app-portage/portagesql/Manifest
new file mode 100644
index 00000000..ac33cf9a
--- /dev/null
+++ b/perso/app-portage/portagesql/Manifest
@@ -0,0 +1,5 @@
+MD5 1c2b83cf5e14c95c923b74126cd74eaa portagesql-0.1.ebuild 1247
+MD5 efa34b2d6f197041b16f6330419a2a54 ChangeLog 258
+MD5 06093ebe48949a45baafbdd2ac5235a1 metadata.xml 272
+MD5 e9b4120d72d2ebabe1b3298ba8d9636f files/init-portage-db.sql 831
+MD5 e4204585dcceb3a186869a0d0332d019 files/digest-portagesql-0.1 65
diff --git a/perso/app-portage/portagesql/files/digest-portagesql-0.1 b/perso/app-portage/portagesql/files/digest-portagesql-0.1
new file mode 100644
index 00000000..7e9f10c1
--- /dev/null
+++ b/perso/app-portage/portagesql/files/digest-portagesql-0.1
@@ -0,0 +1 @@
+MD5 c0b0bfafd386a6617bf0c13f3b2d8a63 portagesql-0.1.tar.bz2 2747
diff --git a/perso/app-portage/portagesql/files/init-portage-db.sql b/perso/app-portage/portagesql/files/init-portage-db.sql
new file mode 100644
index 00000000..70364b6f
--- /dev/null
+++ b/perso/app-portage/portagesql/files/init-portage-db.sql
@@ -0,0 +1,26 @@
+CREATE DATABASE `portage`;
+USE mysql;
+REPLACE INTO user (Host,User,Password) VALUES ('localhost','portage','');
+FLUSH PRIVILEGES;
+GRANT SELECT,UPDATE,DELETE,INSERT,CREATE,LOCK TABLES ON portage.* TO portage@localhost;
+FLUSH PRIVILEGES;
+USE portage;
+CREATE TABLE `path_table` (
+ p_id int PRIMARY KEY AUTO_INCREMENT,
+ name char(255) NOT NULL UNIQUE
+);
+CREATE TABLE `category_table` (
+ c_id int(7) PRIMARY KEY AUTO_INCREMENT,
+ name char(255) NOT NULL UNIQUE
+) ;
+CREATE TABLE `package_name` (
+
+ name char(255) NOT NULL,
+ cat_id int NOT NULL,
+ path_id int NOT NULL,
+ data TEXT,
+ FOREIGN KEY (cat_id) REFERENCES category_table (c_id) ON DELETE CASCADE,
+ FOREIGN KEY (path_id) REFERENCES path_table (p_id) ON DELETE CASCADE,
+ #INDEX p_index (name,cat_id,path_id),
+ primary key (name, cat_id, path_id)
+) MAX_ROWS=99999999;
diff --git a/perso/app-portage/portagesql/metadata.xml b/perso/app-portage/portagesql/metadata.xml
new file mode 100644
index 00000000..14c66540
--- /dev/null
+++ b/perso/app-portage/portagesql/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>office</herd>
+<maintainer>
+ <email>beber.gentoo@gmail.com</email>
+ <name>Bertrand Jacquin</name>
+ <description/>
+</maintainer>
+</pkgmetadata>
diff --git a/perso/app-portage/portagesql/portagesql-0.1.ebuild b/perso/app-portage/portagesql/portagesql-0.1.ebuild
new file mode 100644
index 00000000..78946816
--- /dev/null
+++ b/perso/app-portage/portagesql/portagesql-0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Use mysql to speed up portage"
+HOMEPAGE="http://oneofone.limitlessfx.com/gentoo-stuff/"
+SRC_URI="http://guybrush.ath.cx/pub/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/portage-2.0.51
+ dev-db/mysql
+ dev-python/mysql-python"
+RDEPEND="${DEPEND}"
+
+src_unpack()
+{
+ unpack ${A}
+}
+
+src_install()
+{
+ dodir /usr/lib/portage/pym
+ dodir /etc/portage/
+
+ cp ${WORKDIR}/${PN}/portage_db_mysql.py ${D}/usr/lib/portage/pym/portage_db_mysql.py
+
+ if [ -d /etc/portage/modules ]; then
+ cp /etc/portage/modules ${D}/etc/portage/modules
+ fi
+
+ echo "portdbapi.auxdbmodule=\"portage_db_mysql.database\"
+eclass_cache.dbmodule=\"portage_db_mysql.database\"" >> \
+ ${D}/etc/portage/modules
+}
+
+pkg_postinst()
+{
+ einfo "Now, you will to have mysql server always started if you want to use portage :"
+ einfo " rc-update add mysql default"
+ einfo ""
+ einfo "You need to create the database too :"
+ einfo " mysql -u root -p < ${FILESDIR}/init-portage-db.sql"
+ einfo ""
+ einfo "After that, you will need to enter all ebuild in mysql database (It can take a long time) :"
+ einfo " emerge regen"
+}
diff --git a/perso/header.txt b/perso/header.txt
deleted file mode 100644
index d2f027e7..00000000
--- a/perso/header.txt
+++ /dev/null
@@ -1 +0,0 @@
-link /usr/portage/header.txt \ No newline at end of file
diff --git a/perso/licenses/boinc-1.0 b/perso/licenses/boinc-1.0
new file mode 100644
index 00000000..c612f811
--- /dev/null
+++ b/perso/licenses/boinc-1.0
@@ -0,0 +1,337 @@
+ BOINC PUBLIC LICENSE
+ Version 1.0
+
+ ----------------
+
+1. Definitions.
+
+ 1.1. ``Contributor'' means each entity that creates or contributes to
+ the creation of Modifications.
+
+ 1.2. ``Contributor Version'' means the combination of the Original
+ Code, prior Modifications used by a Contributor, and the Modifications
+ made by that particular Contributor.
+
+ 1.3. ``Covered Code'' means the Original Code or Modifications or the
+ combination of the Original Code and Modifications, in each case
+ including portions thereof.
+
+ 1.4. ``Electronic Distribution Mechanism'' means a mechanism generally
+ accepted in the software development community for the electronic
+ transfer of data.
+
+ 1.5. ``Executable'' means Covered Code in any form other than Source
+ Code.
+
+ 1.6. ``Initial Developer'' means the individual or entity identified as
+ the Initial Developer in the Source Code notice required by Exhibit A.
+
+ 1.7. ``Larger Work'' means a work which combines Covered Code or
+ portions thereof with code not governed by the terms of this License.
+
+ 1.8. ``License'' means this document.
+
+ 1.9. ``Modifications'' means any addition to or deletion from the
+ substance or structure of either the Original Code or any previous
+ Modifications. When Covered Code is released as a series of files, a
+ Modification is:
+
+ A. Any addition to or deletion from the contents of a file
+ containing Original Code or previous Modifications.
+
+ B. Any new file that contains any part of the Original Code or
+ previous Modifications.
+
+ 1.10. ``Original Code'' means Source Code of computer software code
+ which is described in the Source Code notice required by Exhibit A as
+ Original Code, and which, at the time of its release under this License
+ is not already Covered Code governed by this License.
+
+ 1.11. ``Source Code'' means the preferred form of the Covered Code for
+ making modifications to it, including all modules it contains, plus any
+ associated interface definition files, scripts used to control
+ compilation and installation of an Executable, or a list of source code
+ differential comparisons against either the Original Code or another
+ well known, available Covered Code of the Contributor's choice. The
+ Source Code can be in a compressed or archival form, provided the
+ appropriate decompression or de-archiving software is widely available
+ for no charge.
+
+ 1.12. ``You'' means an individual or a legal entity exercising rights
+ under, and complying with all of the terms of, this License or a future
+ version of this License issued under Section 6.1. For legal entities,
+ ``You'' includes any entity which controls, is controlled by, or is
+ under common control with You. For purposes of this definition,
+ ``control'' means (a) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (b) ownership of fifty percent (50%) or more of the
+ outstanding shares or beneficial ownership of such entity.
+
+2. Source Code License.
+
+ 2.1. The Initial Developer Grant.
+ Subject to the restrictions on commercial use set forth below,
+ the Initial Developer hereby grants You a world-wide, royalty-free,
+ non-exclusive license, subject to third party intellectual property
+ claims:
+
+ (a) to use, reproduce, modify, display, perform, sublicense and
+ distribute the Original Code (or portions thereof) with or without
+ Modifications, or as part of a Larger Work,
+ provided, however, that You are not permitted under said license
+ to create, sell, or distribute commercial products
+ based on the Source Code; and
+
+ (b) Subject to the restrictions on commercial use
+ set forth in subsection 2.1(a),
+ under patents now or hereafter owned or controlled by Initial
+ Developer, to make, have made, use and sell (``Utilize'') the
+ Original Code (or portions thereof), but solely to the extent that
+ any such patent is reasonably necessary to enable You to Utilize
+ the Original Code (or portions thereof) and not to any greater
+ extent that may be necessary to Utilize further Modifications or
+ combinations.
+
+ 2.2. Contributor Grant.
+ Subject to the restrictions on commercial use set forth below,
+ each Contributor hereby grants You a world-wide, royalty-free,
+ non-exclusive license, subject to third party intellectual property
+ claims:
+
+ (a) to use, reproduce, modify, display, perform, sublicense and
+ distribute the Modifications created by such Contributor (or
+ portions thereof) either on an unmodified basis, with other
+ Modifications, as Covered Code or as part of a Larger Work,
+ provided, however, that You are not permitted under said license
+ to create, sell, or distribute commercial products
+ based on the Source Code; and
+
+ (b) Subject to the restrictions on commercial use
+ set forth in subsection 2.2(a),
+ under patents now or hereafter owned or controlled by
+ Contributor, to Utilize the Contributor Version (or portions
+ thereof), but solely to the extent that any such patent is
+ reasonably necessary to enable You to Utilize the Contributor
+ Version (or portions thereof), and not to any greater extent that
+ may be necessary to Utilize further Modifications or combinations.
+
+3. Distribution Obligations.
+
+ 3.1. Application of License.
+ The Modifications which You create or to which You contribute are
+ governed by the terms of this License, including without limitation
+ Section 2.2. The Source Code version of Covered Code may be distributed
+ only under the terms of this License or a future version of this
+ License released under Section 6.1, and You must include a copy of this
+ License with every copy of the Source Code You distribute. You may not
+ offer or impose any terms on any Source Code version that alters or
+ restricts the applicable version of this License or the recipients'
+ rights hereunder. However, You may include an additional document
+ offering the additional rights described in Section 3.5.
+
+ 3.2. Availability of Source Code.
+ Any Modification which You create or to which You contribute must be
+ made available in Source Code form under the terms of this License
+ either on the same media as an Executable version or via an accepted
+ Electronic Distribution Mechanism to anyone to whom you made an
+ Executable version available; and if made available via Electronic
+ Distribution Mechanism, must remain available for at least twelve (12)
+ months after the date it initially became available, or at least six
+ (6) months after a subsequent version of that particular Modification
+ has been made available to such recipients. You are responsible for
+ ensuring that the Source Code version remains available even if the
+ Electronic Distribution Mechanism is maintained by a third party.
+
+ 3.3. Description of Modifications.
+ You must cause all Covered Code to which you contribute to contain a
+ file documenting the changes You made to create that Covered Code and
+ the date of any change. You must include a prominent statement that the
+ Modification is derived, directly or indirectly, from Original Code
+ provided by the Initial Developer and including the name of the Initial
+ Developer in (a) the Source Code, and (b) in any notice in an
+ Executable version or related documentation in which You describe the
+ origin or ownership of the Covered Code.
+
+ 3.4. Intellectual Property Matters
+
+ (a) Third Party Claims.
+ If You have knowledge that a party claims an intellectual property
+ right in particular functionality or code (or its utilization
+ under this License), you must include a text file with the source
+ code distribution titled ``LEGAL'' which describes the claim and
+ the party making the claim in sufficient detail that a recipient
+ will know whom to contact. If you obtain such knowledge after You
+ make Your Modification available as described in Section 3.2, You
+ shall promptly modify the LEGAL file in all copies You make
+ available thereafter and shall take other steps (such as notifying
+ appropriate mailing lists or newsgroups) reasonably calculated to
+ inform those who received the Covered Code that new knowledge has
+ been obtained.
+
+ (b) Contributor APIs.
+ If Your Modification is an application programming interface and
+ You own or control patents which are reasonably necessary to
+ implement that API, you must also include this information in the
+ LEGAL file.
+
+ 3.5. Required Notices.
+ You must duplicate the notice in Exhibit A in each file of the Source
+ Code, and this License in any documentation for the Source Code, where
+ You describe recipients' rights relating to Covered Code. If You
+ created one or more Modification(s), You may add your name as a
+ Contributor to the notice described in Exhibit A. If it is not possible
+ to put such notice in a particular Source Code file due to its
+ structure, then you must include such notice in a location (such as a
+ relevant directory file) where a user would be likely to look for such
+ a notice. You may choose to offer, and to charge a fee for, warranty,
+ support, indemnity or liability obligations to one or more recipients
+ of Covered Code. However, You may do so only on Your own behalf, and
+ not on behalf of the Initial Developer or any Contributor. You must
+ make it absolutely clear that any such warranty, support, indemnity or
+ liability obligation is offered by You alone, and You hereby agree to
+ indemnify the Initial Developer and every Contributor for any liability
+ incurred by the Initial Developer or such Contributor as a result of
+ warranty, support, indemnity or liability terms You offer.
+
+ 3.6. Distribution of Executable Versions.
+ You may distribute Covered Code in Executable form only if the
+ requirements of Section 3.1-3.5 have been met for that Covered Code,
+ and if You include a notice stating that the Source Code version of the
+ Covered Code is available under the terms of this License, including a
+ description of how and where You have fulfilled the obligations of
+ Section 3.2. The notice must be conspicuously included in any notice in
+ an Executable version, related documentation or collateral in which You
+ describe recipients' rights relating to the Covered Code. You may
+ distribute the Executable version of Covered Code under a license of
+ Your choice, which may contain terms different from this License,
+ provided that You are in compliance with the terms of this License and
+ that the license for the Executable version does not attempt to limit
+ or alter the recipient's rights in the Source Code version from the
+ rights set forth in this License. If You distribute the Executable
+ version under a different license You must make it absolutely clear
+ that any terms which differ from this License are offered by You alone,
+ not by the Initial Developer or any Contributor. You hereby agree to
+ indemnify the Initial Developer and every Contributor for any liability
+ incurred by the Initial Developer or such Contributor as a result of
+ any such terms You offer.
+
+ 3.7. Larger Works.
+ You may create a Larger Work by combining Covered Code with other code
+ not governed by the terms of this License and distribute the Larger
+ Work as a single product. In such a case, You must make sure the
+ requirements of this License are fulfilled for the Covered Code.
+
+4. Inability to Comply Due to Statute or Regulation.
+
+ If it is impossible for You to comply with any of the terms of this
+ License with respect to some or all of the Covered Code due to statute
+ or regulation then You must: (a) comply with the terms of this License
+ to the maximum extent possible; and (b) describe the limitations and
+ the code they affect. Such description must be included in the LEGAL
+ file described in Section 3.4 and must be included with all
+ distributions of the Source Code. Except to the extent prohibited by
+ statute or regulation, such description must be sufficiently detailed
+ for a recipient of ordinary skill to be able to understand it.
+
+5. Application of this License.
+
+ This License applies to code to which the Initial Developer has
+ attached the notice in Exhibit A, and to related Covered Code.
+
+7. DISCLAIMER OF WARRANTY.
+
+ COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN ``AS IS'' BASIS,
+ WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
+ WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF
+ DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING.
+ THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE
+ IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT,
+ YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE
+ COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER
+ OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF
+ ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.
+
+8. TERMINATION.
+
+ This License and the rights granted hereunder will terminate
+ automatically if You fail to comply with terms herein and fail to cure
+ such breach within 30 days of becoming aware of the breach. All
+ sublicenses to the Covered Code which are properly granted shall
+ survive any termination of this License. Provisions which, by their
+ nature, must remain in effect beyond the termination of this License
+ shall survive.
+
+9. LIMITATION OF LIABILITY.
+
+ UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT
+ (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL THE INITIAL
+ DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE,
+ OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO YOU OR ANY OTHER
+ PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
+ OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF
+ GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND
+ ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE
+ BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF
+ LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY
+ RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW
+ PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE
+ EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THAT
+ EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.
+
+10. U.S. GOVERNMENT END USERS.
+
+11. MISCELLANEOUS.
+
+ This License represents the complete agreement concerning subject
+ matter hereof. If any provision of this License is held to be
+ unenforceable, such provision shall be reformed only to the extent
+ necessary to make it enforceable. This License shall be governed by
+ California law provisions (except to the extent applicable law, if any,
+ provides otherwise), excluding its conflict-of-law provisions. With
+ respect to disputes in which at least one party is a citizen of, or an
+ entity chartered or registered to do business in, the United States of
+ America: (a) unless otherwise agreed in writing, all disputes relating
+ to this License (excepting any dispute relating to intellectual
+ property rights) shall be subject to final and binding arbitration,
+ with the losing party paying all costs of arbitration; (b) any
+ arbitration relating to this Agreement shall be held in Santa Clara
+ County, California, under the auspices of JAMS/EndDispute; and (c) any
+ litigation relating to this Agreement shall be subject to the
+ jurisdiction of the Federal Courts of the Northern District of
+ California, with venue lying in Santa Clara County, California, with
+ the losing party responsible for costs, including without limitation,
+ court costs and reasonable attorneys fees and expenses. The application
+ of the United Nations Convention on Contracts for the International
+ Sale of Goods is expressly excluded. Any law or regulation which
+ provides that the language of a contract shall be construed against the
+ drafter shall not apply to this License.
+
+12. RESPONSIBILITY FOR CLAIMS.
+
+ Except in cases where another Contributor has failed to comply with
+ Section 3.4, You are responsible for damages arising, directly or
+ indirectly, out of Your utilization of rights under this License, based
+ on the number of copies of Covered Code you made available, the
+ revenues you received from utilizing such rights, and other relevant
+ factors. You agree to work with affected parties to distribute
+ responsibility on an equitable basis.
+
+EXHIBIT A.
+
+ ``The contents of this file are subject to the BOINC Public License
+ Version 1.0 (the "License"); you may not use this file except in
+ compliance with the License. You may obtain a copy of the License at
+ http://boinc.berkeley.edu/license_1.0.txt
+
+ Software distributed under the License is distributed on an "AS IS"
+ basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the
+ License for the specific language governing rights and limitations
+ under the License.
+
+ The Original Code is ______________________________________.
+
+ The Initial Developer of the Original Code is ________________________.
+ Portions created by ______________________ are Copyright (C) ______
+ _______________________. All Rights Reserved.
+
+ Contributor(s): ______________________________________.''
diff --git a/perso/skel.ChangeLog b/perso/skel.ChangeLog
deleted file mode 100644
index 6e8362d3..00000000
--- a/perso/skel.ChangeLog
+++ /dev/null
@@ -1 +0,0 @@
-link /usr/portage/skel.ChangeLog \ No newline at end of file
diff --git a/perso/skel.ebuild b/perso/skel.ebuild
deleted file mode 100644
index 667f2b8e..00000000
--- a/perso/skel.ebuild
+++ /dev/null
@@ -1 +0,0 @@
-link /usr/portage/skel.ebuild \ No newline at end of file
diff --git a/perso/skel.metadata.xml b/perso/skel.metadata.xml
deleted file mode 100644
index 4ba27235..00000000
--- a/perso/skel.metadata.xml
+++ /dev/null
@@ -1 +0,0 @@
-link /usr/portage/skel.metadata.xml \ No newline at end of file