summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-06-03 20:19:04 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-06-03 20:19:04 +0100
commitb8d9a272e1b0fb31db3fef8583205d60475f48e0 (patch)
tree1cbdf7414a95af7effb1a602555c57dcb792b740
parentapp-crypt/bip32utils: add support for python3.9 (diff)
downloadportage-b8d9a272e1b0fb31db3fef8583205d60475f48e0.tar.xz
net-p2p/monero: fix build with dev-libs/boost-1.76
Package-Manager: Portage-3.0.18, Repoman-3.0.2
-rw-r--r--net-p2p/monero/files/monero-0.17.2.0-Fix-boost-1.76.0-compatibility.patch24
-rw-r--r--net-p2p/monero/monero-0.17.2.0.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-0.17.2.0-Fix-boost-1.76.0-compatibility.patch b/net-p2p/monero/files/monero-0.17.2.0-Fix-boost-1.76.0-compatibility.patch
new file mode 100644
index 00000000..b0fdd457
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.17.2.0-Fix-boost-1.76.0-compatibility.patch
@@ -0,0 +1,24 @@
+From 44cc6d67620ff09dc0173ad8e6ada89d700ffd3e Mon Sep 17 00:00:00 2001
+From: loqs <loqs@users.noreply.github.com>
+Date: Sun, 23 May 2021 20:29:17 +0100
+Subject: [PATCH] Fix boost 1.76.0 compatibility
+
+Add missing header boost/mpl/contains.hpp
+monero-project/monero/issues/7728
+---
+ contrib/epee/include/storages/portable_storage.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/contrib/epee/include/storages/portable_storage.h b/contrib/epee/include/storages/portable_storage.h
+index 655a2eb12cda..60f3e672fb55 100644
+--- a/contrib/epee/include/storages/portable_storage.h
++++ b/contrib/epee/include/storages/portable_storage.h
+@@ -31,6 +31,8 @@
+ #include "misc_log_ex.h"
+ #include "span.h"
+
++#include <boost/mpl/contains.hpp>
++
+ namespace epee
+ {
+ class byte_slice;
diff --git a/net-p2p/monero/monero-0.17.2.0.ebuild b/net-p2p/monero/monero-0.17.2.0.ebuild
index 92826abe..e8659887 100644
--- a/net-p2p/monero/monero-0.17.2.0.ebuild
+++ b/net-p2p/monero/monero-0.17.2.0.ebuild
@@ -71,6 +71,7 @@ PATCHES_MONERO=(
"${FILESDIR}/monero-${PV}-Do-not-install-trezor-dep-libs.patch"
"${FILESDIR}/monero-${PV}-Use-gentoo-dev-libs-randomx.patch"
"${FILESDIR}/monero-${PV}-translations-use-host-compiler.patch"
+ "${FILESDIR}/monero-${PV}-Fix-boost-1.76.0-compatibility.patch"
)
PATCHES_MONERO_GUI=(