summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-09-23 04:39:03 +0200
committerBertrand Jacquin <beber@meleeweb.net>2006-09-23 04:39:03 +0200
commitb213fb48f8622c87a1f9ef955b7755e398ede3be (patch)
treec080af9f987955af7e641462fc62d166c1311f52
parentBaa; patch was wrong, correted (diff)
downloadportage-b213fb48f8622c87a1f9ef955b7755e398ede3be.tar.xz
apache: New patch relese, alway header & footer (even if HEADER and FOOTER exist)
-rw-r--r--net-www/apache/Manifest8
-rw-r--r--net-www/apache/files/melee-index.diff31
2 files changed, 31 insertions, 8 deletions
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index 7e35c2b2..04401180 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,7 +1,7 @@
-AUX melee-index.diff 1014 RMD160 538fbcdcdc21f24d5c02d8d64e865fcb14d6f4d2 SHA1 af493b01d05f0d63e0d40d28c7ee5a7b77e71e07 SHA256 70bfc9e1d1459b73185aa96475d6c51a378260869ab009c68a96df172b0a1449
-MD5 6232ac94fab567272d4d1b72874dd38d files/melee-index.diff 1014
-RMD160 538fbcdcdc21f24d5c02d8d64e865fcb14d6f4d2 files/melee-index.diff 1014
-SHA256 70bfc9e1d1459b73185aa96475d6c51a378260869ab009c68a96df172b0a1449 files/melee-index.diff 1014
+AUX melee-index.diff 1760 RMD160 dd4bbcf7df8ae8b7e8c18fd3001e4713cd46c78e SHA1 f7f71b6973f7620172e67a75d2fde59c05ec2a4a SHA256 c984bb5e237ade14f82877931607c51b4a8cbf72f8a112d5e01fa17fb275e628
+MD5 8f8f4191d21bc50cfb272166be03d0d6 files/melee-index.diff 1760
+RMD160 dd4bbcf7df8ae8b7e8c18fd3001e4713cd46c78e files/melee-index.diff 1760
+SHA256 c984bb5e237ade14f82877931607c51b4a8cbf72f8a112d5e01fa17fb275e628 files/melee-index.diff 1760
DIST gentoo-apache-2.0.58-r2-20060726.tar.bz2 58758 RMD160 46c6da577db444a6553b60d3ae30c61ae3b741fa SHA1 5399c6076fbccc36b1d8a5ed783f77918c3398eb SHA256 b8e0356e87fdd7b55fcecbee804c9a41525b3e6fe8309f87f2509abd161c8e6b
DIST httpd-2.0.58.tar.bz2 4704318 RMD160 2ff44b2254552db908f1defd09e3142527f9bf83 SHA1 697e1674f8efbbe05b9f6c1ba00cd28a37293229 SHA256 4f746715c408f4cac48099ea72560c50ef190568dfcfa8e0762bae66c0398029
EBUILD apache-2.0.58-r2.ebuild 13861 RMD160 ba9818f212be7e4473c3cccb2ca2e928e50b0872 SHA1 bcce17ee3ed0244d59c74409a6a00d9c943e6567 SHA256 33c80e5e1d83debb7db9d20f34b1653de9f85b06ce60bbdb4e903bd4197c3ca0
diff --git a/net-www/apache/files/melee-index.diff b/net-www/apache/files/melee-index.diff
index 74e971c4..08a73112 100644
--- a/net-www/apache/files/melee-index.diff
+++ b/net-www/apache/files/melee-index.diff
@@ -1,8 +1,10 @@
---- modules/generators/mod_autoindex.c 2006-09-23 03:38:05.000000000 +0200
-+++ modules/generators/mod_autoindex.c 2006-09-23 03:40:36.000000000 +0200
-@@ -152,8 +152,10 @@
+--- modules/generators/mod_autoindex.c.old 2006-09-23 04:11:13.000000000 +0200
++++ modules/generators/mod_autoindex.c 2006-09-23 04:23:19.000000000 +0200
+@@ -151,9 +151,12 @@
+ */
static void emit_preamble(request_rec *r, int xhtml, const char *title)
{
++ /* Melee-Hack: Alway add the css for AutoIndexing */
ap_rvputs(r, xhtml ? DOCTYPE_XHTML_1_0T : DOCTYPE_HTML_3_2,
- "<html>\n <head>\n <title>Index of ", title,
- "</title>\n </head>\n <body>\n", NULL);
@@ -13,11 +15,32 @@
}
static void push_item(apr_array_header_t *arr, char *type, const char *to,
-@@ -1129,7 +1131,7 @@
+@@ -961,6 +964,9 @@
+ const char *r_accept;
+ const char *r_accept_enc;
+
++ /* Melee-Hack: Alway add the html preamble */
++ suppress_amble = 0;
++
+ /*
+ * If there's a header file, send a subrequest to look for it. If it's
+ * found and html do the subrequest, otherwise handle it
+@@ -1081,6 +1087,9 @@
+ int suppress_post = 0;
+ int suppress_sig = 0;
+
++ /* Melee-Hack: Always add the postamble */
++ suppress_amble = 0;
++
+ /*
+ * If there's a readme file, send a subrequest to look for it. If it's
+ * found and a text file, handle it -- otherwise fall through and
+@@ -1129,7 +1138,8 @@
ap_rputs(ap_psignature("", r), r);
}
if (!suppress_post) {
- ap_rputs("</body></html>\n", r);
++ /* Melee-Hack: Alway add the icons for AutoIndexing */
+ ap_rputs("<center><img src=\"/icons/linux.png\"></center></body></html>\n", r);
}
if (rr != NULL) {